Blinking Screen

I have done a fresh install on a new system, that I have never installed anything on before. After install, I notice that my screen is blinking quite frequently. In trying to figure out why that is, I have reduced the Refresh Rate to 60, seems not to do anything. Back to 165 Hz just to see if I notice anything diffrent. I have tried disabeling the compositor via shortcut key, and that seems to have helped a tiny bit. BUt as soon as I start a game it's like watching a stobe light.

I have searched the interwebs, and there seem to be people having luck changing the renderer in the compositor setting, but that option is not there anymore. So after making the compositor not load at all on boot the blikbing is just a problem when loading up a game, like Ark or Conan Exiles.

I would send a video, but that would make you ask me not to do that.

╭─[email protected] in ~ as 🧙 took 5s
╰─λ garuda-inxi 
System:
Kernel: 5.18.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=642f62dd-58af-4e5f-9bb3-bbc552753b57 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: MSI product: MS-7916 v: 1.0
serial: <superuser required>
Mobo: MSI model: Z97 GAMING 7 (MS-7916) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.12
date: 02/16/2016
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell
gen: core 4 built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4379 high: 4405 min/max: 800/4400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 4400 2: 4378 3: 4390
4: 4349 5: 4397 6: 4401 7: 4405 8: 4313 bogomips: 63995
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN 4
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: DP-2 empty: DP-1, DVI-D-1, HDMI-A-1, HDMI-A-2
bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: DP-2 mapped: DisplayPort-1 model: Samsung LS24AG32x
serial: <filter> built: 2021 res: 1920x1080 dpi: 93 gamma: 1.2
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 480 Graphics (polaris10 LLVM 13.0.1 DRM
3.46 5.18.6-zen1-1-zen)
v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
Device-1: Intel 9 Series Family HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 3-1:2 chip-ID: 1532:0514
bus-ID: 00:1b.0 class-ID: 0300 chip-ID: 8086:8ca0 class-ID: 0403
serial: <filter>
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-3: Razer USA Electra V2 USB type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.6-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: c000 bus-ID: 04:00.0 chip-ID: 1969:e091 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 2.52 TiB used: 379.26 GiB (14.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: PC401 HFS256GD9TNG-62A0A size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 80000E00 temp: 40.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DL001-9VT156
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5900 serial: <filter> rev: CC99 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: MZ7TE512HMHP-000L2
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 6L0Q
Partition:
ID-1: / raw-size: 238.17 GiB size: 715.11 GiB (300.25%)
used: 379.26 GiB (53.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 715.11 GiB (300.25%)
used: 379.26 GiB (53.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 715.11 GiB (300.25%)
used: 379.26 GiB (53.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 715.11 GiB (300.25%)
used: 379.26 GiB (53.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 715.2 MiB (4.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 868
Info:
Processes: 304 Uptime: 2h 9m wakeups: 11 Memory: 15.57 GiB
used: 3.68 GiB (23.6%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1944
lib: 548 Shell: fish v: 3.4.1 running-in: konsole inxi: 3.3.19
Garuda (2.6.4-1):
System install date:     2022-06-23
Last full system update: 2022-06-24 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

My advice might sound pretty dull and useless but it's easy and fast to try: you could play with tearing setting and other settings part of System Settings/Display and Monitor/Compositor.

I am not sure if disabling Compositor actually disables or do anything to the other settings on that screen.

Alternatively, try a different screen resolution, just in case.

SO I tried all the different settings on the compositor side. nothing different.

I will try a lower res, but I'm at 1080 right now, and I cant go higher.

I ended up installing garuda with gnome instead. Incase there was something in KDE that massed things up, and it seems like thats not it. Gnome seems better when just surfing the net or stuff like that. But as soon as I start ARK the blinking starts. Though I have had the thought if this is a Vulkan/Proton issue. But not convinced. Also there is something funny about the refresh rates the monitor goves me and the ones in display settings. Monitor says 165Hz, while display settings says 164,96.

Try to plug the monitor to another source (HDMI, a second DP or even DVI-D if it supports it).

You said it's a brand new system on which you haven't installed anything. How sure are you the monitor doesn't have a hardware failure?

2 Likes

I've tried all 4 outputs. Only thing missing iv DVI... Monitor works great with my sons system.

And I might have been bad at explaining. I ment I havent installed on these components before, they are all used, but I have not figured out all the clicks of the different stuff.

F.eks. I have never had a ATI card before. I chose that because it is rumored it is more linux friendly. My old Laptop had a nvidia card, and I had heaps of interresting moments gettign that to cooperate.

Taken as a whole, that's true.

If your monitor works on another system, at least you know it's not faulty.
You already tried Gnome + KDE and both show signs of blinking.
Maybe there's a settings required for your GPU or a kernel boot parm you could try? I can't help in that, I'm not good enough, would need to do all the googling and learn about monitor issues.

As a last advice, I could suggest to test a totally different distro (like Ubuntu, but of course I will never suggest Windows) and see if 100% of blinking is gone or not.
As another alternative, googling for your problem could potentially give you posts elsewhere of people with same issue. I would personally google cuz I don't know what else to test after Ubuntu.

The gurus of this forum probably have a few more easy things to test/check on your Garuda installation, if they read this.

I hope your problem gets fixed.

1 Like

As a fun thing to try I started CoreCtrl. Set the performance on the card to fixes, and high. as soon as I hit the save button screen starts flickering. so it seems to be related to the amount of load going on the card.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.