Blender stopped working

Please help!
I tried installing and uninstalling both from octopi and discover with no avail. I also tried restarting.
I downloaded it from the website and executing the launcher works just fine after unpaking.
I’m using a lenovo legion with nvidia graphics. A week ago blender was running just fine…

Needless to say im very new to linux systems but i believe i can manage to fix this with help.

Here is the crash report on tmp:

Blender 4.0.1, Commit date: 2023-11-16 16:40, Hash d0dd92834a08


# backtrace

/usr/bin/blender(+0xfd0683) [0x5650bad2d683]

/usr/bin/blender(+0x8ba21e) [0x5650ba61721e]

/usr/lib/libc.so.6(+0x3e710) [0x7f448c36f710]

/usr/lib/libLLVM-15.so(+0x17a7a0f) [0x7f4480fa7a0f]

/usr/lib/libLLVM-15.so(+0x17a7b98) [0x7f4480fa7b98]

/usr/lib/libLLVM-16.so(_ZN4llvm14FoldingSetBase19FindNodeOrInsertPosERKNS_16FoldingSetNodeIDERPvRKNS0_14FoldingSetInfoE+0xb6) [0x7f4497b278e6]

/usr/lib/libLLVM-16.so(_ZN4llvm12SelectionDAG19FindNodeOrInsertPosERKNS_16FoldingSetNodeIDERKNS_5SDLocERPv+0x36) [0x7f449869b1b6]

/usr/lib/libLLVM-16.so(_ZN4llvm12SelectionDAG7getNodeEjRKNS_5SDLocENS_8SDVTListENS_8ArrayRefINS_7SDValueEEENS_11SDNodeFlagsE+0x23d) [0x7f44986e79cd]

/usr/lib/libLLVM-16.so(+0x3a0e816) [0x7f449a80e816]

/usr/lib/libLLVM-16.so(_ZN4llvm16SelectionDAGISel14LowerArgumentsERKNS_8FunctionE+0xef3) [0x7f449868f453]

/usr/lib/libLLVM-16.so(_ZN4llvm16SelectionDAGISel20SelectAllBasicBlocksERKNS_8FunctionE+0x22dc) [0x7f449870632c]

/usr/lib/libLLVM-16.so(+0x19079b6) [0x7f44987079b6]

/usr/lib/libLLVM-16.so(+0x12ea945) [0x7f44980ea945]

/usr/lib/libLLVM-16.so(_ZN4llvm13FPPassManager13runOnFunctionERNS_8FunctionE+0x459) [0x7f4497dab989]

/usr/lib/libLLVM-16.so(+0x282aefa) [0x7f449962aefa]

/usr/lib/libLLVM-16.so(_ZN4llvm6legacy15PassManagerImpl3runERNS_6ModuleE+0x3ec) [0x7f4497dac6ac]

/usr/lib/dri/radeonsi_dri.so(+0x82f380) [0x7f443c42f380]

/usr/lib/dri/radeonsi_dri.so(+0x830009) [0x7f443c430009]

/usr/lib/dri/radeonsi_dri.so(+0x84fffc) [0x7f443c44fffc]

/usr/lib/dri/radeonsi_dri.so(+0x85c2cf) [0x7f443c45c2cf]

/usr/lib/dri/radeonsi_dri.so(+0x867c4d) [0x7f443c467c4d]

/usr/lib/dri/radeonsi_dri.so(+0xca51ee) [0x7f443c8a51ee]

/usr/lib/dri/radeonsi_dri.so(+0xcb5136) [0x7f443c8b5136]

/usr/lib/dri/radeonsi_dri.so(+0xbad593) [0x7f443c7ad593]

/usr/lib/dri/radeonsi_dri.so(+0xbc7239) [0x7f443c7c7239]

/usr/lib/dri/radeonsi_dri.so(+0x8a92dc) [0x7f443c4a92dc]

/usr/lib/dri/radeonsi_dri.so(+0x8b6fe2) [0x7f443c4b6fe2]

/usr/lib/dri/radeonsi_dri.so(+0x609487) [0x7f443c209487]

/usr/lib/dri/radeonsi_dri.so(+0x5e8219) [0x7f443c1e8219]

/usr/lib/dri/radeonsi_dri.so(+0x147f72a) [0x7f443d07f72a]

/usr/lib/dri/radeonsi_dri.so(+0x60b018) [0x7f443c20b018]

/usr/lib/dri/radeonsi_dri.so(+0x18753f) [0x7f443bd8753f]

/usr/lib/dri/radeonsi_dri.so(+0xbe454) [0x7f443bcbe454]

/usr/lib/libEGL_mesa.so.0(+0x2bf58) [0x7f446a694f58]

/usr/lib/libEGL_mesa.so.0(+0x1c328) [0x7f446a685328]

/usr/lib/libEGL_mesa.so.0(+0x1406d) [0x7f446a67d06d]

/usr/bin/blender(+0x2960744) [0x5650bc6bd744]

/usr/bin/blender(+0x295ef68) [0x5650bc6bbf68]

/usr/bin/blender(+0x293f759) [0x5650bc69c759]

/usr/bin/blender(+0x295d19b) [0x5650bc6ba19b]

/usr/bin/blender(+0x295a3d4) [0x5650bc6b73d4]

/usr/bin/blender(+0x293bca4) [0x5650bc698ca4]

/usr/bin/blender(+0x10167d2) [0x5650bad737d2]

/usr/bin/blender(+0x1016a1d) [0x5650bad73a1d]

/usr/bin/blender(+0xfe0454) [0x5650bad3d454]

/usr/bin/blender(+0xff62de) [0x5650bad532de]

/usr/bin/blender(+0xffb9f4) [0x5650bad589f4]

/usr/bin/blender(+0x88d681) [0x5650ba5ea681]

/usr/lib/libc.so.6(+0x27cd0) [0x7f448c358cd0]

/usr/lib/libc.so.6(__libc_start_main+0x8a) [0x7f448c358d8a]

/usr/bin/blender(+0x8b5e05) [0x5650ba612e05]


# Python backtrace

why wont it work if I install it from the package managers?

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:

garuda-inxi

Refusing to post the output of the required “garuda-inxi” on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki’s, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum’s search engine and on the web. For in depth information on how to search for answers to Linux issues effectively read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.

4 Likes

Probably this upstream bug:

4 Likes

thanks a lot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.