Blackscreen after switching to dedicated Amd gpu

After i attempted to switch from my integrated gpu to my dedicated amd gpu im now having the problem that i get a blackscreen after grub.
Grub works fine and live garuda from usb stick also works. While troubleshooting i also had multiple occcasions where it worked again until i loged out and in again. I still can use the pc through ssh so only the display isnt working.

Using the command "xrandr --listproviders" outputs: "Can't open display"

Though bot drivers are running and both gpus apapters are detected
I tried to switch back to integrated gpu mode but im not sure how to do that since i cant find related topics on google.

Edit: Restoring an snapshot works until the next log-out log-in only but it gives me temporaly access to the display

How did you "switch" to your dedication AMD GPU? If you used Optimus manager i would highly highly recommend you get rid of it.

Get rid of Optimus manager and use your AMD card by starting a program with this env variable: DRI_PRIME=1

Yes i did actually used optimus until i figured out that it wont work with amd cards. I removed it now but i still get an blackscreen on boot. If i however press e inside grub and then remove "quiet splash" the line that starts with "linux" everything will work again.

Edit: I now created a second grub config which basically doesnt has the "quite splash" part anymore and that kinda fixed the problem. Altough i dont really believe that this is a proper solution it works for now

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.