Blackscreen after BIOS update i am quite frustrated right now.


CPU: AMD Ryzen 7 5800X3D
MoBo: ROG Strix X570-i Gaming
GPU: RTX3070

I have Garuda installed on a NVME Drive, worked perfectly fine. Then i got myself a new CPU (7 5800X3D) before that i had a Ryzen 5 2600X. Installed the new hardware, booted, worked nice...Then i had some weird errors where some Games randomly wouldn'd start...i thought to myself i should maybe also update the BIOS because the current install is quite old.

So i did that, now my system doesn't boot. I can see Grub, and when i boot it stays on Loading initial Ramdisk for a couple minutes, and then goes into a blackscreen. Other TTYs aren't possible to reach...

Now when i put in a USB Drive with any other Distro, i get various errors....sometimes a kernelpanic, sometimes the same black screen as with my current install.

Any tips?...i'm desperate.

Me too ^^

1 Like

yup, nothing worked...i searched the forums...Scrambled arch wiki aswell.

tried three different sticks, 2 different ISOs, installed 2 different BIOS versions

Live ISO, chroot, dkms-autoinstall, repair grub, garuda-update.

1 Like

as i said, i cant even access live ISOs.

either kernel panic, or the same black screen. Tried a fresh, verfied Garuda KDE ISO. Tried Archcraft, tried Fedora.

On different sticks, tested them on my laptop, can boot perfectly fine from them.

I definetely see that this isn't garudas problem. I just hoped that anyone could help me out here bcs i know there are quite a few very very tech savvy ppl here that might help me get on the right tracks.

I think you should also search and possibly ask in the official Asus support sites.

Maybe (just e.g.):
Possibly also their forum (but I see it is currently in maintenance). Again, only for example:


That's crazy.
Disconnect the PC completely from power, i.e. remove the power cable, switch off the power supply, hold down the start button for 20 seconds, remove the memory battery, wait, put it back in, connect the power, reset the BIOS, set the date-time in the BIOS, switch on.

Cross your fingers.


crazy indeed...already resetted CMOS, did the powerreset thing already aswell.

Interestingly enough, when i go into grub edit and remove quiet splash, after the several minutes of initial ramdisk, i get "setfont: KDFONTOP: Function not implemented"

And that's it...When i try to access TTY2 from there, my display simply turns off and says there is no signal

holy works again.

I just went through every single entry in the bios, one by one, and remembered i had to manually set PCIE to gen3 for whatever stupid reason. Ofc with the BIOS Update this went to "auto" again.

Completely forgot about that.

Well, sorry for annoying...


Wow, lucky that you remembered this. It's also indicative of another issue, running at the wrong link speed! Take a look at garuda-inxi and find Graphics result, it should say: pcie: gen: 4 speed: 16 GT/s lanes: 16, anything else is suboptimal. Carefully remove the GPU, ensure no dust is in the slot with a compressed air, and put back. Then you know where to set back to Gen4 to test.

Don't be sorry for asking about help, most especially for a unique issue. This will help someone else in the future too :slight_smile:


Yeah so i did that...i mean the mainboard is brand new, cpu is brand new, ram is brand new, the only "old" piece was the GPU... i made sure everything sits correctly and is dust free.

And yet, when i tell my mainboard to either automatically configure the pcie gen or manually to gen 4, it doesn't boot....

And yeah in my garuda-inxi it says pcie: gen: 3 speed: 8 GT/s and says it's maximum could be gen 4....

No clue what's missing here...

EDIT: yeah i now know what the issue's not my bios config or anything...i have a SFF case that utilizes a GPU Riser cable to mount my GPU only supports PCIE 3...that's why it won't work.

Case solved, closed and hopefully buried. Thank you all for your time and i wish you wonderful christmas days and a happy new year!


I marked the solution :slight_smile:

1 Like

the comment i marked was the correct solution though. This is just the reasoning behind WHY that other solution was even necessary^^

This above reasoning gives a more complete answer, and I feel anyone coming to this should notice that post first; so I think it makes sense to have it as a solution. You can get a gen 4 riser cheap enough, luckily. Glad you got to the bottom of it!

For anyone else using a riser: always suspect it

1 Like

Ups, you can change it to the right one :slight_smile:

@Technetium + @RandomLegend

@SGS I'm not a mod and cannot change such things :stuck_out_tongue:

1 Like

There are always people here who solve their problem themselves and mark it. :smiley:

Hamburger menu and

On EnOS I think it is only allowed by OP and mod/admin.

Give it a try :slight_smile:


Either i forgot, or i already had the correct solution marked as such.

Nonetheless, thanks again for your help, and i wish you all the best :slight_smile: Enjoy the holidays!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.