BlackMagic DeckLink on Linux-Zen

Hi all,

I was wondering if anyone has been able to get BlackMagic DeckLink capture cards working with the Linuz-Zen kernel?

The card is picked up

lspci | grep Blackmagic
04:00.0 Multimedia video controller: Blackmagic Design DeckLink Quad HDMI Recorder

The driver service, desktopvideohelper.service from the decklink driver and decklink-SDK from the AURs appear to be enabled and running

sudo systemctl status  DesktopVideoHelper.service
[sudo] password for thedarthtux:
● DesktopVideoHelper.service - DesktopVideo helper daemon
Loaded: loaded (/usr/lib/systemd/system/DesktopVideoHelper.service; enabled; preset: disabled)
Active: active (running) since Sat 2023-01-21 19:53:47 EST; 43min ago
Main PID: 1330 (DesktopVideoHel)
Tasks: 3 (limit: 76938)
Memory: 10.5M
CPU: 5ms
CGroup: /system.slice/DesktopVideoHelper.service
└─1330 /usr/lib/blackmagic/DesktopVideo/DesktopVideoHelper -n

Jan 21 19:53:47 Scar-2-0 systemd[1]: Started DesktopVideo helper daemon.
Jan 21 19:53:47 Scar-2-0 DesktopVideoHelper[1330]: Start
Jan 21 19:53:47 Scar-2-0 DesktopVideoHelper[1330]: Listening for DesktopVideo settings changes

But for whatever reason, the card is not detected. However, in the Linux-LTS kernel (which is still at version 5.15 vs Linux-Zen 6.1.7) the card is detected perfectly fine.

I don't know if there is anything I could do to get the card detected in linux-zen or if I just have to keep switching between kernels and wait for the maybe a driver update or a zen kernel that supports the card again.

My garuda-inxi if it helps in anyway

λ garuda-inxi
System:
Kernel: 6.1.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9e7734ad-4c3a-4599-bf16-6f73c8b1b2b7 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS MASTER v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS MASTER serial: <superuser required>
UEFI: American Megatrends LLC. v: F36e date: 05/12/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Craft Advanced Keyboard
serial: <filter> charge: 10% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3622 high: 4280 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3596 2: 3500
3: 3500 4: 3500 5: 3500 6: 4092 7: 3500 8: 3500 9: 4280 10: 3994 11: 3500
12: 3500 13: 3500 14: 3788 15: 3500 16: 3763 17: 3500 18: 3500 19: 3500
20: 3500 21: 3500 22: 3500 23: 3500 24: 3500 25: 3850 26: 3500 27: 3500
28: 3500 29: 3500 30: 3606 31: 4278 32: 3663 bogomips: 224006
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: Blackmagic Design DeckLink Quad HDMI Recorder driver: N/A pcie:
gen: 3 speed: 8 GT/s lanes: 4 link-max: lanes: 8 bus-ID: 04:00.0
chip-ID: bdbd:a14e class-ID: 0400
Device-2: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Sapphire
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 0d:00.0 chip-ID: 1002:73bf
class-ID: 0300
Display: wayland server: X.org v: 1.21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 3840x2160 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon RX 6900 XT (navi21
LLVM 15.0.7 DRM 3.49 6.1.7-zen1-1-zen) direct render: Yes
Audio:
Device-1: Blackmagic Design DeckLink Quad HDMI Recorder driver: N/A pcie:
gen: 3 bus-ID: 3-6.3:4 speed: 8 GT/s chip-ID: b58e:9e84 class-ID: 0300
lanes: 4 link-max: serial: <filter> lanes: 8 bus-ID: 04:00.0
chip-ID: bdbd:a14e class-ID: 0400
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-4: Blue Microphones Yeti Stereo Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.7-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: JACK v: 1.9.21 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp5s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-3: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 07:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: ztksetuwxp state: unknown speed: 10 Mbps duplex: full
mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-5:2
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 23.03 TiB used: 4.68 TiB (20.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T1XHE-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 614600WD temp: 48.9 C
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 010 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000MX500SSD1
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 010
ID-4: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT1000MX500SSD1
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 010
ID-5: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 860 QVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q
ID-6: /dev/sde maj-min: 8:64 type: USB vendor: Western Digital
model: WD80EDBZ-11B0ZA0 size: 7.28 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 7200 serial: <filter> rev: 1031 scheme: GPT
ID-7: /dev/sdf maj-min: 8:80 type: USB vendor: Western Digital
model: WD20SDZW-11JJ8S0 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B type: HDD rpm: 5400 serial: <filter> rev: 1021 scheme: GPT
ID-8: /dev/sdg maj-min: 8:96 type: USB vendor: Western Digital
model: WD80EMZZ-11B4FB0 size: 7.28 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 5640 serial: <filter> rev: 1031 scheme: GPT
ID-9: /dev/sdh maj-min: 8:112 type: USB vendor: Seagate
model: ST332082 0AS ST3320820A size: 298.09 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 1.23 TiB (67.5%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%)
used: 594 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.23 TiB (67.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.23 TiB (67.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.23 TiB (67.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.72 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.1 C mobo: N/A gpu: amdgpu temp: 55.0 C
mem: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 569
Info:
Processes: 611 Uptime: 1h 3m wakeups: 4 Memory: 62.72 GiB
used: 6.54 GiB (10.4%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 alt: 11 clang: 15.0.7 Packages:
pm: pacman pkgs: 2915 libs: 753 tools: gnome-software,octopi,pamac,paru
pm: flatpak pkgs: 0 Shell: fish v: 3.6.0 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2021-06-08
Last full system update: 2023-01-21
Is partially upgraded:   No
Relevant software:       timeshift NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Failed units: