Blackarch.db failed to download, while updating the system

Hi there. I am a newbie in Garuda Linux Community. I recently installed the OS and tried to to update the system via Setup-Assistant. I am encountering the same problem again and again in the "[email protected]", that 'blackarch.db failed to download', and the system doesn't get updated thereafter. Can anybody tell me how to fix this? I have Garuda KDE Dr460nized Edition.

Hi there, welcome!
Please provide more precise teminal information as text.
Anyway, looks similar to this one:

Although not yet solved, please try:
sudo micro /etc/pacman.d/blackarch-mirrorlist
comment the line with mirrors.fossho.st (I assume this is appearing in your error), save & exit and try again.
Edit: the proposed solution has just been confirmed as working in the other thread.

4 Likes

I am really sorry. But I didn't quite get your steps. I copy-pasted the line:

sudo micro /etc/pacman.d/blackarch-mirrorlist

in the Konsole, and then its showing a long list of different countries with their servers. Can you please explain a little more in detail? :slight_smile:

btw, here is the full terminal info:

:: Synchronizing package databases...
core 134.1 KiB 15.2 KiB/s 00:09 [--------------------------------] 100%
extra 1565.6 KiB 49.4 KiB/s 00:32 [--------------------------------] 100%
community 5.6 MiB 105 KiB/s 00:54 [--------------------------------] 100%
multilib 149.7 KiB 22.1 KiB/s 00:07 [--------------------------------] 100%
chaotic-aur 1244.1 KiB 27.9 KiB/s 00:45 [--------------------------------] 100%
blackarch.db failed to download
error: failed retrieving file 'blackarch.db' from mirrors.fossho.st : The requested URL returned error: 503
error: failed to synchronize all databases (failed to retrieve some files)
Press enter to continue

You should find the server I mentioned above and add a # before.
Also give a look to the list and make sure that other servers are without the #

1 Like

:slight_smile: ......

Spoonfeeding ? :wink:

3 Likes

Someone who thinks he has to use blackarch should know how to do it.

My 0,02 $

3 Likes

Check the last post in the linked thread.
It is very clear...

2 Likes