Black screen with mouse cursor after logging in

After I connected a second monitor which I had configured previously I got some issues as dock and menubar was not showing properly, so I did kwin_x11 --replace and then plasmashell --replace hoping to restart kwin. Everything went downhill from there...

This didn't help so I rebooted without the second screen connected. Now after logging in, I keep getting a black screen with just a mouse cursor (I can get a tty terminal and work from there, ctrl+alt+f2, etc...) but can't get the plasma/kde working.

Tried many things but nothing, including what you guys suggested in another post (systemctl stop sddm and systemctl start sddm with sudo pacman -Syyu), but nothing.

If I log in to a guest user, everything works fine though.

I tried other thing mentioned in the community such as removing .local/share and .config, etc., but nothing. Finally, if I try to kstart5 plasmashell, I get that "Could not load Qt platform plugin "xcb" "" even though it was found" message. I reinstall qt5 and libxcb but nothing, still get a black screen when logging in to my main user (again, the guest user works fine).

This is driving me crazy, please help me out :pray:t2:

I'm running the dra460nized editon in an iMac late 2013, dual boot with MacOS.

Hi,
Choosing snap from boot menu doesn't change anything,
except you can boot to your system.
You have to open timeshift and restore your system there.

1 Like

unfortunately, the oldest timeshift restore available was after the issue happened, so that didn't solve the issue.

This a very strong move that should probably solve your problem. After these are deleted (you could have just renamed them, keeping them as backup :man_shrugging: ) you just go to sddm and login.

This is latte-dock crashed probably.
You could have checked if it was running and restart it with clean start (with a restarted kwin

killall latte-dock
kwin_x11 --replace
latte-dock --cc -r --default-layout

To save yourself of unnecessary loss you could/can rename latte-dock configs

mv $HOME/.config/lattedockrc $HOME/.config/lattedockrc.old
mv $HOME/.config/latte $HOME/.config/latte.old
3 Likes

Unfortunately this didn't help. I renamed those directories and rebooted, but still I get a black screen with mouse cursor after logging in to the main user.

Why not try creating a new user account.

Sure, that would be an option, but I have already configured that user account quite a bit, so not sure if I can transfer that config to a new user account. Second, if the problem happens again, I don't want to keep creating new user accounts later on, so would like to have a solution to this issue so I can reliably use Garuda as my main system.

Test it first. You could try selectively replacing configuration files and hopefully identify and avoid the issue on a replacement account. Your other option is to simply keep searching till you hopefully find a fix.

4 Likes

Yes, I think I will keep searching for awhile, as I don't find it feasible to create a new user account every time something like that happens.

1 Like

The issue you are experiencing may not be so easy to eradicate if you are unable to return to a snapshot before the issue arose. In my experience, sometimes this type of problem just isn't so easy to get unstuck once it's stuck. That's why I made the suggestion I did.

Good luck

1 Like

Thanks, I see your point. I guess I will have to do that as nothing else is working, and make sure to do a system update to get a snapshot regularly.

Does this issue tend to happen more often in KDE as opposed to Gnome, for example?

I'm not a Gnome user and never have been, so I really couldn't say.

Good luck.

This has nothing to do with your issue. Snapshots save system configuration.
Your issue lies inside your $HOME folder, after some changes you have made.

If renaming .config or latte did not solve it, then check inside your dot files.
And study a bit. It is not a deadly habit.
https://wiki.archlinux.org/index.php/Xinit
systemd/Journal - ArchWiki

1 Like

Timeshift also gives you the option of backing up your .dot files in $HOME (if you so choose). I usually enable this option as I think it is a good idea to have you personal config files backed up as well. Just a personal preference that I usually choose.

2 Likes

I don't understand your comment. That's exactly what I'm trying to do to find a solution instead of going ahead and create a fresh new user account.

1 Like

I checked pretty much every dotfile (renaming them and booting up again) but the problem persists. Cleared the journal as well as suggested in one of the links and copied xinitrc from the original, but nothing. Still a black screen. It doesn't seem that the problem is in my home directory but rather in some other file buried somewhere (and since I'm a Linux newbie, don't know where else to look). I'm giving up on this and will probably end up creating a new user, and pray that the issue will not come up again later on.

I don't think clearing the journal can help in troubleshooting. I would say the opposite.
You should check journal for useful messages, that can show you what the real problem is.
In the link for journal (and in man journalctl) there are examples of filtering journal log.

3 Likes

Great, will check that out!