Black screen with frozen cursor after wake up from sleep/hibernation

Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=38a681ac-45de-4303-bcc2-f73c06b02750 rw rootflags=subvol=@
quiet resume=UUID=95bba0d7-f700-4714-bb64-edb79c0261c6 loglevel=3
mem_sleep_default=s2idle ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Predator PH315-51 v: V1.26
serial: <superuser required>
Mobo: CFL model: Sienta_CFS v: V1.26 serial: <superuser required>
UEFI: Insyde v: 1.26 date: 03/27/2019
ID-1: BAT1 charge: 35.9 Wh (99.7%) condition: 36.0/48.9 Wh (73.6%)
volts: 16.6 min: 15.2 model: LG PABAS0241231 type: Li-ion serial: <filter>
status: not charging
Info: model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 875 high: 901 min/max: 800/4000 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 900 3: 900 4: 900
5: 900 6: 901 7: 900 8: 800 bogomips: 36799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 545.29.06
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x process: TSMC 16nm
built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s ports: active: none empty: HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:1c20 class-ID: 0300
Device-3: Quanta HD Webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:5 chip-ID: 0408:a060
class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: eDP-1 res: 1536x864 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) device-ID: 8086:3e9b memory: 15.1 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 8 device: 0 type: integrated-gpu name: Intel
UHD Graphics 630 (CFL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:3e9b surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce GTX 1060 driver: nvidia
v: 545.29.06 device-ID: 10de:1c20 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: speed: Unknown lanes: 63 link-max:
gen: 6 speed: 64 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-3: DCMT USB Condenser Microphone
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-3:3 chip-ID: 31b2:0011 class-ID: 0300
serial: <filter>
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.85 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.1 chip-ID: 10ec:8168
class-ID: 0200
IF: enp7s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:6
chip-ID: 8087:0aaa class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 1.59 TiB used: 63.28 GiB (3.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 2B2QEXM7 temp: 40.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD7500BPVT-22HXZT3 size: 698.64 GiB block-size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 1A01 scheme: GPT
ID-1: / raw-size: 681.33 GiB size: 681.33 GiB (100.00%)
used: 63.28 GiB (9.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 884 KiB (0.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 681.33 GiB size: 681.33 GiB (100.00%)
used: 63.28 GiB (9.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 681.33 GiB size: 681.33 GiB (100.00%)
used: 63.28 GiB (9.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 681.33 GiB size: 681.33 GiB (100.00%)
used: 63.28 GiB (9.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.46 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.01 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 45.0 C pch: 58.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 269 Uptime: 20m wakeups: 0 Memory: total: 16 GiB
available: 15.46 GiB used: 3.72 GiB (24.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1415 libs: 459 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-25
Last full system update: 2023-11-25
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

I recently installed Garuda on an Acer Predator Laptop: I5 8300h, 16 RAM, GTX 1060 and everything works fine except that every time I close the lid of the laptop the fans never stop completely and when I open it back up the screen is black with just the mouse which is frozen.

Check in the BIOS for any settings related to power management. Disable them one at a time to see if you can find one which is causing the issue.


The only relevant settings seemed to be Fast Boot and Lid Open Resume both of which I have tried disabling and the same thing keeps happening.

You don’t have settings related to ASPM or sleep state?

The next thing to try would be to install the LTS kernel and test resuming from suspend with that.

And then make sure your bios is up to date. The two most important factors in most suspend issues is the kernel and the bios.

If you are not using your wifi and the bios allows it, try disabling your wifi.

Welcome to the Garuda community. :wave:

Those are the only settings available in BIOS.

Same thing happend with the LTS kernel and the BIOS was up-to-date.

Because the installation wasn’t even a couple days old I made a fresh one but this time I choose not to have a swap partiton and the issue seems to be fixed. Although I don’t really know if not choosing swap is what fixed or not.

The last pic , secure boot is in custom so try to disable it

If I remember right, the actual switch to turn off secure boot is in the boot tab

I don’t think secure boot is the issue since the installation succeeded and they are able to boot normally.

Did you try the WiFi thing TBG mentioned?

Don’t really have an option to disable WiFi on the BIOS and I do have Secure Boot disabled. The issue came back on the new install apparently out of no where. It had been waking up correctly until right now, but I haven’t done anything in particular that could have triggered it to come back.

Just an idea: assuming the WiFi has anything to do with the problem, does it still happen if you disable it before sleep/hybernation with rfkill ?

Have you tried logging in with an X session?


I don’t know what that is sorry

At your login screen there is a drop down box where you can choose your session type.

In your UEFI:
Main -> Lid Open Resume -> Enabled
Main -> Fast Boot -> Disabled
Security -> Secure Boot Mode -> leave it on Custom
Boot -> Secure Boot -> Disabled

System Settings -> Power Management -> Energy Saving -> Buttons events handling -> When laptop lid closed
choose an option - apply, close, reboot and test again.

Try an x11 session like @tbg suggested.

(My daily driver is an “Acer Aspire Nitro Black Edition” with garuda-dr460nized. But power management is always deactivated for me. When I have time I’ll test it.)

Edit: typo

So I tried and X11 session and the same thing still happened so I tried switching to the LTS kernel again even though the last time I tried it didn’t help but this time it did. I made sure by going back and forth between LTS and ZEN and on LTS it did wake up everytime and on ZEN it got stuck on the same black screen everytime.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.