Black screen on laptop but it works on external monitor

Hello, it's my first time posting here, let me know if there is something else I need to help you help me.

What happened ?

I upgraded to Spotted Eagle

Exepected Behaviour

Well, have my machine working as usual and for every other update I haven't had any problem.

Unexpected Behavior

After rebooting the system

  • I have an encrypted disk, so I entered the password,
  • Then it took me to Grub menu and hit enter.
  • When transitioning to the login screen is where the laptop screen turns black and I cannot see anything.

Stuff I tried so far

  • I connected an external monitor and it works, but not the laptop screen.
  • I normally use Xrandr to do configs for my monitor, to discard that xrandr was the issue I tried Arandr and it didn't worked
  • I try using different kernels and didn't work
    • 5.12.2-zen2-1-zen
    • 5.12.2-153 linux-tkg-bmp

Thank you for the help, I leave my inxi -Fxxxza output

inxi -Fxxxza 
System:    Kernel: 5.12.2-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=72071089-d419-485a-9a2f-14e721d62e38 rw 
           [email protected] quiet 
           cryptdevice=UUID=b29157b9-880f-47d4-9db6-d45198405171:luks-b29157b9-880f-47d4-9db6-d45198405171 
           root=/dev/mapper/luks-b29157b9-880f-47d4-9db6-d45198405171 splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: i3 4.19.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Precision 5540 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Dell model: 03G9D9 v: A00 serial: <filter> UEFI: Dell v: 1.3.3 date: 09/25/2019 
Battery:   ID-1: BAT0 charge: 49.3 Wh (100.0%) condition: 49.3/56.0 Wh (88.1%) volts: 12.7 min: 11.4 
           model: BYD DELL CP6DF9A type: Li-poly serial: <filter> status: Full 
CPU:       Info: 6-Core model: Intel Core i7-9850H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: D (13) microcode: DE cache: L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399 
           Speed: 4032 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4032 2: 4380 3: 4460 4: 4489 5: 4411 
           6: 4458 7: 4009 8: 4258 9: 4301 10: 4302 11: 4302 12: 4291 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort mitigation: TSX disabled 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:3e9b class-ID: 0300 
           Device-2: NVIDIA TU117GLM [Quadro T1000 Mobile] vendor: Dell driver: N/A alternate: nouveau 
           bus-ID: 01:00.0 chip-ID: 10de:1fb9 class-ID: 0302 
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-12:6 chip-ID: 0c45:6723 
           class-ID: 0e02 
           Display: x11 server: X.Org 1.20.11 compositor: picom v: git-dac85 driver: loaded: modesetting 
           alternate: fbdev,intel,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") s-diag: 581mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           Monitor-2: DP-1 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.0 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.2-zen2-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.27 running: yes 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 3000 bus-ID: 3b:00.0 
           chip-ID: 8086:2526 class-ID: 0280 
           IF: wlp59s0 state: up mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 4-1.2:3 
           chip-ID: 0bda:8153 class-ID: 0000 serial: <filter> 
           IF: enp58s0u1u2 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 
           chip-ID: 8087:0025 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no 
           software: no address: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 32.7 GiB (6.9%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200S NVMe 512GB size: 476.94 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 22001030 
           scheme: GPT 
Partition: ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 32.7 GiB (6.9%) fs: btrfs dev: /dev/dm-0 
           maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 708 KiB (0.2%) fs: vfat 
           dev: /dev/nvme0n1p1 maj-min: 259:1 
           ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 32.7 GiB (6.9%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171 
           ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 32.7 GiB (6.9%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171 
           ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 32.7 GiB (6.9%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
           ID-9: swap-9 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram8 
           ID-10: swap-10 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9 
           ID-11: swap-11 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10 
           ID-12: swap-12 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4872 fan-2: 4866 
Info:      Processes: 369 Uptime: 43m wakeups: 3 Memory: 30.97 GiB used: 6.03 GiB (19.5%) Init: systemd v: 248 
           target: graphical.target tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 1275 lib: 296 
           Shell: Zsh v: 5.8 running-in: terminator inxi: 3.3.04

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Try to check *bios updates for your system . Sometimes bios is able to fix this.

2 Likes

Try

xrandr --prop | grep -w connected
HDMI-0 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 596mm x 335mm

and
:slight_smile:

Display: x11 server: X.Org 1.20.11 compositor: picom v: git-dac85 driver: loaded: modesetting 
           alternate: fbdev,intel,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") s-diag: 581mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           Monitor-2: DP-1 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:3e9b class-ID: 0300 
           Device-2: NVIDIA TU117GLM [Quadro T1000 Mobile] vendor: Dell driver: N/A alternate: nouveau 

There is something with change between nvidia and intel GPU.

I don't know anything about that. :frowning:

2 Likes

There is a known issue with upgrading to the kernel 5.12.1 in arch Blackscreen after update to Kernel 5.12.1 / Kernel & Hardware / Arch Linux Forums

I downgraded to 5.10.36-1-lts and it worked.

Thank you for your help

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.