Black screen on first boot after installation

Hello all,

I’ve just downloaded the KDE Ultimate version of Garuda Linux.
I’ve bought a new SSD just for this purpose. So I’ve installed everything on the new SSD.

My config is a Ryzen 7 3800X paired with 32Gigs of RAM and a RTX 2080 connected to a LG C9 OLED TV which runs on 120Hz (1440p)
The installation went just fine and everything worked very well in the live system.
After I click on reboot at the end of the installation, it shows me GRUB just fine, then eventually showed me the cursor right before the logon screen and then my TV turned into the “no signal” mode.

Any ideas?

Thanks in advance for your help!

Pascal (MacGyver)

Welcome :slight_smile:

Could you post from live system the output from konsole

inxi -Fxxxza

BIOS is new / up to date?

1 Like

Can you try ctrl + alt +f2

To see if you get to tty

I have seen this kind of problem before where you get no signal for the monitor and that pc was nvidia

The things you can try are

Reconnect the hdmi cable to get the connection again.

Go into bios and check if you have some settings about graphics card.


Created a pastebin for the output…
Looks like I’m not able to format it right :stuck_out_tongue:

System:    Kernel: 5.8.5-zen1-1-zen x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=de tz=Europe/Berlin 
           driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1 misobasedir=garuda 
           misolabel=GARUDA_KDE_ROLLING_ULTIMATE quiet systemd.show_status=1 splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 apparmor=1 security=apparmor 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 1201 date: 09/09/2019 
CPU:       Info: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
           model-id: 71 (113) stepping: N/A microcode: 8701013 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 124567 
           Speed: 3572 MHz min/max: 2200/3900 MHz boost: enabled Core speeds (MHz): 1: 3572 2: 3697 
           3: 3590 4: 4349 5: 3663 6: 3615 7: 3894 8: 4246 9: 3688 10: 3656 11: 4343 12: 3615 13: 4428 
           14: 3620 15: 3586 16: 3969 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: always-on, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 Rev. A] vendor: Micro-Star MSI driver: nvidia 
           v: 450.66 alternate: nouveau,nvidia_drm bus ID: 0a:00.0 chip ID: 10de:1e87 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 2560x1440 s-dpi: 60 s-size: 1083x609mm (42.6x24.0") 
           s-diag: 1242mm (48.9") 
           Monitor-1: HDMI-0 res: 2560x1440 hz: 120 dpi: 41 size: 1600x900mm (63.0x35.4") 
           diag: 1836mm (72.3") 
           OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 direct render: Yes 
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 0a:00.1 chip ID: 10de:10f8 
           Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.4 chip ID: 1022:1487 
           Device-3: C-Media Anua Mic CM 900 type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 1-1:2 chip ID: 0d8c:0134 
           Device-4: Texas Instruments SMSL M-3 Desktop DAC type: USB driver: snd-usb-audio 
           bus ID: 7-1:2 chip ID: 0451:0003 serial: <filter> 
           Sound Server: ALSA v: k5.8.5-zen1-1-zen 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 05:00.0 chip ID: 8086:2723 
           IF: wlp5s0 state: down mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k port: f000 
           bus ID: 06:00.0 chip ID: 8086:1539 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.39 TiB used: 847.5 MiB (0.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 3B7QCXE7 
           scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: S5Z42105 
           scheme: GPT 
           ID-3: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 020 scheme: GPT 
           ID-4: /dev/sdb type: USB vendor: Corsair model: Voyager GT 3.0 size: 29.50 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 000A scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: N/A size: 23.50 GiB used: 847.5 MiB (3.5%) fs: overlay source: ERR-102 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 54.1 C mobo: N/A gpu: nvidia temp: 32 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 17% 
Info:      Processes: 352 Uptime: 5m Memory: 31.33 GiB used: 2.51 GiB (8.0%) Init: systemd v: 246 
           Compilers: gcc: 10.2.0 Packages: pacman: 1901 lib: 555 flatpak: 0 Shell: Zsh v: 5.8 
           running in: konsole inxi: 3.1.06

If you can get into a tty then login and try running “startx” or “startkde”.

1 Like

Just tried that now. I was indeed able to get tty.
Login was also possible in command line.
Then tried "startkde" which failed in a "no such file or directory"-error.
Then tried "startx" and got some messages. Took a photo of it, hopefully it's readable:


Give us output of

mhwd -li

From tty

1 Like

Here you go :slight_smile:

1 Like

Try this

systemctl stop sddm


systemctl start sddm

Ok this worked.
Came to the X Login screen and logged myself on and came to the desktop.
It's now updating some wine configs and guess first setup...

EDIT: It's kinda hanging there... Start menu is working but almost nothing else...


After that it should work fine


ok will do! :slight_smile:
Will update this in a minute!

EDIT: Unfortunately I got the “no signal”-behavior again.
Change to tty still possible like before :frowning:


Hmm you can try to update the system

sudo pacman -Syyu

Then see if the problem persists


Sure… will do that :slight_smile:

Update 1: Yikes… 1.3GB Total Download Size :stuck_out_tongue:

sudo reflector --country Germany --latest 15 --age 2 --fastest 20 --protocol https --sort rate --save /etc/pacman.d/mirrorlist

Got that too late lol
but it’s downloading almost at fullspeed…
I will do a reboot after that and see what I come up with!

EDIT: YIKES!!! It works… it just booted normally and about 4x faster than before…
For some reason I did not get any transparency effects… but I will click myself trough all the settings to see if I can fix it!

Guess the solution for now was really jumping into tty and do a full upgrade…


Ok guess the issue is now completely solved…
System works like a charm now and transparency is also working.
Just had to restart the compositor

Thanks to all of you for the (really) quick help!


I am trying to setup Garuda linux on Hyper-v but i am getting black screen after i select the bootloader from the grub.
I am new to linux
I have attached the screenshot of inix Fxxxza

I am getting black screen after i boot the linux.
I am trying to setup this using Hyper-V

Search for black screen on forum search upper right and do not bump old topics, please.

1 Like