Black screen | Hi I am a newbie in this Linux World

I am sorry but no. Also I used Balena Etcher to flash the iso into the usb pen

have you tried a different usb port. also fast boot coould be called something like skip "somethi9ng something". since thats basically what fast boot does.

Let me try that then. I tried another usb port. So hopefully it will work this time. I really don’t know how to fix this...

1 Like

I leave you Just a "desperate" try. It will not hurt :smiley: but it worked for me (with AMD CPU and Radeon graphic card) long ago with a very old kernel bug now fixed. Additionally it helps with some motherboards.
When in the grub line for open source drivers press button E. Then go to line starting with Linux and add at the end iommu=soft
The press ctrl+x to boot.
Again 99% will not help, but the issue is identical, so you may want to try or just disregard (no prob) :blush:


also after you press open source drivers. and it shows a black screen. try to press one of the arrow keys to bring up the boot log(if it got to that stage).

Or Esc :slight_smile:

I tried your way. It didn't work :frowning:
I am so sad.
And it does not even load into the installation page at all. I am 1 sec away from pulling my hair of my head cause of this (even though it's short)... :frowning:

Are you getting far enough in the boot process that you can get to a TTY? Boot to the black screen and then try pressing ctrl+alt+f3 and see if you get to a login prompt. If you can't, wait 5 minutes at the black screen and then try ctrl+alt+f3 again.


I was waiting for like 10 mins and then did that. It didn't load at all. I don't know if it is my GPU or not, sadly. It was working fine on Windows 10. :frowning:

Maybe you could remove quite splash from the GRUB parameters as above, to see if any useful info is shown?

I did try that way as well. It's been 30 mins and still waiting for the live USB page to load.

Please match your ISO checksums before every install,
Secondly you can use imgur for non staff members to see

Thirdly as Dalto said try getting into tty by pressing every f key uptill for, personally for me ctrl + alt + f6 that got me in

Edit - Failed formatting:(
ModEdit: Fixed formatting. Check how, so you know :wink:

It is finally working after I added "nomodeset radeon.modeset=0"
Now hopefully it's working well.
I will add more update after installing. Thanks a lot guys!


Hi it's me again! Now I am stuck at Starting Terminate Plymouth Boot Screen.
Does anyone have any idea to fix it?


Do you happen to use a display port?
If so, you could try if possible with an HDMI cable.

1 Like

I have exactly same issue, this command helped, little.

nomodeset Radeon.modeset=0

Im also stuck at “ Starting Terminate Plymouth Boot Screen “.
Is there any way to install Garuda just by boot command line. No special graphics card needed?
I use laptop but i tried other monitor on HDMI cable, just for sure, it makes no difference.

This is a first time installation (live).

I hope tomorrow’s update will fix that, it is quite common issue. Of course AMD is also in fault.

At least we know where the problem is.

So how can I install that?

sudo pacman -S xf86-video-amdgpu vulkan-radeon libva-mesa-driver mesa-vdpau

Im trying to boot live first and it stops at “Starting Terminate Plymouth Boot”
Where should I write those commends ?

If there is a setting in your BIOS somehow concerning how thoroughly it checks the machine's hardware, you want it to be the max allowed.