Black screen | Hi I am a newbie in this Linux World

I am learning how to install Garuda KDE Dragonizer onto my AMD PC, and I just hit a problem. It is when I try to either boot into the USB stick in order to install with open sources drivers or with properiaty drivers, things always give me a black screen.
Sorry I can't upload any image due to being a new user.
But here are my specs:
CPU: AMD Ryzen 7 2700
GPU: ATI Radeon RX 570
Motherboard: MSI B450M Mortar Max
Memory: 16GB

Does anyone have any way to help fixing it? Thank you in advanced!

Since you can't reach the point where you can run inxi, can you give us some details about your hardware? What CPU are you using? Do you have a dedicated GPU? Is it a laptop or a full PC? If it is a prebuilt machine, what is the model number?


I am sorry I just added the specs onto the original post.
And I am using a full PC. It's not a prebuilt-machine as I was the one who chose every spec for it, and it's originally for Windows but I was thinking about installing Garuda onto it.

somemes the live mhwd script can take a while to finish running try waiting a long time , like five minutes. since you have an amd gpu use the open source drivers. also have you tried reformatting the pen drive and verifying the sha256 of the iso?

1 Like

Yes I have tried everything. Fully formatted the pen drive, and verify the sha256 of the iso file as well.

is secure boot on


What did you use to burn the ISO on the USB? Balena Etcher or Ventoy should be ok, if starting from Linux dd as well. Rufus worked for many but had troubles for many others


Also make sure that in BIOS secure boot and fast boot are disabled

1 Like

I use a Kingston 16GB USB. I already checked in my Bios, there's no option for fast boot. I only could disable secure boot.

is it working now?

I am sorry but no. Also I used Balena Etcher to flash the iso into the usb pen

have you tried a different usb port. also fast boot coould be called something like skip "somethi9ng something". since thats basically what fast boot does.

Let me try that then. I tried another usb port. So hopefully it will work this time. I really don’t know how to fix this...

1 Like

I leave you Just a "desperate" try. It will not hurt :smiley: but it worked for me (with AMD CPU and Radeon graphic card) long ago with a very old kernel bug now fixed. Additionally it helps with some motherboards.
When in the grub line for open source drivers press button E. Then go to line starting with Linux and add at the end iommu=soft
The press ctrl+x to boot.
Again 99% will not help, but the issue is identical, so you may want to try or just disregard (no prob) :blush:


also after you press open source drivers. and it shows a black screen. try to press one of the arrow keys to bring up the boot log(if it got to that stage).

Or Esc :slight_smile:

I tried your way. It didn't work :frowning:
I am so sad.
And it does not even load into the installation page at all. I am 1 sec away from pulling my hair of my head cause of this (even though it's short)... :frowning:

Are you getting far enough in the boot process that you can get to a TTY? Boot to the black screen and then try pressing ctrl+alt+f3 and see if you get to a login prompt. If you can't, wait 5 minutes at the black screen and then try ctrl+alt+f3 again.


I was waiting for like 10 mins and then did that. It didn't load at all. I don't know if it is my GPU or not, sadly. It was working fine on Windows 10. :frowning: