Black screen after updating nvidia driver 495.46-2 to 510.47.03-3

Hi guys,

I'm new using Garuda, and after updating I also got the black screen and it seems the problem is related to the Nvidia drivers when going from version 495.46-2 to 510.47.03-3)

The system is up to date except for the packages: nvidia-utils, lib32-nvidia-utils, lib32-opencl-nvidia and nvidia-dkms. If I update them I get the black screen after that.

Do you have any suggestion about how to update nvidia driver and get rid of these issues?

inxi -G

Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nvidia
v: 495.46
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
Display: x11 server: X.Org 1.21.1.3 driver: loaded: nvidia
unloaded: modesetting resolution: 1: 2560x1440~60Hz 2: 1920x1080~144Hz
OpenGL: renderer: NVIDIA GeForce GTX 1650 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46

garuda-inxi -Faz

System:
Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5b311d4f-7831-4b6d-bddb-d5e81dd35fd8 rw [email protected]
quiet
cryptdevice=UUID=8ab2ec56-9ad4-44ad-baac-b4453b9bdd75:luks-8ab2ec56-9ad4-44ad-baac-b4453b9bdd75
root=/dev/mapper/luks-8ab2ec56-9ad4-44ad-baac-b4453b9bdd75 splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.24.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05
serial: <superuser required> Chassis: type: 10 v: Lenovo Legion 5 15ARH05
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
serial: <superuser required> UEFI: LENOVO v: EUCN31WW date: 01/01/2021
Battery:
ID-1: BAT0 charge: 74.1 Wh (100.0%) condition: 74.1/80.0 Wh (92.6%)
volts: 17.2 min: 15.4 model: Celxpert L19C4PC1 type: Li-poly
serial: <filter> status: Full cycles: 52
CPU:
Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600106
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1499 high: 2171 min/max: 1400/2900 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 2171
3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1398 9: 1646 10: 1532 11: 1387
12: 1459 13: 1396 14: 1495 15: 1466 16: 1652 bogomips: 92626
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
chip-ID: 10de:1f95 class-ID: 0300
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-3:4 chip-ID: 174f:244c class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 143 s-size: 796x254mm (31.3x10.0")
s-diag: 836mm (32.9")
Monitor-1: DP-0 res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.2") diag: 685mm (27")
Monitor-2: DP-2 res: 1920x1080 hz: 144 dpi: 142
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: NVIDIA GeForce GTX 1650 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: Lenovo driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 1000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: br-aa05e101528f state: down mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-3:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 121.2 GiB (25.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: HFM512GDHTNI-87A0B size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 11010C00 temp: 36.9 C scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 121.2 GiB (25.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-8ab2ec56-9ad4-44ad-baac-b4453b9bdd75
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 121.2 GiB (25.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-8ab2ec56-9ad4-44ad-baac-b4453b9bdd75
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 121.2 GiB (25.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-8ab2ec56-9ad4-44ad-baac-b4453b9bdd75
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 121.2 GiB (25.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-8ab2ec56-9ad4-44ad-baac-b4453b9bdd75
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A
Info:
Processes: 379 Uptime: 32m wakeups: 1 Memory: 15.56 GiB
used: 4.06 GiB (26.1%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 Packages: pacman: 1538 lib: 451 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-01-01
Last full system update: 2022-01-31
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Apart from updating, have you tried anything else suggested in this tutorial?

7 Likes

Thanks!

For me The first thing to try worked:

sudo reflector -a6 -f5 --save /etc/pacman.d/mirrorlist
sudo pacman -Syyu
2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.