Black screen after boot but startx works

System:
  Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=733f468d-fbc6-45d3-9342-5dbe48047967 rw [email protected]
    splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
    resume=UUID=733f468d-fbc6-45d3-9342-5dbe48047967 resume_offset=21777664
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: OMEN Laptop 15-en0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8787 v: 22.54 serial: <superuser required> UEFI: AMI
    v: F.07 date: 09/16/2020
Battery:
  ID-1: BAT0 charge: 65.8 Wh (100.0%) condition: 65.8/65.8 Wh (100.0%)
    volts: 12.8 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: N/A status: full cycles: 592
CPU:
  Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1607 high: 2835 min/max: 1400/2900 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 1548 2: 1480
    3: 1396 4: 1946 5: 1359 6: 1397 7: 1397 8: 1397 9: 1478 10: 1347 11: 2712
    12: 2835 13: 1382 14: 1285 15: 1365 16: 1396 bogomips: 92629
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Hewlett-Packard
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Turing pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
    off: HDMI-A-1 empty: DP-1,DP-2 bus-ID: 01:00.0 chip-ID: 10de:1f15
    class-ID: 0300
  Device-2: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: none
    bus-ID: 06:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-3: Luxvisions Innotech HP Wide Vision HD Camera type: USB
    driver: uvcvideo bus-ID: 3-3:3 chip-ID: 30c9:000e class-ID: 0e02
  Display: server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia alternate: intel
    gpu: amdgpu,nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: right
    model: Dell P2419H serial: <filter> built: 2019 res: 1920x1080 hz: 60
    dpi: 93 gamma: 1.2 size: 527x296mm (20.75x11.65") diag: 604mm (23.8")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-2: eDP-1 mapped: eDP pos: primary,left model: LG Display 0x05fe
    built: 2018 res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.46 5.18.3-zen1-1-zen)
    v: 4.6 Mesa 22.1.1 direct render: Yes
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f9 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-4:4 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 209.95 GiB (22.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
    model: MTFDHBA1T0TDV-1AZ1AABHA size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS0032 temp: 50.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 300 GiB size: 300 GiB (100.00%) used: 81.65 GiB (27.2%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 64.4 MiB (25.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 300 GiB size: 300 GiB (100.00%)
    used: 81.65 GiB (27.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 300 GiB size: 300 GiB (100.00%)
    used: 81.65 GiB (27.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-5: /var/tmp raw-size: 300 GiB size: 300 GiB (100.00%)
    used: 81.65 GiB (27.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 14.99 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: file size: 10 GiB used: 0 KiB (0.0%) priority: -2
    file: /swap/swapfile
Sensors:
  System Temperatures: cpu: 67.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 437 Uptime: 4m wakeups: 1 Memory: 14.99 GiB
  used: 4.03 GiB (26.9%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 alt: 11 clang: 13.0.1 Packages: pacman: 1956 lib: 393
  Shell: fish v: 3.4.1 running-in: kitty inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2022-06-07
  Last full system update: 2022-06-11
  Is partially upgraded:   No
  Relevant software:       tlp NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service 

The problem is exactly what the title says.
After booting I am able to use the login manager, but once i login the tty1 does not load the environment. It is stuck on a blacks screen

Whereas, when I login to tty2 ( ctrl + alt + F2) and execute startx it works. Idk why this problem suddenly occurred.

I also have another user on the system. Logging into that user in tty1 loads the desktop environment.

journalctl -b

Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GnuPG network certificate management daemon.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GCR ssh-agent wrapper.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GNOME Keyring daemon.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GnuPG cryptographic agent and passphrase cache (access for web browsers).
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GnuPG cryptographic agent and passphrase cache (restricted).
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on GnuPG cryptographic agent and passphrase cache.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on p11-kit server.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on PipeWire PulseAudio.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on PipeWire Multimedia System Socket.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Listening on D-Bus User Message Bus Socket.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Reached target Sockets.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Reached target Basic System.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[1]: Started User Manager for UID 1000.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='[email protected] comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr
=? terminal=? res=success'
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Started AppImageLauncher daemon.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[1]: Started Session 5 of User arjun.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Starting Profile-sync-daemon...
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Starting Update XDG user dir configuration...
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Finished Update XDG user dir configuration.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx login[2433]: pam_env(login:session): deprecated reading of user environment enabled
Jun 11 16:08:36 arjun-omenlaptop15en0xxx audit[2433]: USER_START pid=2433 uid=0 auid=1000 ses=5 msg='op=PAM:session_open grantors=pam_loginuid,pam_keyinit,pam_systemd_home,pam_limits,pam_un
ix,pam_permit,pam_mail,pam_systemd,pam_env acct="arjun" exe="/usr/bin/login" hostname=arjun-omenlaptop15en0xxx addr=? terminal=/dev/tty2 res=success'
Jun 11 16:08:36 arjun-omenlaptop15en0xxx audit[2433]: CRED_REFR pid=2433 uid=0 auid=1000 ses=5 msg='op=PAM:setcred grantors=pam_securetty,pam_shells,pam_faillock,pam_permit,pam_faillock acc
t="arjun" exe="/usr/bin/login" hostname=arjun-omenlaptop15en0xxx addr=? terminal=/dev/tty2 res=success'
Jun 11 16:08:36 arjun-omenlaptop15en0xxx appimagelauncherd[3022]: Searching for existing AppImages
Jun 11 16:08:36 arjun-omenlaptop15en0xxx appimagelauncherd[3022]: Searching directory: /home/arjun
Jun 11 16:08:36 arjun-omenlaptop15en0xxx appimagelauncherd[3022]: Searching directory: /home/arjun/Applications
Jun 11 16:08:36 arjun-omenlaptop15en0xxx appimagelauncherd[3022]: Watching directories: /home/arjun /home/arjun/Applications
Jun 11 16:08:36 arjun-omenlaptop15en0xxx profile-sync-daemon[3023]:  firedragon is not a supported browser. Check config file for typos: /home/arjun/.config/psd/psd.conf
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: psd.service: Main process exited, code=exited, status=1/FAILURE
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: psd.service: Failed with result 'exit-code'.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Failed to start Profile-sync-daemon.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Dependency failed for Timed resync.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: psd-resync.service: Job psd-resync.service/start failed with result 'dependency'.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Stopped Timer for profile-sync-daemon - 1Hour.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Reached target Main User Target.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx systemd[3015]: Startup finished in 126ms.
Jun 11 16:08:36 arjun-omenlaptop15en0xxx login[2433]: LOGIN ON tty2 BY arjun

I edited the firedragon part and removed it in the config ~/.config/psd/psd.conf

If none of the above helps fix this issue (which the first one will in 90% of cases) then search all Arch OS related forums for recent issues (Search results for 'black screen' - Garuda Linux Forum), and, if you can’t find anything, start a new thread mentioning what you have already tried.

2 Likes

Thanks, but I think I know the problem after debugging

xauth: error in locking authority file /home/user/.Xauthority

The tty1 is stuck in an endless timeout loop
in tty 2 I manually quit this part with Ctrl + C

I'm currently trying to fix this. chown did not help

Ok I found it. It was a lockfile issue.
I had

.Xauthority-c 
.Xauthority-l

I found that these were messing up the boot by using
strace xauth list
the fix was quite straightforward

rm .Xauthority-c .Xauthority-l
3 Likes