Black / Grey screen on boot. Know issue don't know how to fix

Ps: used Google lens to get code from screen. 8 and 0 can be misplaced. So code can be misspelled
I select Garuda from grub bootloader. And come to a grey screen. No login screen, just grey.

What I've done. Ctrl + alt+ f2
Tried to update. Error when trying to update

Checked timeshift backups. The one from yesterday is also broken. But not the one from last week. I think and remember that I was messing around trying to enable freesync. About 3 days ago by making a 20-amdgpu.conf file. And yesterday I edited that file for some reason. I changed the identifier because I thought it didn't do anything important (I was wrong).

I searched the Garuda wiki and found this link:

Did first thing to try in tty but it just ends in errors.

sudo reflector -a6 -f5 --save /etc/pacman.d/mirrorlist
sudo pacman -Syyu

This gives me:
error: failed to retrieve mirrorstatus data: URLError: <urlopen error [Errno -2] Name or service not known>

The second thing to try is to run:

startx

This gives me:

X.Org X Server 1.20.13

X Protocol Version 11. Revision 0
 Build Operating System: Linux Archlinux
*more stuff*
stemd.unified_cgroup_hierarchy=1 loglevel=3 Build Date: 04 August 2021 08:13:54AM

Current version of pixman: 0.40.0 Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.

Markers: (--) probed, (**) from config file, (==) default setting,

(++) from command line, (!!) notice, (11) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/home/antong/.local/share/xorg/Xorg.0.log", Time: Sat Aug 28 16:13:43 2021

(==) Using config directory: "/etc/X11/xorg.conf.d' (==) Using system config directory "/usr/share/X11/xorg.conf.d" Parse error on line 1 of section Device-1 in file /etc/X11/xorg.conf.d/20-anmgpu.conf "Device-1" is not a valid section name.
(EE)

Fatal server error:

(EE) no screens found (EE)

(EE)

Please consult the The X.Org Foundation

at http://wiki.x.org

for help.

support

(EE) Please also check the log file at "/home/antong/.local/share/xorg/org.0.log" for additional information.

(EE) (EE) Server terminated with error (1). Closing log file.

xinit: giving up

xinit: unable to connect to X server: Connection refused

The thing that caught my eye was:

Parse error on line 1 of section Device-1 in file /etc/X11/xorg.conf.d/20-anmgpu.conf "Device-1" is not a valid section name.

So my theory is true. I believe this is (or one of) the things that caused the grey screen problem. But I don't know how to fix this

So I now ask you guys for help. How do you fix this. How can I edit the file from tty

XD fixed it

Searched the internet. (I love that place)

Used

Cd /etc/X11/xorg.conf

Searched for Garuda terminal text editor and
Used

micro 20-amdgpu.conf

Changed "Device-1"
To "Device"
And

Reboot
2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.