BIOS upgrade adventures | HP ZBook


Please forgive me if this isn’t the right forum or category.

I thought I’d share my user journey trying to update the BIOS on my HP ZBook laptop.

The first steps were pretty straightforward:

  1. Get to the driver section of the HP site
  2. Lie about using Windows
  3. Download the latest exe file (“I want to believe”)
  4. Extract the exe file, and find the bin file inside

Some say the bin file should be renamed to “firmware.bin”, but that didn’t seem to be necessary in this instance.

Anyway, this is where the plot thickens. Within the BIOS itself, HP instructs me to place the correct binaries in “EFI\HP\DEVFW” location. However, this particular location doesn’t seem to be correct. So I’ve searched and moved the files around, and eventually this turned out to do the initial trick for me: “/boot/efi/EFI/HP/BIOS/New”. Initial trick, you say? Yes siree. For now the BIOS tells me that it understands I want to update my BIOS, and even mentions the new BIOS version. It also tells me to fasten my seatbelt, be patient, kick back and relax until everything is done. Sounds promising, no? When I try to proceed, however, it tells me to “Place the System BIOS on a FAT32 partition [etc etc]”. I’m pretty sure the partition is FAT32, and the fact that I got so far must mean that the bin file is already in the correct location.

I hope you enjoyed this little travel log, if I get any further I’ll be sure to report back.


FreeDOS would free you, and no having to convert the .exe


Well, that was fun. I tried FreeDOS, but couldn’t get my existing BIOS to use Legacy Boot. So eventually I went with fwupd (following these steps: fwupd - ArchWiki), and that worked like a charm. Apparently I’m now protected by “HP Wolf Security”. I guess that’s supposed to be a good thing. :thinking:

1 Like

LOL, never even thought about fwupd even though I know it should work. My present desktop machine’sBIOS is a bit different, doing in-place upgrades, but fwupd also handles some peripheral hardware firmware upgrades, as well as BIOS’.

I didn’t note the file size of your BIOS upgrade, but might it not have fit on a (very common file format) FAT32-formatted USB key?

Second, thank you for annotating your “adventures.” As you can tell, it’s been a while since I’ve done one using FreeDOS. Probably since a 2014 laptop in 2015, etc. 'til it died. :slight_smile: Still, there are a lot of older machines around that are non-EFI and I don’t believe fwupd works on those older machines. That’s what makes me think this thread would be a good, current online search engine source encompassing both types. :slight_smile:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.