Best way to use garuda-update

I use garuda-update and I am happy to use it.

Is it better

sudo su -

or as user with high privileges (admin)


and insert user password.

my garuda-inxi is

Kernel: 5.18.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e1b87af6-67e0-4350-97cb-8bdfe430d209 rw [email protected]
root=/dev/mapper/luks-735c2a29-e901-4fc7-893a-52a88bf43878 splash
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=/dev/mapper/luks-23c04b79-4698-461f-ade3-f485919f86ca loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: FUJITSU product: LIFEBOOK A544 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: FUJITSU model: FJNBB35 serial: <superuser required>
UEFI: FUJITSU // Phoenix v: Version 1.13 date: 11/18/2013
ID-1: BAT0 charge: 0.9 Wh (100.0%) condition: 0.9/4.5 Wh (20.1%)
volts: 12.2 min: 10.8 model: PTL CP651527-01 type: Li-ion serial: <filter>
status: N/A cycles: 274
Info: model: Intel Core i7-4702MQ bits: 64 type: MT MCP arch: Haswell
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2193 high: 2200 min/max: 800/3200 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2195 2: 2196 3: 2195
4: 2200 5: 2195 6: 2171 7: 2196 8: 2196 bogomips: 35118
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Fujitsu
driver: i915 v: kernel ports: active: HDMI-A-1 off: eDP-1 empty: VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
Device-2: Importek FJ Camera type: USB driver: uvcvideo bus-ID: 1-7:5
chip-ID: 10f1:1a58 class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 22.1.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2)
v: 4.6 Mesa 22.1.0 direct render: Yes
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
vendor: Fujitsu driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:0c0c class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio
vendor: Fujitsu driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Sound Server-1: ALSA v: k5.18.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b1 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Fujitsu driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
IF-ID-2: virbr1 state: down mac: <filter>
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-8:7 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 5 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 931.51 GiB used: 106.28 GiB (11.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: GPT
ID-1: / raw-size: 922.45 GiB size: 922.45 GiB (100.00%)
used: 106.28 GiB (11.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-735c2a29-e901-4fc7-893a-52a88bf43878
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 682 KiB (0.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 922.45 GiB size: 922.45 GiB (100.00%)
used: 106.28 GiB (11.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-735c2a29-e901-4fc7-893a-52a88bf43878
ID-4: /var/log raw-size: 922.45 GiB size: 922.45 GiB (100.00%)
used: 106.28 GiB (11.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-735c2a29-e901-4fc7-893a-52a88bf43878
ID-5: /var/tmp raw-size: 922.45 GiB size: 922.45 GiB (100.00%)
used: 106.28 GiB (11.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-735c2a29-e901-4fc7-893a-52a88bf43878
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 1.2 GiB (15.6%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-23c04b79-4698-461f-ade3-f485919f86ca
System Temperatures: cpu: 70.0 C pch: 62.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Processes: 311 Uptime: 1d 13h 30m wakeups: 13 Memory: 7.67 GiB
used: 2.77 GiB (36.2%) Init: systemd v: 251 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1738 lib: 385 Shell: fish
v: 3.4.1 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
System install date:     2021-03-13
Last full system update: 2022-06-03 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

You do not need to specify sudo or run as root. The command runs a script that will automatically prompt you for elevation. All you need to do is:


Or for the shorties like me and Dragonfire




And me haha


ls there any more shortcut command ? at past 1 month i was using command line sudo pacman -Syu to update every day .:sweat_smile:

garuda-update is recommended instead of this because it will keep your system in better shape. It does more than just take a simple update. Have a peek for yourself:

sudo micro /usr/bin/garuda-update

The command update is equivalent, as it is actually just a symlink to garuda-update:

lrwxrwxrwx 1 root root         22 May 17 13:04 update -> /usr/bin/garuda-update

upd is a bash alias that calls usr/bin/update.

alias upd='/usr/bin/update'

Switch to bash and type alias to list out the aliases currently set up on your device. It is also simple to set up your own if you like! alias(1p) — Arch manual pages


ohh u means garuda-update is better then sudo pacman -Syu command line .

Absolutely! For Garuda installs, garuda-update is THE one to use. Or simply upd. :smiley:


ohh got it getting new knowledge about Linux command feel good . thx i will switch to bash to learn more command line like that


No need to switch to bash for the alias command btw. I run it almost daily through fish to make sure my rsync alias doesn't change as it's messed up before lol

1 Like

Grimy you're right about that, I had confused myself while poking around on KDE lite.

KDE lite starts off with ~/.config/fish/ as basically an empty file (fish did not even recognize "alias" as a command), but the aliases are set up in bash.

I poked around a little bit and discovered /etc/skel/.config/fish/ contains the proper Garuda setup (probably pulled down through an update), so restoring fish in Garuda Assistant gave me a "normal" Garuda fish setup with working aliases.

1 Like

Oh so Fish itself doesn't support the command by default but basically links to bash to output it in fish? Either that or I didn't read what you said properly as I'm tired.

I'm still scratching my head on how fish went from not recognizing alias as a command at all, to working normally after restoring the skeleton. I get that the aliases themselves were missing, but not recognizing the command seems odd--why not just return an empty output? I've looked through the files in the skeleton trying to figure out what does this, but so far I'm kind of stumped. :thinking:

I don't think they are links. fish has it's own set of aliases set up in ~.config/fish/, and there are way more than the aliases set up in bash--on this system, I'd say at least twice as many. If you run alias with no arguments from a fish shell it will print out the list, although they don't print right (missing the colors typical to fish, and also with an excessive number of backslashes that are not present in the file).

hey i just move to bash for alias to make own custom command line . But problem is i am not getting that auto name on bash i means like this

when i move to bash it does not active like that feature . Is there any solution to do that on bash .it will be great help.

@Sandesh55 I tried to explain, that comment was just a misunderstanding. You do not need to switch to bash, you can use and create aliases from fish. If you would like to continue to enjoy the autocomplete features of fish, that is what you should do.


ohh got it sorry

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.