Best way to install Conky for KDE D460nized

Hi Everyone,

What is the best way to install & get Conky working with Garuda? I've never worked with it before & am kind of confused. I originally installed it with:

pacman -S conky conky-manager

but then read through some things in the Forum, & ended up trying to compile conky-lua-nv via:

git clone

After doing that, it said that the regular conky package was in conflict, so I just let it remove that one. There is a .conky folder in my home directory, and the conky.desktop file is in /etc/xdg/autostart.

Now I'm unsure what to do from here. I am using the KDE Dr460nized version, & have read that Conky can be tricky to get working right with Plasma. What's the best way to go about doing everything?

Kernel: 6.1.0-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=219f04f8-c9e0-400f-9d0d-043e8bfeff04 rw [email protected]
root=/dev/mapper/luks-52208f8d-eb2d-4f13-aa58-a362bbe116ae splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: XPS 17 9710 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0Y1K2K v: A01 serial: <superuser required> UEFI: Dell
v: 1.4.1 date: 09/08/2021
ID-1: BAT0 charge: 88.3 Wh (100.0%) condition: 88.3/95.1 Wh (92.9%)
volts: 12.4 min: 11.4 model: BYD DELL F8CPG1A type: Li-poly serial: <filter>
status: full
Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
microcode: 0x42
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 2361 high: 3276 min/max: 800/4600 scaling:
driver: intel_pstate governor: performance cores: 1: 2300 2: 2300 3: 2300
4: 2300 5: 2300 6: 2300 7: 2300 8: 2300 9: 2300 10: 2300 11: 2300 12: 2300
13: 2300 14: 2300 15: 3276 16: 2300 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Dell
driver: nvidia v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25a2 class-ID: 0302
Display: x11 server: X.Org v: 21.1.5 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: i965 gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2400 s-dpi: 96 s-size: 1016x635mm (40.00x25.00")
s-diag: 1198mm (47.17")
Monitor-1: eDP-1 mapped: eDP1 model: Sharp 0x1517 built: 2021
res: 3840x2400 hz: 60 dpi: 264 gamma: 1.2 size: 370x230mm (14.57x9.06")
diag: 432mm (17") ratio: 16:10 modes: 3840x2400
API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel UHD Graphics (TGL GT1)
direct render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: Dell
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0401
Sound API: ALSA v: k6.1.0-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: Waifu state: down mac: <filter>
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
bus-ID: 2-4.1:3 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
IF: enp0s13f0u4u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: br10 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-14:3 chip-ID: 8087:0026 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: see --recommends
Local Storage: total: 476.94 GiB used: 374.24 GiB (78.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC711 NVMe 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 41001131 temp: 42.9 C scheme: GPT
ID-1: / raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 374.24 GiB (78.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-52208f8d-eb2d-4f13-aa58-a362bbe116ae
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 738 KiB (0.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 374.24 GiB (78.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-52208f8d-eb2d-4f13-aa58-a362bbe116ae
ID-4: /var/log raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 374.24 GiB (78.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-52208f8d-eb2d-4f13-aa58-a362bbe116ae
ID-5: /var/tmp raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 374.24 GiB (78.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-52208f8d-eb2d-4f13-aa58-a362bbe116ae
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.36 GiB used: 1 GiB (6.5%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 389 Uptime: 2h 55m wakeups: 30330 Memory: 15.36 GiB
used: 6.48 GiB (42.2%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages:
pm: pacman pkgs: 1636 libs: 353 tools: pamac,paru,trizen,yay Shell: fish
v: 3.5.1 default: Zsh v: 5.9 running-in: konsole inxi: 3.3.24
Garuda (2.6.12-1):
System install date:     2022-01-08
Last full system update: 2022-12-20 ↻
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift
Failed units:            shadow.service


First of all, you have to edit PKGBUILD file in the folder where you downloaded the conky-lua-nv source, and edit line




and save and exit.

Now, in the same folder, open terminal and run

makepkg -rsf

This should take some time and make a tarball called conky-lua-nv-.... where .... would be the version ( it is conky-lua-nv-1.15.0-1-x86_64.pkg.tar.zst for me right now).

So, now, all you have to do is

sudo pacman -U conky-lua-nv-1.15.0-1-x86_64.pkg.tar.zst

or replace the name with exact version.

Now you have conky-lua-nv installed.
What do you want to do now? I mean which theme?


Hey there :slight_smile:

Okay, I restored a snapshot back to before compiling conky-lua-nv, so I could "start over" so to speak.

This is the PKGBUILD file:

# Maintainer: Spyros Stathopoulos <[at]gmail[dot]com>
# Contributor: Jon Wilson <[email protected]>
# Contributor: Andrwe Lord Weber <lord-weber-andrwe [at] andrwe [dot] org>
# Contributor: Giovanni Scafora <[email protected]>
# Contributor: James Rayner <[email protected]>
# Contributor: Partha Chowdhury <[email protected]>

pkgdesc="An advanced system monitor for X based on torsmo with lua and nvidia enabled"
arch=('i686' 'x86_64')
license=('GPL' 'BSD')
replaces=('torsmo' 'conky')
provides=('conky' 'conky-lua')
  'glibc' 'glib2' 'lua' 'wireless_tools' 'libxdamage' 'libxinerama' 'libxft' 'imlib2'
  'libxml2' 'libpulse' 'libxnvctrl' 'systemd-libs' 'ncurses' 'curl'
makedepends=('cmake' 'docbook2x' 'docbook-xsl' 'man-db' 'git' 'catch2'
             'pandoc' 'python-yaml' 'python-jinja')
optdepends=('nvidia: for GT4xx and newer GPUs',
  'nvidia-340xx: for G8x, G9x, GT2xx GPUS',
  'nvidia-304xx: for GeForce 6/7 GPUs')
options=('!strip' 'debug')

prepare() {
  # disable HSV gradients for now
  cd ${srcdir}/${_pkgname}-${pkgver}
  rm -r tests/catch2
  ln -s /usr/include/catch2 tests

build() {
  cd ${srcdir}/${_pkgname}-${pkgver}

  cmake \
    -B build \
    -D CMAKE_BUILD_TYPE=Release \
    -D CMAKE_CXX_FLAGS="$CXXFLAGS -ffat-lto-objects" \
    -Wno-dev \
    -S .

  make -C build

package() {
  cd ${srcdir}/${_pkgname}-${pkgver}
  make -C build DESTDIR=${pkgdir} install
  install -D -m644 COPYING -t ${pkgdir}/usr/share/licenses/${pkgname}
  install -D -m644 build/extras/vim/syntax/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
  install -D -m644 extras/vim/ftdetect/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim

# vim:ts=2:et:sw=2

Should I recompile it again to be able to see the MAINTAINER_MODE=ON part? My guess is that wouldn't make sense, but just not seeing it in here. I got it from the AUR

[EDIT]: I'm a moron, lol... just saw it :woman_facepalming: :sweat_smile:

Okay, well, before I go trying to pick themes, what should I be doing next?

I still can't find the conky.conf file anywhere.

If I run conky-manager, it looks like there are some theme type entries in there. Simply checking the boxes next to them doesn't result in all of them showing up on the desktop, to be edited further or otherwise.
And of the ones that do, there is often this screen tearing effect within the widget display.

Should I also install conky-cairo?

Just pick up the theme and follow their guide



Ended up just trying to follow a ChrisTitus video where he shows how to edit a script he downloaded.

Since I couldn't figure out how the conky-lua-nv was working, I just started over & dealt straight with Conky. No conky-manager or anything else.

Once I got the script modified the way I wanted as far as colors & things like that, I put it into the ~/.conky folder. Then did his suggestion to make a symbolic link for it in /etc/profile.d to have it run on startup. conky.desktop was already in /etc/xdg/autostart, and it seemed to be loading up on startup just fine like that before doing the sym link. But I guess that covers it in some additional way. I'm not sure I fully understand the implications of adding the sym link.

But for now, it's working, Lol <: D

As far as other places to find more conky scripts/configs, a lot of people have suggested DeviantArt... which has tons of amazing looking ones. But now everything is paywalled, it's not the site I remember browsing to for wallpapers 20+yrs ago, lol :joy:
Aside from r/conkyporn, are there any other good places anyone might recommend?