BCM4360 - Need help enabling wifi on garuda linux macbook air 2015


Post your terminal/konsole in- and output as text (no pictures) from:

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
misolabel=GARUDA_DR460NIZED_HARPYEAGLE quiet systemd.show_status=1 driver=free
nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0 serial: <filter> Chassis: type: 9
v: Mac-937CB26E2E02BB01 serial: <filter>
Mobo: Apple model: Mac-937CB26E2E02BB01 v: MacBookAir7,2 serial: <filter> UEFI: Apple
v: 428. date: 09/25/2021
Battery:   ID-1: BAT0 charge: 20.9 Wh (43.1%) condition: 48.5/54.3 Wh (89.2%) volts: 7.4 min: 7.6
model: DP bq20z451 type: Li-ion serial: N/A status: Discharging cycles: 258
Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A status: N/A
CPU:       Info: Dual Core model: Intel Core i5-5250U bits: 64 type: MT MCP arch: Broadwell family: 6
model-id: 3D (61) stepping: 4 microcode: 2F cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12800
Speed: 1600 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 1600 2: 1610 3: 1600 4: 1668
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:1626 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.0x9.4") s-diag: 449mm (17.7")
Monitor-1: eDP1 res: 1440x900 hz: 60 dpi: 126 size: 290x180mm (11.4x7.1") diag: 341mm (13.4")
OpenGL: renderer: Mesa Intel HD Graphics 6000 (BDW GT3) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: N/A bus-ID: 02:00.0 chip-ID: 14e4:1570
class-ID: 0480
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
driver: bcma-pci-bridge v: N/A modules: bcma bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF-ID-1: enp0s20u2c4i2 state: up speed: N/A duplex: N/A mac: <filter>
Bluetooth: Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 bus-ID: 1-3.3:8
chip-ID: 05ac:828f class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 127.91 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0128G size: 113 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: SA0Q
scheme: GPT
ID-2: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Cruzer Switch size: 14.91 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.26 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 70.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 195 Uptime: 28m wakeups: 7 Memory: 7.67 GiB used: 3.95 GiB (51.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1171 lib: 287
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Hi, i am trying to install garuda linux on my macbook air 2015, it has a broadcom wifi chip and i need help in enabling wifi, i am still currently running it off the usb stick and not installed on my ssd, on other distro like linux mint there was an option to enable the proprietary driver for bcml

Network:   Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
driver: bcma-pci-bridge v: N/A modules: bcma bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF-ID-1: enp0s20u2c4i2 state: up speed: N/A duplex: N/A mac: <filter>

Looks like it's working in Live environment, is it?

Live and installed versions use different drivers.

What do you mean? It would not work in live environment? I am a newbie btw, also thks tbg and chrispynut

Thank you for the quick responses btw

Use the 'brcmfmac' kernel module. Uninstall the Broadcom wl driver and restart.

Or use modprobe -r wl; modprobe brcmfmac in the terninal.


Ok, would i be able to test this in the live environment and then replicate in the main one?

Possibly, but switching drivers in the live envioronment is often unsuccessful.

ok, thank you, i'll test this


modprobe -r wl; modprobe brcmfmac

So i did what you said in an installation, there were no replies in terminal after the commands and wifi didnt work, should i reboot the laptop?


sudo modprobe -r b43 b43legacy ssb bcm43xx brcm80211 brcmfmac brcmsmac bcma wl

Then load the wl driver:

sudo modprobe wl

Also when i ran lsmod brcmfmac was the first module

Please post:

lsmod | sort

After rebooting.

1 Like

Ok, should i first reboot or should i run the previous commands?

Just rebooted, it is displaying the wifi networks but when i hit connect, it fails to connect

I tried a different wifi, it works

Now all of my wifis are working, thanks you absolute legend

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.