BCM4360 - Dell dw1830 wireless card not working when garuda is installed

Hello,

just used garuda with a live usb and it worked great. I installed it onto the ssd in my Dell e5450, but i can't get the card to work, with the live usb it worked oob.
In the live, i checked pacman whether broadcom-wl, broadcom-wl-dkms or b43-firmware was installed but neither of these was, worked anyway.
With the installed system i tried both broadcom-wl (-dkms), but i don't get it to work.

What could i do to solve this?

Look at the output of inxi -Fa to identify the wifi chipset, then search the forum for the many threads that already exist. :wink:

2 Likes

In Live ISO, check inxi -n output, or other utility (Network Assistant, etc.) to see the used driver for WiFi card.

3 Likes

And post the output please.

3 Likes

Thanks for the replies, i had to install b43 again, and turn off the laptop for several minutes and then it worked.

This thread is without merit without that ^^^ information.

The forum serves as a reference for other users, your thread has little helpful information without your adapter model.

Please post the information requested.

2 Likes
╭─[email protected] in ~
╰─λ inxi -n
  Network: 
    Device-1: Intel Ethernet I218-LM driver: e1000e
    IF: eno1 state: down mac: 35:c6:d6:7c:4a:80
    Device-2: Broadcom BCM43602 802.11ac Wireless LAN SoC driver: brcmfmac
    IF: wlp2s0 state: down mac: e4:1b:0f:bc:3a:cd

BCM43602 does not use the B43 driver, it uses brcmfmac.

From your output your adapter is not operational.

You wanted me to post the output when the live iso is running, so i started it and fetched the output - without connecting to a wifi network. But i connected it afterwards, and it is the same output, just "down" replaced by "up".

I don't know why, but installing b43 worked with the installed garuda.

Thank you for posting, and the explanation.

I hope you don't mind I have edited your thread title to include your adapter model. I do this with most networking help requests so that users with the same adapters may find solutions that apply to their hardware more easily.

I am going to close your thread now as this issue appears resolved.

1 Like