BCM4312 - Wifi not working on my Dell Studio 1735

Wifi isn't working on my laptop Dell Studio . He didn't find no networks.

Network: Device-1: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe vendor: Dell driver: tg3 v: kernel
port: 10c0 bus-ID: 09:00.0
IF: enp9s0 state: down mac:
Device-2: Broadcom BCM4312 802.11b/g LP-PHY vendor: Dell Wireless 1397 WLAN Mini-Card
driver: b43-pci-bridge v: N/A port: 10c0 bus-ID: 0c:00.0

For your info, from the mighty Arch wiki -

https://wiki.archlinux.org/index.php/Dell_Studio_1555

Networking

Ethernet works out of the box. Wireless may work out of the box depending on your wifi card. If you have a Broadcom BCM43XX card, you will need to install the broadcom-wl driver from the AUR. Read Broadcom wireless guide for details. b43 driver can work as well, if supplied with proper firmware.

5 Likes

I've tried broadcom-wl, broadcom-wl-dkms,broadcom-wl-lts and b43,nothing is working?

Try a search in the forum with

"Dell wifi" and plain "wifi", there are many (solved) threads to look through.

Unfortunately, I am no wifi guru, sorry. :blush:

1 Like

The Arch Wiki recommends installing the b43-firmware-classic package for the BCM4312 adapter.

If the broadcom-wl driver is installed then uninstall it.

Install the b43-firmware-classic package and reboot.

If after rebooting your internal wifi adapter is still not working then you may have to create a blacklist file. You may need to blacklist the wl, brcm80211, bcma, and b43_legacy modules when installing the the b43-firmware-classic package.

If this does not work please post:

inxi -Fxxxza
lsmod | sort
rfkil list
grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 
sudo dmesg  | grep -Ei 'error|fail|firm|regdom|cfg80211|alpha2|wmi|wl|b43|80211|brcm|ssb|bcma|deauth' | grep -viE 'acpi|ras|nvidia|eth'

Welcome to Garuda.

3 Likes

It doesn't work.

[[email protected] ~]$ inxi -Fxxxza
System:    Kernel: 5.11.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=7b2ee055-b9cf-4e22-be5c-2f65c3ea2cb5 rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Portable System: Dell product: Studio 1735 v: N/A serial: <filter> Chassis: type: 8 
           serial: <filter> 
           Mobo: Dell model: 0H268K serial: <filter> BIOS: Dell v: A04 date: 08/01/2008 
Battery:   ID-1: BAT0 charge: 726.0 Wh (100.0%) condition: 726.0/57.7 Wh (1257.8%) volts: 12.5 min: 11.1 
           model: SMP DELL KM9788 type: Li-ion serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185/M225 serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Dual Core model: Intel Core2 Duo T8100 bits: 64 type: MCP arch: Penryn family: 6 
           model-id: 17 (23) stepping: 6 microcode: 60F cache: L2: 3 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 bogomips: 8378 
           Speed: 2103 MHz min/max: 1200/2101 MHz boost: enabled Core speeds (MHz): 1: 2103 2: 2177 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Mobile GM965/GL960 Integrated Graphics vendor: Dell driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:2a02 class-ID: 0300 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.0x9.4") s-diag: 449mm (17.7") 
           Monitor-1: LVDS1 res: 1440x900 hz: 61 dpi: 99 size: 370x230mm (14.6x9.1") diag: 436mm (17.2") 
           OpenGL: renderer: Mesa DRI Intel 965GM (CL) v: 2.1 Mesa 21.0.1 direct render: Yes 
Audio:     Device-1: Intel 82801H HD Audio vendor: Dell Studio 1735 driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 chip-ID: 8086:284b class-ID: 0403 
           Sound Server-1: ALSA v: k5.11.11-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe vendor: Dell driver: tg3 v: kernel 
           port: 10c0 bus-ID: 09:00.0 chip-ID: 14e4:1698 class-ID: 0200 
           IF: enp9s0 state: down mac: <filter> 
           Device-2: Broadcom BCM4312 802.11b/g LP-PHY vendor: Dell Wireless 1397 WLAN Mini-Card 
           driver: b43-pci-bridge v: N/A modules: ssb port: 10c0 bus-ID: 0c:00.0 chip-ID: 14e4:4315 
           class-ID: 0280 
           IF-ID-1: wlan0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 545.86 GiB (46.7%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Intenso model: SSD Sata III size: 238.47 GiB block-size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: SSD serial: <filter> rev: 2A0 
           scheme: MBR 
           ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB 
           block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: A560 scheme: MBR 
Partition: ID-1: / raw-size: 33.52 GiB size: 33.52 GiB (100.00%) used: 10.68 GiB (31.9%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /home raw-size: 135.41 GiB size: 132.28 GiB (97.69%) used: 54.58 GiB (41.3%) fs: ext4 
           dev: /dev/sda4 maj-min: 8:4 
           ID-3: /var/log raw-size: 33.52 GiB size: 33.52 GiB (100.00%) used: 10.68 GiB (31.9%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/tmp raw-size: 33.52 GiB size: 33.52 GiB (100.00%) used: 10.68 GiB (31.9%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: partition size: 5.64 GiB used: 0 KiB (0.0%) priority: 1024 dev: /dev/sda3 
           maj-min: 8:3 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2480 
Info:      Processes: 208 Uptime: 1m wakeups: 3 Memory: 3.83 GiB used: 1.11 GiB (29.0%) Init: systemd 
           v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1208 lib: 303 
           Shell: Bash v: 5.1.4 default: fish v: 3.2.1 running-in: konsole inxi: 3.3.03

[[email protected] ~]$ lsmod | sort
ac97_bus 16384 1 snd_soc_core
acpi_cpufreq 28672 1
agpgart 40960 5 intel_agp,intel_gtt,ttm,nouveau,drm
amdgpu 7282688 0
b43 479232 0
bcma 73728 1 b43
blake2b_generic 20480 0
bpf_preload 16384 0
btrfs 1642496 2
cdrom 77824 1 sr_mod
cec 81920 2 drm_kms_helper,i915
cfg80211 1064960 2 b43,mac80211
cordic 16384 1 b43
coretemp 20480 0
cqhci 32768 1 sdhci_pci
crc16 16384 1 ext4
crc32c_generic 16384 5
crc_itu_t 16384 1 firewire_core
crypto_user 20480 0
dcdbas 20480 1 dell_smbios
dell_laptop 28672 0
dell_smbios 32768 2 dell_wmi,dell_laptop
dell_smm_hwmon 24576 0
dell_wmi 20480 0
dell_wmi_descriptor 20480 2 dell_wmi,dell_smbios
drm 622592 13 gpu_sched,drm_kms_helper,amdgpu,radeon,drm_ttm_helper,i915,ttm,nouveau
drm_kms_helper 307200 4 amdgpu,radeon,i915,nouveau
drm_ttm_helper 16384 3 amdgpu,radeon,nouveau
ext4 962560 1
fb_sys_fops 16384 1 drm_kms_helper
firewire_core 90112 1 firewire_ohci
firewire_ohci 49152 0
fuse 167936 3
gpio_ich 16384 0
gpu_sched 45056 1 amdgpu
hid_logitech_dj 28672 0
hid_logitech_hidpp 53248 0
i2c_algo_bit 16384 4 amdgpu,radeon,i915,nouveau
i2c_i801 36864 0
i2c_smbus 20480 1 i2c_i801
i915 2965504 13
intel_agp 24576 0
intel_gtt 24576 2 intel_agp,i915
intel_pmc_bxt 16384 1 iTCO_wdt
ip_tables 32768 0
ir_rc6_decoder 20480 0
iTCO_vendor_support 16384 1 iTCO_wdt
iTCO_wdt 16384 0
ite_cir 36864 0
jbd2 151552 1 ext4
joydev 28672 0
ledtrig_audio 16384 2 snd_hda_codec_generic,dell_laptop
libarc4 16384 1 mac80211
libcrc32c 16384 1 btrfs
libphy 163840 1 tg3
lpc_ich 28672 0
mac80211 1232896 1 b43
mac_hid 16384 0
mbcache 16384 1 ext4
memstick 24576 1 r592
mmc_core 204800 5 b43,sdhci,ssb,cqhci,sdhci_pci
Module Size Used by
mousedev 24576 0
mxm_wmi 16384 1 nouveau
nouveau 2506752 0
pcmcia 81920 1 ssb
pcmcia_core 36864 1 pcmcia
psmouse 196608 0
r592 24576 0
radeon 1761280 0
raid6_pq 122880 1 btrfs
rc_rc6_mce 16384 0
rfkill 32768 5 dell_laptop,cfg80211
rng_core 20480 1 b43
sdhci 81920 1 sdhci_pci
sdhci_pci 65536 0
serio_raw 20480 0
snd 118784 16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_cod
ec,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_hda_codec_idt
snd_compress 28672 1 snd_soc_core
snd_hda_codec 184320 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_idt
snd_hda_codec_generic 110592 1 snd_hda_codec_idt
snd_hda_codec_hdmi 86016 1
snd_hda_codec_idt 73728 1
snd_hda_core 114688 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_
codec_idt
snd_hda_intel 57344 3
snd_hwdep 16384 1 snd_hda_codec
snd_intel_dspcfg 28672 1 snd_hda_intel
snd_pcm 163840 8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_compress,s
nd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd_pcm_dmaengine 16384 1 snd_soc_core
snd_soc_core 352256 1 soundwire_intel
snd_timer 45056 1 snd_pcm
soundcore 16384 1 snd
soundwire_bus 98304 3 soundwire_intel,soundwire_generic_allocation,soundwire_cadence
soundwire_cadence 36864 1 soundwire_intel
soundwire_generic_allocation 16384 1 soundwire_intel
soundwire_intel 45056 1 snd_intel_dspcfg
sparse_keymap 16384 1 dell_wmi
sr_mod 28672 0
ssb 106496 1 b43
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
tg3 208896 0
ttm 90112 4 amdgpu,radeon,drm_ttm_helper,nouveau
uinput 24576 0
usbhid 69632 1 hid_logitech_dj
video 53248 4 dell_wmi,dell_laptop,i915,nouveau
wmi 36864 6 dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi,nouveau
wmi_bmof 16384 0
xor 24576 1 btrfs
x_tables 57344 1 ip_tables
zram 36864 4

[[email protected] ~]$ rfkil list
bash: rfkil: opdracht niet gevonden

[[email protected] ~]$ grep -r "blacklist|install|options" /etc/modprobe.d/ /etc/modules-load.d/ /usr/
lib/modprobe.d/
/etc/modprobe.d/nobeep.conf:blacklist pcspkr
/etc/modprobe.d/noime.conf:blacklist mei
/etc/modprobe.d/noime.conf:blacklist mei_me
/usr/lib/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore
-install libnvdimm $CMDLINE_OPTS
/usr/lib/modprobe.d/README: excludes 32-bit x86!), then nspawn will now install a
/usr/lib/modprobe.d/README: Any configuration options can be specified as -Darg=value... arguments
/usr/lib/modprobe.d/README: refuse to run again, and options must be changed with:
/usr/lib/modprobe.d/README: meson configure without any arguments will print out available options and
/usr/lib/modprobe.d/README: sudo meson install -C build/
/usr/lib/modprobe.d/README: DESTDIR=... meson install -C build/
/usr/lib/modprobe.d/README: install nss-myhostname to ensure that, in a world of
/usr/lib/modprobe.d/README: if nss-myhostname is not installed.
/usr/lib/modprobe.d/README: with programs installed split between / and /usr. Moving everything
/usr/lib/modprobe.d/README: SysV init.d script, it calls /usr/lib/systemd/systemd-sysv-install;
/usr/lib/modprobe.d/README: Please see src/systemctl/systemd-sysv-install.SKELETON for how this
/usr/lib/modprobe.d/README: -Dvalgrind=true and have valgrind development headers installed
/usr/lib/modprobe.d/systemd.conf:options bonding max_bonds=0
/usr/lib/modprobe.d/systemd.conf:options dummy numdummies=0
/usr/lib/modprobe.d/bluetooth-usb.conf:options btusb reset=1

[[email protected] ~]$ sudo dmesg | grep -Ei 'error|fail|firm|regdom|cfg80211|alpha2|wmi|wl|b43|80211|brcm|ssb|bcma|deauth' | grep -viE 'acpi|ras|nvidia|eth'
[sudo] wachtwoord voor willy:         
[    5.230884] ssb: Found chip with id 0x4312, rev 0x01 and package 0x00
[    5.320012] b43-pci-bridge 0000:0c:00.0: Sonics Silicon Backplane found on PCI device 0000:0c:00.0
[    5.562078] dell-smbios A80593CE-A997-11DA-B012-B622A1EF5492: WMI SMBIOS userspace interface not supported(0), try upgrading to a newer BIOS
[    5.641361] input: Dell WMI hotkeys as /devices/platform/PNP0C14:00/wmi_bus/wmi_bus-PNP0C14:00/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input18
[    6.836090] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    6.861334] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    7.116643] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
[    7.135329] b43-phy0: Found PHY: Analog 6, Type 5 (LP), Revision 1
[    7.135354] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2062, Revision 2, Version 0
[    7.145784] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   43.143143] audit: type=1131 audit(1618125896.520:247): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth-autoconnect comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
[  936.183521] audit: type=1100 audit(1618126789.560:252): pid=98706 uid=1000 auid=1000 ses=1 msg='op=PAM:authentication grantors=pam_faillock,pam_permit,pam_faillock acct="willy" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/0 res=success'
[  936.186710] audit: type=1110 audit(1618126789.563:254): pid=98706 uid=1000 auid=1000 ses=1 msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_faillock acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/0 res=success'

Is your bios up to date?

2 Likes

I don't know,I'm going to find out and upgrade .

I can not update the bios, it is Ao4 and the latest is A05.

A n unexpected error occurred while running the Flash application.Please reboot and try again.

I've done that several time?

Are you attempting to flash your bios from within Windows?

You can try this below, paste the following commands into the terminal and execute them:

Paste the commands below into the terminal and execute them:

nmcli networking off
sleep 1
sudo systemctl stop NetworkManager
sleep 1
sudo rmmod -v tg3
sleep 1
sudo rmmod -v b43
sleep 1
sudo rmmod -v  ssb
sleep 1
sudo rmmod -v bcma
sleep 1
sudo rfkill unblock wifi
sleep 1
sudo modprobe b43
sleep 3
sudo systemctl start NetworkManager
sleep 2
sudo nmcli networking on
sleep 2
nmcli r wifi off
sleep 2
nmcli r wifi on

Please post all inputs, and all outputs of that sequence of commands once they are finished being run.


If that is not successful I would recommenced doing the following:

Power down the laptop and remove the battery and power plug. Let the laptop sit without power for a few minutes. Then, hold down the power button for approximately 30 seconds. Pressing the power button will help drain all left over power from the unit’s motherboard.

Then reattach the AC power (no battery), and restart. Boot into your bios, then reset the bios to the factory defaults, save the default settings. See if it will boot correctly with the factory default settings. If not, you may have to change a few settings in the BIOS (such as secure boot, fastboot, AHCI) to get Garuda to boot correctly. After rebooting your adapter may be working properly.

4 Likes

I've tried everything nothing helps?

Where are the outputs? @tbg asked for them to help with diagnosing problems, even though it may be a pain to do so. Just sayin :slightly_smiling_face:

1 Like

Its working....first after several attempts to update the bios ,the update was successful, and then I applied everything from tbg's last answer, and then it worked, thank you very much and certainly special to tbg ... top!

3 Likes

Glad you stuck with it and learned a whole lot for the future! :slight_smile:

And, yes - @tbg is pretty darned special. :+1:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.