Bad fps with nvidia on wine

Hello garuda user

i as the topic says but i still didnt figure the problem why i was in archlinux and when i use it the nvidia work with wine perfect in linux kernel and linux-hardened no low fps or bugs but when i switch to garuda wine in the same game low fps but with mesa(intel “integrated”) its working fine i tried cs1.6 too same result idk the reason

Kernel: 6.5.8-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
v: 13.2.1 clocksource: tsc available: acpi_pm parameters: pti=on
page_alloc.shuffle=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
root=UUID=83a4bc62-3011-45dd-b31c-0b4eae7ca0d8 rw rootflags=subvol=@
quiet nvidia_drm.modeset=1 quiet rd.udev.log_priority=3
resume=UUID=a8888fdc-4f40-426c-9bf6-0673c44a8a27 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC
v: 098C110000404100000610180 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Hewlett-Packard model: 2166 v: 29.42 serial: <superuser required>
UEFI: Insyde v: F.71 date: 03/13/2017
ID-1: BAT0 charge: 14.2 Wh (91.0%) condition: 15.6/15.6 Wh (100.0%)
volts: 17.2 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: charging
Info: model: Intel Core i7-4500U bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2694 min/max: 800/3000 scaling: driver: intel_cpufreq
governor: performance cores: 1: 2694 2: 2694 3: 2694 4: 2694 bogomips: 19162
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a16
class-ID: 0300
Device-2: NVIDIA GK208M [GeForce GT 740M] vendor: Hewlett-Packard
driver: nvidia v: 470.199.02 alternate: nouveau,nvidia_drm non-free:
series: 470.xx+ status: legacy-active (EOL~2023/24) arch: Kepler
code: GKxxx process: TSMC 28nm built: 2012-18 pcie: gen: 2 speed: 5 GT/s
lanes: 4 link-max: lanes: 8 bus-ID: 0a:00.0 chip-ID: 10de:1292
class-ID: 0302
Device-3: Cheng Uei Precision Industry (Foxlink) Webcam driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-3:3
chip-ID: 05c8:036e class-ID: 0e02
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: crocus
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 mapped: eDP-1-1 model: Samsung 0x4651 built: 2012
res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
API: EGL v: 1.5 hw: drv: intel crocus drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: crocus device: 3 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: swrast x11: drv: nvidia inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 470.199.02
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GT 740M/PCIe/SSE2
memory: 1.95 GiB
API: Vulkan v: 1.3.269 layers: 7 device: 0 type: discrete-gpu
name: NVIDIA GeForce GT 740M driver: nvidia v: 470.199.02
device-ID: 10de:1292 surfaces: xcb,xlib
Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c
class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 8
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
class-ID: 0403
Device-3: [] driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-6:6 chip-ID: f389:0168
class-ID: 0300
API: ALSA v: k6.5.8-hardened1-1-hardened status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
driver: rt2800pci v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 08:00.0 chip-ID: 1814:3290 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 4000 bus-ID: 09:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 08:00.1 chip-ID: 1814:3298
class-ID: 0d11
Local Storage: total: 238.47 GiB used: 51.66 GiB (21.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SKC600 256G
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 426H scheme: GPT
ID-1: / raw-size: 126.9 GiB size: 126.9 GiB (100.00%) used: 11.81 GiB (9.3%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 859.1 MiB size: 857.4 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4
ID-3: /home raw-size: 102.73 GiB size: 102.73 GiB (100.00%)
used: 39.84 GiB (38.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 126.9 GiB size: 126.9 GiB (100.00%)
used: 11.81 GiB (9.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 126.9 GiB size: 126.9 GiB (100.00%)
used: 11.81 GiB (9.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.7 GiB used: 527.5 MiB (6.7%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 78.0 C mobo: N/A gpu: nvidia temp: 63 C
Fan Speeds (rpm): N/A
Processes: 263 Uptime: 39m wakeups: 1 Memory: total: 8 GiB
available: 7.7 GiB used: 2.31 GiB (30.0%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1658 libs: 478 tools: octopi,paru Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-28
Last full system update: 2023-10-29 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut(custom) mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

i followed instruction in the nvidia archwiki as and install the nvidia-4700xx-utils its the correct version link: NVIDIA - ArchWiki
but i cant figure the problem i changed the runners install the dependencies nothing work i am using optimus-manager too to switch between nvidia and integrated if anyone has any tip or solution tell me

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.