Awful gaming performance after moving from NV to AMD?

Hello fellow users,

  Kernel: 6.3.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=97036dd2-069e-4c8e-9342-dc76d80b5bb7
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Desktop System: Gigabyte product: X570 I AORUS PRO WIFI v: -CF serial: <superuser required>
  Mobo: Gigabyte model: X570 I AORUS PRO WIFI serial: <superuser required> UEFI: American
    Megatrends LLC. v: F37a date: 02/08/2023
  Info: model: AMD Ryzen 7 5800X3D bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check
    built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 2
    microcode: 0xA20120A
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 3717 high: 4450 min/max: 2200/4549 boost: enabled scaling:
    driver: acpi-cpufreq governor: ondemand cores: 1: 3558 2: 4450 3: 3567 4: 3536 5: 3555 6: 3561
    7: 3683 8: 3559 9: 3471 10: 4313 11: 3557 12: 3553 13: 3560 14: 4450 15: 3545 16: 3561
    bogomips: 108801
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine driver: amdgpu
    v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DP-2,DP-3 empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 0a:00.0
    chip-ID: 1002:67df class-ID: 0300 temp: 64.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6000x1440 s-dpi: 96 s-size: 1587x381mm (62.48x15.00")
    s-diag: 1632mm (64.26")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,left model: Dell AW3420DW serial: <filter>
    built: 2019 res: 3440x1440 dpi: 109 gamma: 1.2 size: 798x335mm (31.42x13.19") diag: 865mm (34.1")
    modes: max: 3440x1440 min: 640x480
  Monitor-2: DP-3 mapped: DisplayPort-2 pos: right model: Dell S2716DG serial: <filter>
    built: 2017 res: 2560x1440 dpi: 109 gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
    ratio: 16:9 modes: max: 2560x1440 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 570 Series (polaris10 LLVM 15.0.7 DRM
    3.52 6.3.1-zen2-1-zen) direct-render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: Creative Sound Blaster X3 driver: cdc_acm,hid-generic,snd-usb-audio,usbhid type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3.1.2:6 chip-ID: 041e:3264 class-ID: 0102
    serial: <filter>
  Device-3: JMTek LLC. USB PnP Audio Device driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3.1.3:8 chip-ID: 0c76:161e class-ID: 0300
  API: ALSA v: k6.3.1-zen2-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp6s0 state: down mac:
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-2:3 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 1.84 TiB used: 1.12 TiB (61.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Western Digital model: WD BLACK SN850 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 613200WD temp: 46.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 model: PCIe SSD size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: ECFM12.2 temp: 37.9 C
    scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 642.25 GiB (69.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:4
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:3
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 642.25 GiB (69.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:4
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 642.25 GiB (69.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 642.25 GiB (69.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.26 GiB used: 1.75 GiB (5.6%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 51.8 C mobo: 43.0 C gpu: amdgpu temp: 65.0 C
  Fan Speeds (RPM): fan-1: 927 gpu: amdgpu fan: 615
  Processes: 450 Uptime: 2h 40m wakeups: 0 Memory: available: 31.26 GiB used: 8.64 GiB (27.7%)
  Init: systemd v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1972 libs: 562 tools: octopi,pamac,paru Client: shell wrapper
  v: 5.1.16-release inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-05-07
  Last full system update: 2023-05-12
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

Unfortunately my 2080ti just died which has forced me back to a Radeon RX570. At first nothing worked but then I used the "Auto Install Open Source Driver" in GSM which enabled me to start games. The issue now seems to be that any games that rely on Proton have such bad performance that they're unplayable. Returnal for instance should run at around 60fps on low settings at 1080p but it's 4-10fps. Helldivers shows that it's running 90fps but the actual game is running in slow motion. Native games such as Hollow Knight and Beyond All Reason are running fine. I realize that the RX570 is way slower than the 2080ti but it should still be able to run games fine at 1080p/low settings so it seems like it's something to do with DXVK? Any ideas?

I'll probably go grab a new GPU tomorrow but this will likely determine whether I pick up a new Radeon or stick with Nvidia.

I guess lower performance is definitely to be expected:

Have you tried turning of the compositor? (ALT + SHIFT + F12) This seems to wreck performance for me the most.


That 570 is a true joke for what you want to do. I would suggest say at least a AMD 6600 which from the benchmarks just out performs the 2080. I have a nVidia 1650 and just got a 6600 after comparing it with both the 3060 and the 2060.


I know that it's not a fast card but it can still run games fine at 1080p. If you look at the fpsbenchmark link above I'm getting 1/10th of the fps of what it should have. If it's a native game it's fine. If it's a proton game it's unplayable even if it's a 10 year old game.

Are you using a Multimonitor Setup?

U're saying 1080p but the inxi shows two UWQHD monitors, does it not?

Could slash the perfomance when you try to run 1080p on one of them.

On the other hand, the fact that it only affects proton-games is strange. My RX580 worked as expected with Arch Linux.

1 Like

The only suggestion I can honestly make since I don't game is if you have the space on your OS drive to install another instance of Garuda and see if you have the same issue, or create a secondary profile fist and see what you get.

I was a long-time Nvidia gpu user, recently switched to a 5700 xt, love it. Here is the guide I use. You can also use the Arch wiki, but this is the simplified version;

Generally, AMDGPU is preferable to AMDGPU PRO unless you find you specifically need the pro version for some reason.The additional packages you will need are (with additional 32-bit versions, if needed):

  • linux-firmware: firmware for the GPU (always get this)
  • mesa (lib32-mesa): userspace tools/libraries (always get this)
  • vulkan-radeon (lib32-vulkan-radeon): vulkan support (you very likely want this)
  • xf86-video-amdgpu: X.Org support (ignore if using Wayland)
  • libva-mesa-driver (lib32-libva-mesa-driver): VA-API hardware acceleration (you probably want this if you watch videos)
  • mesa-vdpau (lib32-mesa-vdpau): VDPAU hardware acceleration (you probably don't need this, or if you do you know)
  • radeontop: command-line tool to view GPU utilization (optional)

Another 2080ti fell into my lap so I've installed it. The crazy thing is that I'm still getting the same weird performance issues that I had with the RX570. Games will show 100+ fps but they look like 15 fps. It doesn't matter if I set everything to low and 720p it will be 300fps and unplayable.

I uninstalled and reinstalled the Nvidia driver to no avail.

Heard recent news that its not only ASUS motherboards that are experiencing voltage issues with supporting that CPU; Gigabyte is as well. I've noticed there is a beta version F37 of that BIOS now, with "Optimized performance for 5800X3D". Not sure if that beta bios helps that issue fully (or if that specific AORUS motherboard is effected by that problem) but it is worth looking into regardless.
I can only hope that the beta version should be at bit more stable than the current alpha version you are using at least. I would keep an eye out for future BIOS releases as well.

1 Like

So I was messing around and discovered that if I disable the secondary monitor game performance goes back to where it should be . This also enables G-Sync. Not sure why I need to disable a monitor when I didn't have any issues before but it's progress at least.

Any suggestions on where to go from here?

1 Like

Just to verify, did you:



Sorry I thought I replied to you already. I disabled the compositor; didn't affect performance at all.

1 Like

If multi monitors cause this issue, could you give Wayland a shot?


Alright, so I tried Wayland tonight. Once I rebooted and verified that Wayland was started I tried a few games. The performance was much much better than before (with both monitors active) but there was a bit of stutter that kept it from playing smoothly and textures looked muddy during movement (disabling a monitor had no effect).

I started reading up a bit on Wayland as I always just ignored it since Nvidia doesn't seem to have great support for it and I wanted to find out what I might be in for. Apparently Wayland forces Vsync (eww) and because of that Gsync won't work.

I wasn't happy with that so on a whim I logged out and back in to an X11 session. I wasn't sure what I was going to do but to my utter elation games were now working perfectly with both monitors enabled and with functioning Gsync so everything is silky smooth with pristine image quality.

I'm not sure what changed but switching between Wayland and X11 seems to have reset something somewhere.

Thanks for all the help and suggestions!


As strange as that solution is, now that you mention it I have actually seen it before:

I have no idea why switching to Wayland and back again would change anything, but it does appear to have some kind of effect. If anyone figures out what is actually happening here, I would be curious to hear the explanation! :smile:


If it helps these are the steps that made it happen:

Issue: When running a multimonitor setup games start performing badly on either monitor. Disabling one monitor will restore performance. Toggling from X11 to Wayland and back to X11 seems to fix it and I'll get full performance with both monitors enabled.

  1. Nvidia GPU dies
  2. Install AMD card <-- When the issue started
  3. Install Nvidia card <-- Still occurs
  4. Install Wayland <-- Works better but not great
  5. Switch back to X11 <-- Everything is perfect

I'm sure there are 100 little things that I did in between all of that but these are the biggest events.

My guess it allows for any buffered data to finally be purged.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.