Autostart, Initial bashrc and user file question

Hi!

I come with another question that may be useless again, but here we go:

This is the garuda-inxi command

[email protected] i
╰─λ garuda-inxi
System:
Kernel: 5.19.13-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=69cb4a22-33d6-4af4-8a49-29a7895df4d2 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 systemd.unified_cgroup_hierarchy=0
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 2301
date: 04/19/2019
CPU:
Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen level: v3
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
microcode: 0x8001137
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3353 high: 3393 min/max: 1550/3200 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3392 2: 3393
3: 3393 4: 3200 5: 3374 6: 3200 7: 3386 8: 3391 9: 3391 10: 3349 11: 3379
12: 3390 bogomips: 76652
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: DP-2,DP-3 empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 09:00.0
chip-ID: 1002:67df class-ID: 0300
Device-2: MacroSilicon USB Video type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 3-2:2
chip-ID: 534d:2109 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1200 s-dpi: 96 s-size: 1016x317mm (40.00x12.48")
s-diag: 1064mm (41.9")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,left model: HP ZR2440w
serial: <filter> built: 2012 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
max: 1920x1200 min: 640x480
Monitor-2: DP-3 mapped: DisplayPort-2 pos: primary,right
model: Asus BE24A serial: <filter> built: 2016 res: 1920x1200 hz: 60
dpi: 94 gamma: 1.2 size: 518x324mm (20.39x12.76") diag: 611mm (24.1")
ratio: 16:10 modes: max: 1920x1200 min: 640x480
OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
3.47 5.19.13-zen1-1-zen) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 3-2:2 pcie:
chip-ID: 534d:2109 gen: 3 class-ID: 0300 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0b:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: MacroSilicon USB Video type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
Sound Server-1: ALSA v: k5.19.13-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 151.63 GiB (31.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Plextor model: PX-512M9PeG
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1.07
temp: 42.9 C scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 151.63 GiB
(31.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 151.63
GiB (31.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 151.63
GiB (31.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 151.63
GiB (31.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 37.5 C mobo: N/A gpu: amdgpu temp: 58.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 784
Info:
Processes: 389 Uptime: 4m wakeups: 0 Memory: 15.55 GiB used: 6.54 GiB
(42.1%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1523 libs: 434
tools: octopi,paru,yay Shell: fish v: 3.5.1 running-in: konsole
inxi: 3.3.21
Garuda (2.6.8-1):
System install date:     2022-09-18
Last full system update: 2022-10-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            systemd-oomd.socket

In my previous thread, when i posted this journalctl i noticed there were two lines at the end

1. Sep 28 16:50:37 ROK systemd[3369]: Failed to start Initial Bashrc setup.
2. Sep 28 16:50:37 ROK systemd[3369]: Failed to start BTRFS Assistant Snapper check.

I started searching around, and in settings > startup and shutdown > autostart there were 2 applications ( .desktop files), one was called initial bashrc setup and the other initial user setup. I double clicked these (i didn't know how to open to check what they contained) and they disappeared. Panic ensues because I thought i botched something, tried reboot, and nothing seems off, and in journalctl right now I don't have those two lines anymore. (snap restore didnt bring them back in there)

Are these files something important? Do i have to try to put them back on?
Also since one line was about btrfs assistant is this gonna affect my snaps or something?

Thanks in advance!

That's an interesting find. These are supposed to be run once, deleting themselves afterwards - which basically means everything is alright. However you might have found a bug :eyes: Definitely gotta look into why these aren't run.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.