Auto TDP for laptops

Do we already use something akin to this?

1 Like

wdym? we can just use auto-cpufreq why use something akin to it?

It's already there in chaotic-aur

pacman -Si auto-cpufreq
Repository      : chaotic-aur
Name            : auto-cpufreq
Version         : 1.9.7-2.3
Description     : Automatic CPU speed & power optimizer
Architecture    : any
URL             :
Licenses        : LGPL3
Groups          : None
Provides        : None
Depends On      : python-setuptools  python-distro  python-psutil  python-click  dmidecode
Optional Deps   : cpufreqctl: CPU Power Manager
gnome-shell-extension-cpufreq: CPU Power Manager for GNOME Shell
thermald: recommended to have running alongside by upstream
Conflicts With  : None
Replaces        : None
Download Size   : 54.46 KiB
Installed Size  : 256.96 KiB
Packager        : Nico Jensch <[email protected]>
Build Date      : Friday 02 June 2023 09:55:17 PM
Validated By    : MD5 Sum  SHA-256 Sum  Signature

just don't use power-profiles-daemon with it, they conflict. Plus install themald with it too, it's recommended.


I like power-profiles-daemon, which is preinstalled, quite a lot. It allows me to easily toggle power states via system tray and also depending on quite a lot of other factors. Iirc we shipped auto-cpufreq in the very early days :thinking:


actually power-profiles-daemon is not preinstalled, atleast wasn’t for me. The reason for asking not to install it is because the services power-profiles-daemon.service and auto-cpufreq.service conflict with each other, this is recent. I don’t remember the exact reason for this but when one runs then the other is terminated forcefully. To solve this the developers developed a script that disables power-profiles-daemon.service upon installation in ubuntu but that doesn’t happen in arch due to it’s philosophy. And simply disabling it from systemctl doesn’t seem to be enough to stop power-profiles-daemon.service, it still runs at every boot stopping auto-cpufreq. The only solution after all this that I could find was to either mask the service or to not install it at all.

Well I don’t particularly mind the absence of power-profiles-daemon. I never used it either way though I guess that’s quite a personal thing. Though I am a little curious

For whatever time I had it installed (I didn’t install auto-cpufreq until much later) I never found any such toggle button to switch between states, how did you get it? I thought command line was the only way to interact with it.


Now that you mention it, it might actually be GNOME/KDE only:

1 Like

That's strange I am on KDE dra460nized too. Maybe some service other than power-profiles-daemon.service needs to be enabled for this to work? Like how in warp you need to enable warp-taskbar to use the toggle button they provide apart from enabling warp-svc to use their services.

Guess I will searx around a bit.


I mean by default, shipping it with the ISO and configuring it