Auto brightness adjustment

 ╭─[email protected] in ~
 ╰─λ inxi -Faz
System:    Kernel: 5.15.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=ec03565d-8e80-4014-a8cc-99d0281f1d50 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Micro-Star product: Modern 15 A5M v: REV:1.0
           serial: <superuser required> Chassis: type: 10 serial: <superuser required>
           Mobo: Micro-Star model: MS-155L v: REV:1.0 serial: <superuser required>
           UEFI: American Megatrends LLC. v: E155LAMS.108 date: 07/28/2021
Battery:   ID-1: BAT1 charge: 44.3 Wh (89.5%) condition: 49.5/52.4 Wh (94.3%) volts: 12.3
           min: 11.4 model: MSI BIF0_9 type: Li-ion serial: N/A status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
           arch: Zen 2 family: 17 (23) model-id: 68 (104) stepping: 1 microcode: 8608103 cache:
           L1: 384 KiB L2: 3 MiB L3: 8 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
           bogomips: 50302
           Speed: 1397 MHz min/max: 1400/2100 MHz boost: disabled Core speeds (MHz): 1: 1397
           2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397
           12: 1397
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP:
           conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Lucienne vendor: Micro-Star MSI driver: amdgpu v: kernel
           bus-ID: 04:00.0 chip-ID: 1002:164c class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
           diag: 395mm (15.5")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637
           class-ID: 0403
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Micro-Star MSI
           driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x
           bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
           Device-3: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
           v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.7-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 01:00.0
           chip-ID: 8086:2723 class-ID: 0280
           IF: wlp1s0 state: up mac: <filter>
           Device-2: Lite-On Dell Wireless Device type: USB driver: hid-generic,usbhid
           bus-ID: 3-2:2 chip-ID: 04ca:00ac class-ID: 0301
           IF-ID-1: docker0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:3
           chip-ID: 8087:0029 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
           rfk-block: hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 147.43 GiB (30.9%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AI1
           size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
           type: SSD serial: <filter> rev: ECFK52.8 temp: 30.9 C scheme: GPT
Partition: ID-1: / raw-size: 40 GiB size: 40 GiB (100.00%) used: 23.21 GiB (58.0%) fs: btrfs
           dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 2.8 MiB (0.9%)
           fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
           ID-3: /home raw-size: 50 GiB size: 50 GiB (100.00%) used: 19.02 GiB (38.0%) fs: btrfs
           dev: /dev/nvme0n1p7 maj-min: 259:7
           ID-4: /var/log raw-size: 40 GiB size: 40 GiB (100.00%) used: 23.21 GiB (58.0%)
           fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-5: /var/tmp raw-size: 40 GiB size: 40 GiB (100.00%) used: 23.21 GiB (58.0%)
           fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.19 GiB used: 4.67 GiB (64.9%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A gpu: amdgpu temp: 35.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 432 Uptime: 6h 51m wakeups: 2536 Memory: 7.19 GiB used: 5.67 GiB (78.8%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
           pacman: 1401 lib: 338 Shell: fish v: 3.3.1 running-in: alacritty inxi: 3.3.09

Hello, I am using msi modern 15. My screen brightness keeps auto adjusting I have tried everything but nothing seems to work. sometimes in low ambient light conditions screen goes full dim and vice versa. Even if I manually adjust the brightness after few seconds it will sart auto adjusitng itself. How can I turn this feature off

Comical that it sounds like it's working but inverted.

"I have tried everything" doesn't help a ton so let's start with the most obvious that you have disabled idle dimming in your monitor power management. Also does this happen all the time or just when on AC or Battery?

1 Like

No, that's the right way around. Don't want it going full brightness when it's dark and dark in bright sunshine.

Is there a setting in the bios? This could be feature of the laptop itself (I honestly don't know though, just spit-ballin')

BIOS won't have anything, this is a top level feature you need a config to set to your liking. Which kinda comes back to what I said about inverted. I want my screen up in the dark. This is also contingent if you're one of those whacko's that runs white/bright UI. This is where you need to set your levels. Normally you want max insane BURN MY EYES OUT in sun light but max dim if you're battery is low but also this is subjective because we don't know if the screen is dim on max bright or ripping through your eyes with the power of a thousand suns. I had a ToChiba laptop that on max brightness was worthless heh.

Either way he just asked to disable it which in theory should be the idle time before dim sliders. I've never seen a config to actually set the correct limits and levels of this feature though in Linux.

There will likely be a KDE setting for it (there's a setting in KDE for pretty much everything) - check the power and display settings areas.

1 Like

Idle dimming is disabled on both battery and AC. It happens on both ac and battery.

I have searched for a way to turn off auto brightness or something but couldn't find the option.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.