Audio stopped working, no output devices are detected

I've been using the KDE dragonized version for about two months now and everything was mostly fine, however, two days ago all of a sudden audio stopped working while I was watching some videos. When I checked the audio settings, the output device had "analog stereo duplex" profile, changing it to "analog stereo output" fixed the problem, but introduced constant popping, buzzing and crackling sound. I tried both reinstalling pipewire and switching to pulseaudio through garuda assistant but nothing worked and now my system doesn't even detect any output devices and also there's no "port" options for any device in the settings.

please help, everything worked great out of the box for my system and I wasn't doing anything unusual when it broke

System:
Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6616facf-5f2f-4f6f-9071-292018baf3bc rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME H410M-K R2.0 v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 2421
date: 07/15/2021
CPU:
Info: model: Intel Core i5-10400F bits: 64 type: MT MCP arch: Comet Lake
family: 6 model-id: 0xA5 (165) stepping: 3 microcode: 0xEA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 4192 high: 4261 min/max: 800/4300 scaling:
driver: intel_pstate governor: performance cores: 1: 4194 2: 4154 3: 4121
4: 4197 5: 4206 6: 4196 7: 4199 8: 4203 9: 4261 10: 4208 11: 4175
12: 4198 bogomips: 69597
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1650] vendor: Gigabyte driver: nvidia
v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2188
class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.7x11.9")
s-diag: 1102mm (43.4")
Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 102
size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 93
size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb
class-ID: 0403
Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.44 running: no
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d4d class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.13 TiB used: 214.33 GiB (18.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 054 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-22BBHA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 203.07 GiB size: 203.07 GiB (100.00%)
used: 41.21 GiB (20.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 931.5 GiB size: 931.5 GiB (100.00%)
used: 173.12 GiB (18.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/log raw-size: 203.07 GiB size: 203.07 GiB (100.00%)
used: 41.21 GiB (20.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 203.07 GiB size: 203.07 GiB (100.00%)
used: 41.21 GiB (20.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 20 GiB used: 1024 KiB (0.0%)
priority: 100 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 15.52 GiB used: 1024 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 39 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 64%
Info:
Processes: 311 Uptime: 2m wakeups: 0 Memory: 15.52 GiB
used: 1.94 GiB (12.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 Packages: pacman: 1847 lib: 540 Shell: fish v: 3.3.1
default: Zsh v: 5.8 running-in: konsole inxi: 3.3.12
Garuda (2.5.3-1):
System install date:     2021-12-01
Last full system update: 2022-01-31
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

1 Like

This thread sounds kind of similar to your problem. There are a lot of good troubleshooting efforts in there as well, although it looks like a few folks are actually going to reinstall a fresh ISO for the fix.

3 Likes

none of those troubleshooting methods worked. and I opened this topic after reading and trying everything about this issue that I could find here.

I tried switching to PulseAudio, this resulted in still no audio, no devices being detected. then somehow yesterday, while not doing anything related to audio (just work-related browsing), the notification that audio device was found popped up, but it started to buzz and hiss every second, then after about an hour the system started changing profiles by itself from analog stereo audio output to digital stereo audio output to some random ones for about 10 seconds and then the sound just fcking died again, back to no nothing at all.

Since the problem started in the morning of January 29, I tried rolling back (no effect), I tried downgrading pipewire (no effect). The weirdest part of the whole issue is how it happened without anything being updated or changed in the system.

If I have to reinstall the system completely, how much of my settings would I lose, provided I use separate hdd for home folder and would install same flavor of garuda?

Is garuda not a live-system? I'm asking because I tried booting into fresh iso to check for sound and it shows no devices at all, whereas in manjaro I can at least open up something in browser to verify that there is sound

That is very interesting. My immediate thought would be perhaps Manjaro uses different firmware, or some other part of the audio stack, by default.

What is the equivalent output if you boot to Manjaro?

inxi -Faz

2 Likes

Start looking for hardware problems.

For software, delete local configuration folders, depending on audio server used.
If there was a system failure, restoring a snapshot should have solved it.

3 Likes

After another update today, the configs for kde got messed up, plasma/latte won't load on boot, I can't do anything with my pc anymore, restoring snapshots doesn't do anything, in every restored state this travesty persists. what the hell is happening with the distro, how come it went from rock-solid stable to complete mess in a matter of couple days?

Update: I randomly stumbled into a key combination that opens latte settings, there I found out that the profile for my panels and docks layout contains nothing, but at least I can switch to duplicate profile to get latte back.

Still no sound, no devices, no options for ports in sound settings. I think this might me of some importance for troublesooting:

Summary

● maxim-desktop
State: running
Jobs: 0 queued
Failed: 0 units
Since: Wed 2022-02-02 21:32:32 EET; 16min ago
CGroup: /user.slice/user-1000.slice/[email protected]
β”œβ”€app.slice
β”‚ β”œβ”€app-org.kde.konsole-022a849afe654c65a714fd23a7d708a0.scope
β”‚ β”‚ β”œβ”€86485 /usr/bin/konsole
β”‚ β”‚ β”œβ”€86496 /usr/bin/fish
β”‚ β”‚ β”œβ”€88549 systemctl --user status --state=failed
β”‚ β”‚ └─88550 less
β”‚ β”œβ”€app-systemsettings-5c6104f4d6e0430dadbc6566961abb89.scope
β”‚ β”‚ └─73064 /usr/bin/systemsettings5
β”‚ β”œβ”€dbus.service
β”‚ β”‚ β”œβ”€3524 /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
β”‚ β”‚ └─3779 /usr/lib/kf5/kscreen_backend_launcher
β”‚ β”œβ”€dconf.service
β”‚ β”‚ └─3614 /usr/lib/dconf-service
β”‚ β”œβ”€gamemoded.service
β”‚ β”‚ └─3516 /usr/bin/gamemoded
β”‚ └─obex.service
β”‚ └─3813 /usr/lib/bluetooth/obexd
β”œβ”€background.slice
β”‚ β”œβ”€plasma-kactivitymanagerd.service
β”‚ β”‚ └─3648 /usr/lib/kactivitymanagerd
β”‚ └─plasma-kglobalaccel.service
β”‚ └─3643 /usr/bin/kglobalaccel5
β”œβ”€init.scope
β”‚ β”œβ”€3509 /usr/lib/systemd/systemd --user
β”‚ └─3510 "(sd-pam)"
└─session.slice
β”œβ”€at-spi-dbus-bus.service
β”‚ β”œβ”€3794 /usr/lib/at-spi-bus-launcher
β”‚ └─3800 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3
β”œβ”€pipewire-pulse.service
β”‚ └─3518 /usr/bin/pipewire-pulse
β”œβ”€pipewire.service
β”‚ └─3517 /usr/bin/pipewire
└─wireplumber.service
└─3521 /usr/bin/wireplumber

This is not a criticism, and this is by no means a fix, simply my observations on ways to avoid these types of problems. Running a rolling distro is very different from running a fixed point release model, so other methodologies are sometimes helpful.

Timeshift/snapper is an excellent system rollback feature, but it is in no way a complete backup solution. I would highly advise users to start making incremental backups of their home directory on an external drive. Back In Time is a good utility for ensuring your home directory and all its config files can be easily restored if you ever need to.

If you are too lazy to create proper backups, I'd suggest you become
even lazier. :stuck_out_tongue_winking_eye:

By this I mean if you are reading about serious ongoing issues on the forum skip doing updates until these posts die off. Generally, if a serious bug has occurred that is affecting users it will generally be ironed out before too long with new updates. You will not learn how to correct problems by doing this, but you may avoid some serious problems that require correcting by being extra lazy. :rofl:

I'm not talking about skipping updates for months, but a couple of weeks is no big deal if you want to side step an ongoing issue.

Just some observations, from someone who has never had to reinstall Garuda since the day I first installed it.

4 Likes

Thanks for pointers, getting familiar with snapshots is definitely something I should educate myself further on, being that this exact feature is one of the things that pulled me towards Garuda on this new PC in the first place. Btw, is there a way to give snapshots names in Garuda? Like, if I want to manually create a good one before major updates and have it named/commented. I recently found out that I accidentally got stuck in "restore backup" subvolume of snapper, lol.

On the topic of sound issue – I checked for sound in both Manjaro and the exact Garuda iso that I first installed – no sound in both of those, so it is definitely a hardware issue and now I contacted the manufacturer's service center to get it sorted under warranty. Thanks guys for good talk and decent pointers to various useful things. <3