Audio problem on Asus g18 fresh install

Hello, I’ve just joined to linux family with Garuda Linux (actually flashing garuda-dr460nized-gaming-linux-zen-240428.iso with USBWriter within Windows.). Although I searched many similar problems, I couldn’t solve my issue by myself and decided to get some help.

The issue is related to the Audio on Asus ROG Strix G18 G814JZR. I cannot make the speakers work in any case. I confirmed that they are working physically (Since Asus has some sound when you start the laptop). I tried many solutions on the internet with pipewire and pulseaudio and messed up with the system a lot. At the best point I can see sound playing on pavucontrol (both input and output section), but couldn’t make the speakers produce the sound. This is why I decided to reflash and reinstall the OS. Now I have fresh install so that I can try one solution at a time.

What I tried before;

  • checking sof-firmware installed
  • updated the BIOS
  • in /etc/default/grub , changing GRUB_CMDLINE_LINUX_DEFAULT=“quiet …” to GRUB_CMDLINE_LINUX_DEFAULT=“quiet snd_hda_intel.dmic_detect=0 …” and sudo grub-mkconfig -o /boot/grub/grub.cfg
  • Switching from pipewire to pulseaudio and other options on Garuda Assistant and rebooting in between.
  • Trying to install linux kernel instead of zen and switching different options.
  • Overriding the speakers using hdajackretask along with switching output profiles on audio settings.

Since I tried many solutions that could contradict with each other, I freshly installed the same iso and now I’m open for your suggestions.

garuda-inxi after fresh installation:

Kernel: 6.9.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d94874cf-9442-4b7c-96b3-54e985485ec3 rw rootflags=subvol=@
quiet resume=UUID=06b194df-7bf5-46e0-b4b8-59500f89c9cd loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.2 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Strix G18 G834JZR_G814JZR v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: G834JZR v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: G834JZR.316
date: 05/20/2024
ID-1: BAT0 charge: 89.7 Wh (100.0%) condition: 89.7/90.0 Wh (99.6%)
volts: 17.5 min: 16.0 model: AS3GYFG3KC R220358 type: Unknown
serial: <filter> status: full
Info: model: Intel Core i9-14900HX bits: 64 type: MST AMCP arch: Raptor Lake
gen: core 14 level: v3 note: check built: 2022+ process: Intel 7 (10nm)
family: 6 model-id: 0xB7 (183) stepping: 1 microcode: 0x123
Topology: cpus: 1x cores: 24 mt: 8 tpc: 2 st: 16 threads: 32 smt: enabled
cache: L1: 2.1 MiB desc: d-16x32 KiB, 8x48 KiB; i-8x32 KiB, 16x64 KiB
L2: 32 MiB desc: 8x2 MiB, 4x4 MiB L3: 36 MiB desc: 1x36 MiB
Speed (MHz): avg: 928 high: 1334 min/max: 800/5600:5800:4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 1334 3: 800 4: 800
5: 1300 6: 800 7: 800 8: 800 9: 1265 10: 800 11: 800 12: 800 13: 1180
14: 800 15: 1229 16: 800 17: 959 18: 1300 19: 1300 20: 1300 21: 800
22: 800 23: 800 24: 800 25: 800 26: 936 27: 800 28: 800 29: 800 30: 800
31: 800 32: 800 bogomips: 154828
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Raptor Lake-S UHD Graphics vendor: ASUSTeK driver: i915
v: kernel alternate: xe arch: Gen-13 process: Intel 7 (10nm) built: 2022+
ports: active: eDP-2 empty: DP-4, DP-5, HDMI-A-2, HDMI-A-3
bus-ID: 0000:00:02.0 chip-ID: 8086:a788 class-ID: 0300
Device-2: NVIDIA AD104M [GeForce RTX 4080 Max-Q / Mobile] vendor: ASUSTeK
driver: nvidia v: 555.58.02 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-06) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ ports: active: none empty: DP-1,
DP-2, DP-3, HDMI-A-1, eDP-1 bus-ID: 0000:01:00.0 chip-ID: 10de:27e0
class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:4 chip-ID: 13d3:5458
class-ID: fe01 serial: <filter>
Display: wayland server: v: with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: eDP-2 res: 2048x1280 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (RPL-S)
device-ID: 8086:a788 memory: 15.12 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 10 device: 0 type: integrated-gpu
name: Intel Graphics (RPL-S) driver: mesa intel v: 24.1.3-arch1.1
device-ID: 8086:a788 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 4080 Laptop GPU driver: nvidia
v: 555.58.02 device-ID: 10de:27e0 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 18.1.8 256 bits) driver: mesa llvmpipe
v: 24.1.3-arch1.1 (LLVM 18.1.8) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Raptor Lake High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_soc_avs,snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:7a50 class-ID: 0403
Device-2: NVIDIA AD104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:22bc
class-ID: 0403
API: ALSA v: k6.9.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Raptor Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:7a70 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
port: 3000 bus-ID: 0000:6c:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp108s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Local Storage: total: 953.87 GiB used: 20.56 GiB (2.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN560 SDDPNQE-1T00-1102 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 74114000 temp: 51.9 C scheme: GPT
ID-1: / raw-size: 919.51 GiB size: 919.51 GiB (100.00%)
used: 20.56 GiB (2.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 919.51 GiB size: 919.51 GiB (100.00%)
used: 20.56 GiB (2.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 919.51 GiB size: 919.51 GiB (100.00%)
used: 20.56 GiB (2.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 919.51 GiB size: 919.51 GiB (100.00%)
used: 20.56 GiB (2.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.96 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.06 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (rpm): cpu: 2300
Memory: total: 32 GiB note: est. available: 30.97 GiB used: 5.51 GiB (17.8%)
Processes: 485 Power: uptime: 9m states: freeze,mem,disk suspend: s2idle
avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.34 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1839 libs: 542 tools: octopi,paru Compilers:
clang: 18.1.8 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-07-06
Last full system update: 2024-07-06
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Looking forward for your advices. Thanks in advance.

although I doubt this very much since you have reinstalled your system check out


and ensure none of the volume settings are mute (The MM will be highlighted when not mute)

also try select sound card using f6 in the same utility maybe you are just using the wrong sound card?

There are some reports on the internet of similar problems (not necessarily your model). E.g. from a kernel bug report:
Little chances it will help, but you could easily try the solution for this:

1 Like


Yes I have checked nothing was muted as well. But after you wrote I tried again and figured out that when I exit alsamixer, whenever I try to change volume level it gets muted. That could be a clue.

Also ,there are different options when I press f6 on alsamixer, on default option it says pipewire for both chip and card. When f6 I have options and I’m choosing the Intel one.

And everytime I enter alsamixer, I see the first picture (pipewire as the device)

Am I doing everything right?

What I learnt from you, I was thinking the muted-unmuted part opposite way. So I make all the MM’s green now. May be I can focus trying other solutions again while everything is green.

Thank you for your guidance by the way.

Indeed you have opened new window for me. I will check and let you know as soon as possible. Thank you.

Unfortunately that doesn’t help. But thanks a lot anyways.

At least my headphones and bluetooth is working. I think there will be some kind of update in the future that will fix my speakers too.

1 Like

I’m not sure if this helps, but I happened to encounter some sound issues with my Asus Zenbook. The Github project that worked for me mentions my specific model, but since it’s the same brand perhaps it’s worth a try: Zenbook + Garuda

Thank you, it could be me who couldn’t edit the file properly on the first step but I tried the solution, couldn’t make it. Thank you anyways.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.