Audio Problem (manually-installed Pulseaudio conflicts with Pipewire)

I am having problem with the audio on my system, Each time I start my PC and try to play something nothing cam out of the speaker.when i do pulseaudio -k the sound came back, but after that when i restart the PC again the same problem is there.
These are my system information

parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2c3e9637-10ef-4bc0-90bb-0b245dbe8da9 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Latitude E6420 v: 01 serial: <filter> Chassis: type: 9 
serial: <filter> 
Mobo: Dell model: N/A serial: <filter> BIOS: Dell v: A14 date: 07/11/2012

Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.13.9-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.33 running: yes


Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.33 running: yes

This is confusing me, why do you have pipewire and pulse simultaneously working, like how according to me they are in conflict. Did you manually install pulseaudio?

no i have not installed pulse audio.

As per my knowledge garuda only uses pipewire, try unijstalling pulse

there is no conflict between them

[[email protected] aaryan]# pacman -Qi pipewire   
Name            : pipewire
Version         : 1:0.3.33-1
Description     : Low-latency audio/video router and processor
Architecture    : x86_64
URL             : https://pipewire.org
Licenses        : MIT  LGPL
Groups          : None
Provides        : libpipewire-0.3.so=0-64
Depends On      : rtkit  alsa-card-profiles  libdbus-1.so=3-64  libncursesw.so=6-64
libsndfile.so=1-64  libudev.so=1-64  libusb-1.0.so=0-64  libasound.so=2-64
libsystemd.so=0-64  libbluetooth.so=3-64  libsbc.so=1-64
libldacBT_enc.so=2-64  libfreeaptx.so=0-64  libfdk-aac.so=2-64
libwebrtc_audio_processing.so=1-64
Optional Deps   : pipewire-docs: Documentation
pipewire-media-session: Default session manager [installed]
pipewire-alsa: ALSA configuration [installed]
pipewire-jack: JACK support [installed]
pipewire-pulse: PulseAudio replacement
gst-plugin-pipewire: GStreamer support [installed]
pipewire-zeroconf: Zeroconf support
Required By     : gst-plugin-pipewire  kwin  pipewire-jack  pipewire-media-session
telegram-desktop  wireplumber  xdg-desktop-portal
Optional For    : google-chrome
Conflicts With  : None
Replaces        : None
Installed Size  : 6.57 MiB
Packager        : Jan Alexander Steffens (heftig) <[email protected]>
Build Date      : Thursday 05 August 2021 09:36:50 PM
Install Date    : Friday 06 August 2021 09:09:20 AM
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

[[email protected] aaryan]# pacman -Qi pulseaudio
Name            : pulseaudio
Version         : 15.0-1
Description     : A featureful, general-purpose sound server
Architecture    : x86_64
URL             : https://www.freedesktop.org/wiki/Software/PulseAudio/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : libpulse=15.0-1  rtkit  libltdl  speexdsp  tdb  orc  libsoxr
webrtc-audio-processing  libxtst
Optional Deps   : pulseaudio-alsa: ALSA configuration (recommended) [installed]
pulseaudio-zeroconf: Zeroconf support [installed]
pulseaudio-lirc: IR (lirc) support [installed]
pulseaudio-jack: Jack support [installed]
pulseaudio-bluetooth: Bluetooth support [installed]
pulseaudio-equalizer: Graphical equalizer [installed]
pulseaudio-rtp: RTP and RAOP support [installed]
Required By     : plasma-pa  pulseaudio-bluetooth  pulseaudio-equalizer  pulseaudio-jack
pulseaudio-lirc  pulseaudio-rtp  pulseaudio-support  pulseaudio-zeroconf
Optional For    : bluetooth-autoconnect  firedragon  phonon-qt5  phonon-qt5-gstreamer
Conflicts With  : None
Replaces        : pulseaudio-xen<=9.0  pulseaudio-gconf<=11.1
Installed Size  : 5.81 MiB
Packager        : Jan Alexander Steffens (heftig) <[email protected]>
Build Date      : Wednesday 28 July 2021 05:44:50 PM
Install Date    : Tuesday 03 August 2021 05:53:11 PM
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

tried to uninstall it but didn't worked

╭─[email protected] in ~ took 2s
[🔴] × sudo pacman -R pulseaudio                                                                       (base)
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio breaks dependency 'pulseaudio' required by plasma-pa
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-1' required by pulseaudio-bluetooth
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-1' required by pulseaudio-equalizer
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-1' required by pulseaudio-jack
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-1' required by pulseaudio-lirc
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-1' required by pulseaudio-rtp
:: removing pulseaudio breaks dependency 'pulseaudio' required by pulseaudio-support
:: removing pulseaudio breaks dependency 'pulseaudio=15.0-1' required by pulseaudio-zeroconf

You can only have one pipewire or pulseaudio, it's wierd no conflict flags go off

i tried uninstalling pulseaudio , entire sound options are gone, no audio control nothing is there then i have to restore the system using timeshift.

Install pipewire.

it is there

pacman -Qi pipewire                                                                               (base)
Name            : pipewire
Version         : 1:0.3.33-1
Description     : Low-latency audio/video router and processor
Architecture    : x86_64
URL             : https://pipewire.org
Licenses        : MIT  LGPL
Groups          : None
Provides        : libpipewire-0.3.so=0-64
Depends On      : rtkit  alsa-card-profiles  libdbus-1.so=3-64  libncursesw.so=6-64  libsndfile.so=1-64
libudev.so=1-64  libusb-1.0.so=0-64  libasound.so=2-64  libsystemd.so=0-64
libbluetooth.so=3-64  libsbc.so=1-64  libldacBT_enc.so=2-64  libfreeaptx.so=0-64
libfdk-aac.so=2-64  libwebrtc_audio_processing.so=1-64
Optional Deps   : pipewire-docs: Documentation
pipewire-media-session: Default session manager [installed]
pipewire-alsa: ALSA configuration [installed]
pipewire-jack: JACK support [installed]
pipewire-pulse: PulseAudio replacement
gst-plugin-pipewire: GStreamer support [installed]
pipewire-zeroconf: Zeroconf support
Required By     : gst-plugin-pipewire  kwin  pipewire-jack  pipewire-media-session  telegram-desktop
wireplumber  xdg-desktop-portal
Optional For    : google-chrome
Conflicts With  : None
Replaces        : None
Installed Size  : 6.57 MiB
Packager        : Jan Alexander Steffens (heftig) <[email protected]>
Build Date      : Thursday 05 August 2021 09:36:50 PM
Install Date    : Friday 06 August 2021 09:09:20 AM
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

If it were you wouldn't lose your audio control. Reinstall

I have removed the pulseaudio then everything is gone related to audio. i tried searching for solution i found nothing. Still at this point pipewire was there but still no audio. I did system restore and then pulseaudio -k audio is working again but if i do restart the system again i have to execute the command pulseaudio -k or the sound won't play.

There are a few fishy things here.
It's not possible to have pulseaudio by default because according to my info KDE uses pipwire. And you deny installing
2nd there is no way to have them both install without conflicting.

You need to enable pulseaudio service in systemd, Google how to do that.

1 Like

I tried as you suggested but facing this issue now.

╭─[email protected] in /etc/systemd/system
╰─λ systemctl --system enable pulseaudio.service
Created symlink /etc/systemd/system/multi-user.target.wants/pulseaudio.service → /etc/systemd/system/pulseaudio.service.

╭─[email protected] in /etc/systemd/system took 1s
╰─λ systemctl --system start pulseaudio.service
Failed to start pulseaudio.service: Unit pulseaudio.service has a bad unit file setting.
See system logs and 'systemctl status pulseaudio.service' for details.

╭─[email protected] in /etc/systemd/system took 29ms
[🔴] × systemctl --system status pulseaudio.service
○ pulseaudio.service - PulseAudio system server
Loaded: bad-setting (Reason: Unit pulseaudio.service has a bad unit file setting.)
Active: inactive (dead)

Aug 10 23:48:37 aaryan-latitudee6420 systemd[1]: /etc/systemd/system/pulseaudio.service:6: Unknown key name '>
Aug 10 23:48:37 aaryan-latitudee6420 systemd[1]: pulseaudio.service: Service has no ExecStart=, ExecStop=, or>
lines 1-6/6 (END)

Enable and start the pulseaudio server in systemd.

1 Like

This is not true at all. You can both installed without conflicting.

For example:

yay -Q | grep -E "pipewire|pulse"
libpulse 15.0-1
pipewire 1:0.3.33-1
pulseaudio 15.0-1
pulseaudio-alsa 1:1.2.5-2
pulseaudio-qt 1.3-1
5 Likes

If you have pipewire and don't want pulseaudio then you also want pipewire-pulse .

This is, "pipewire + pipewire-pulse" OR "pulseaudio"

4 Likes

Replace pipewire-support with pulseaudio-support, and Bob's yer Aunt.

1 Like

Thanks everyone, The Problem is solved now, as suggested by @regularCoder need to enable pulseaudio service in systemd. I did it using the help from this website https://rudd-o.com/linux-and-free-software/how-to-make-pulseaudio-run-once-at-boot-for-all-your-users