Audio not working through Speakers but, Bluetooth works fine

Hello there people. I'm relatively new to using Arch Linux. This is a problem I've only been facing very recently. This issue started after I ran "update" as part of a Garuda announcement that there was now a dependency conflict

The issue itself:
Audio playback DOESNT WORK AT ALL when I'm using speakers. This prevents me from watching YouTube videos or playing any kind of audio at all. When I connect my Bluetooth headphones everything works fine but, the speakers do not.

inxi -Faz Output:

System:    Host: msreddy-G3-3500 Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=721db9d0-601f-4e5a-972d-402b157edef8
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=22b6b363-82a8-42bd-be47-7314726701c3 loglevel=3
           Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: G3 3500 v: N/A serial: <superuser required> Chassis:
           type: 10 serial: <superuser required>
           Mobo: Dell model: 0Y7260 v: A00 serial: <superuser required> UEFI: Dell v: 1.10.1
           date: 08/13/2021
Battery:   ID-1: BAT0 charge: 50.1 Wh (100.0%) condition: 50.1/51.0 Wh (98.2%) volts: 13.0 min: 11.4
           model: BYD DELL M4GWP06 type: Li-poly serial: 1634 status: Full
CPU:       Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake family: 6
           model-id: A5 (165) stepping: 2 microcode: EA cache: L2: 12 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399
           Speed: 4803 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 4803 2: 4868 3: 4801 4: 4743
           5: 4793 6: 4800 7: 4773 8: 4618 9: 4634 10: 4859 11: 4785 12: 4735
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell driver: nvidia v: 470.74
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3
           chip-ID: 0c45:671f class-ID: 0e02
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142 size: 344x194mm (13.5x7.6")
           diag: 395mm (15.5")
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: sof-audio-pci-intel-cnl
           alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8
           class-ID: 0401
           Device-2: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 01:00.1
           chip-ID: 10de:10fa class-ID: 0403
           Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: yes
           Sound Server-5: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
           chip-ID: 8086:06f0 class-ID: 0280
           IF: wlp0s20f3 state: up mac: 9c:fc:e8:41:a9:d8
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169
           v: kernel port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp4s0 state: down mac: 8c:47:be:20:0c:cd
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8
           bus-ID: 1-14:5 chip-ID: 8087:0aaa class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: 9C:FC:E8:41:A9:DC
Drives:    Local Storage: total: 1.14 TiB used: 28.89 GiB (2.5%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM991 NVMe 256GB size: 238.47 GiB
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
           serial: S50ANF2N620886 rev: 25309039 temp: 39.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: 70CRTEL5T rev: 01
           scheme: GPT
Partition: ID-1: / raw-size: 221.38 GiB size: 221.38 GiB (100.00%) used: 28.89 GiB (13.0%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
           dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 221.38 GiB size: 221.38 GiB (100.00%) used: 28.89 GiB (13.0%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw-size: 221.38 GiB size: 221.38 GiB (100.00%) used: 28.89 GiB (13.0%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 221.38 GiB size: 221.38 GiB (100.00%) used: 28.89 GiB (13.0%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 16.83 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/nvme0n1p3 maj-min: 259:3
           ID-2: swap-2 type: zram size: 15.3 GiB used: 2.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 363 Uptime: 15m wakeups: 1313 Memory: 15.3 GiB used: 3.85 GiB (25.1%) Init: systemd
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2075 lib: 535
           Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

I've tried to find a solution but, I didn't find many. And the ones that turned up were basically asking me to install packages which were already installed on my system. So, I decided I'd ask here before breaking my system.

Hi there, welcome!
I know this may sound stupid, but have you already checked that everything is OK in the Volume widget on the panel and in your Audio Settings?
It once happened to me e.g. that for some reasons my speakers profile was set to stereo input, so it was not working.

1 Like

Hey filo. Thanks for the reply.

Yes, I did check the Volume Widget and the Speaker/Mic profiles. I even tried to test the speakers through the provided test in Settings but, it wasn't working.

If allowed, I can even post a Screenshot of my Audio Tab in Settings

No need to proof your Audio Tab, we believe you! :wink:
Assuming that yesterdy's update went OK (I saw several threads around wireplumber and pipewire-media-session in conflict), this could be something new due to wireplumber.
I have no experience on it, the only thing I can provide is the link to the upstream project.
Maybe you could see if there is any known issue like yours (I saw a similar one, but it's specific to built-in audio connecting with HDMI / display port).
In addition to that, maybe you could gather information and check in your system with regards to the configuration (I see the initial, documentation, issue explaining the interested services and relevant configuration files)...

1 Like

I am not sure if it's an issue with wireplumber itself but, for some reason the video and audio work fine "for a while" after starting up. And then, YT starts buffering and then stops. From then on, no audio works at all.

I'll try replacing wireplumber with pipewire-media-session and let you know how it goes. If it works then, at least ik that it's not my issue.

1 Like

Hey Filo thanks a lot for replying.

I just solved my issue through the following steps, if it might help anyone in the future:
I just went through the output of inxi -FaZ when I started my system up and after the audio stopped working and I noticed pipewire was going On/Off randomly.

so I tried running

pipewire

and there was this error

[E][00201.602550] mod.protocol-native | [module-protocol-:  606 lock_socket()] server 0x558e41421b60: unable to lock lockfile '/run/user/1000/pipewire-0.lock': Resource temporarily unavailable (maybe another daemon is running)
[E][00201.602636] pw.conf      | [          conf.c:  412 load_module()] 0x558e413e47a0: could not load mandatory module "libpipewire-module-protocol-native": Resource temporarily unavailable
[E][00201.602684] default      | [      pipewire.c:  123 main()] failed to create context: Resource temporarily unavailable

so I figured there must be some kind of pipewire conflict so I ran this command to terminate pipewire

systemctl --user stop pipewire.service pipewire.socket

And somehow the audio and YT playback started working!

Now, I'm not sure what exactly is going on. I tried searching for pipewire processes and this is what pops up

╭─[email protected] in ~ took 18ms
╰─λ ps ax | grep pipewire
24567 pts/1    S<+    0:00 grep --color=auto pipewire

Previously before termination, this was what showed up

╭─[email protected] in ~ took 4ms
[⚡] × ps ax | grep pipewire
6987 ?        S<sl   0:00 /usr/bin/pipewire
14971 pts/1    R<+    0:00 grep --color=auto pipewire

But the audio and video seem to be working perfectly for now. What could've been the issue? And is pipewire stopping my audio from working? Is this an issue with Garuda handling pipewire or with pipewire itself? Please do let me know for future reference.

Sorry, this is out of my reach. I hope someone else can help you.
I was pointing directly to wireplumb only because I read that it all started after yesterday's update after the announcement...
By-the-way, the update script has just been adjusted, I think you should give it another try.

1 Like

Replacing wireplumber with pipewire-media-session permanently fixed the issue. If possible, please do look into this Garuda Team

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.