Assassin's Creed Valhalla not running

I would love to get Assassin's Creed Valhalla running, but since a game update some months ago I can't get it to work anymore. Maybe someone can help here?

I've tried to install Ubisoft Connect with Lutris and Bottles. I have read in many forums and tried the weirdest hints given there. I have tried to get it to run under Garuda, EndeavourOS, Linux Mint and Ubuntu. Not only that, but I tried different versions of GE Proton on each os. DXVK and VKD3D enabled. I have tried to turn esync and fsync on and off. I have added d3dx11 and d3dx12 libraries. Now I don't have any more ideas how I could get it to work.

Does anyone play Valhalla under Garuda and can help me with that?

Please do not post help requests under Community, as they are off-topic.

You can post there again but without the gaming problem. Thank you. :slight_smile:

1 Like

I'm not a gamer :wink:, but checking on protondb I've found this comment. It seems recent, so, if you want, give a look at it...
Oh well, I see now you probably already tried it...

1 Like

Hey, this post is new, thank you! I have searched protondb several times in the past, but there was no entry for Valhalla.

Unfortunately this doesn't work for me. Same problem as always. The small splash screen appears and after a few seconds it closes and the game doesn't start.

I think there must be an issue with DX12. All DX11 games are working fine. Valhalla is the only DX12 game I want to play so far. Or it is caused by version 1.6 and later of the game. I had running with 1.5x a few months ago.

I think it's time to provide your garuda-inxi.
Do you know if your GPU fully supports DX12?

1 Like

I have a RTX2080. It supports DX12 for sure. I have played some DX12 games on Windows before I switched over to Linux last year.

Here is my garuda-inxi, hope it helps :slight_smile: :

Kernel: 6.0.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=*** rw [email protected]
root=/dev/mapper/*** quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: Z390 AORUS PRO WIFI v: N/A
serial: <superuser required>
Mobo: Gigabyte model: Z390 AORUS PRO WIFI-CF v: x.x
serial: <superuser required> UEFI: American Megatrends v: F12k
date: 01/19/2021
Info: model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 4398 high: 4406 min/max: 800/4700 scaling:
driver: intel_pstate governor: performance cores: 1: 4398 2: 4389 3: 4400
4: 4394 5: 4400 6: 4394 7: 4400 8: 4400 9: 4400 10: 4406 11: 4399 12: 4400
bogomips: 88796
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: Gigabyte driver: nvidia
v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1e82 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 60 s-size: 1626x914mm (64.02x35.98")
s-diag: 1865mm (73.44")
Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 61
size: 1600x900mm (62.99x35.43") diag: 1836mm (72.27") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX
2080/PCIe/SSE2 direct render: Yes
Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10f8 class-ID: 0403
Sound API: ALSA v: k6.0.9-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
driver: hid-generic,usbhid bus-ID: 1-10:3 chip-ID: 0b05:1949 class-ID: 0301
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:8 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 2.39 TiB used: 656.68 GiB (26.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte
model: GP-ASM2NE2512GTTDR size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: ECFM12.2 temp: 32.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Sabrent model: Rocket Q
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: RKT30Q.1 temp: 26.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 type: USB vendor: IBM model: ESA3SF1120GB
size: 111.79 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> scheme: GPT
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 137.13 GiB (28.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-***
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 752 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:2
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 137.13 GiB (28.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-***
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 137.13 GiB (28.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-***
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 137.13 GiB (28.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-***
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.3 GiB used: 25.8 MiB (0.1%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 39.0 C pch: 36.0 C mobo: N/A gpu: nvidia
temp: 58 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 393 Uptime: 5h 30m wakeups: 1 Memory: 31.3 GiB
used: 10.98 GiB (35.1%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1934
pm: pacman pkgs: 1929 libs: 516 tools: gnome-software,pamac,paru pm: flatpak
pkgs: 5 Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: yakuake
inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-18
Last full system update: 2022-11-26 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:
1 Like