AR9485 - network issues

Hi all,

I'm quite new to Arch and Garuda. I've been running linux in all my machines for quite a long time now. I'm no expert but generally I can find my way around the issues that I've encountered during this time. Yet, after installing Garuda, I'm having consistent connection issues (almost 2 months now). At first I couldn't connect with the internet at all, I then uninstalled and installed the driver again. After that, some how, the wifii came back to life, but since then I'm having issues with signal strength and I'm unable to connect with anything beyond 30 cm from the computer. Network is also unable to discovery my 2.4g and 5g wifii (router is 2,5m away from machine). Just to be clear, I have run around and tried different solutions over this 2 months, but now this issue has become super annoying, mainly because I couldn't solve it.

Thanks in advance!!!!!

Here is my inxi output:

System:    Kernel: 5.12.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c9b0eb2a-e0b4-4d96-a96b-92c0c09ddf77 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=cdacd386-5cea-468b-aebd-00827cc39a98 loglevel=3 
Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Sony product: SVE15128CGW v: C904QZ2H serial: <filter> Chassis: type: 10 
serial: N/A 
Mobo: Sony model: VAIO serial: N/A UEFI-[Legacy]: Insyde v: R0140D6 date: 08/23/2012 
Battery:   ID-1: BAT0 charge: 24.3 Wh (100.0%) condition: 24.3/45.4 Wh (53.6%) volts: 12.4 min: 10.8 
model: SONY Corp. VGP-BPS26 type: Li-ion serial: <filter> status: Full 
CPU:       Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 
model-id: 3A (58) stepping: 9 microcode: 21 cache: L1: 64 KiB L2: 3 MiB L3: 3 MiB 
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19954 
Speed: 2695 MHz min/max: 1200/3100 MHz base/boost: 2500/2500 volts: 0.8 V ext-clock: 100 MHz 
Core speeds (MHz): 1: 2695 2: 2084 3: 2924 4: 2544 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
Type: l1tf mitigation: PTE Inversion 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds status: Vulnerable: No microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Thames [Radeon HD 7550M/7570M/7650M] vendor: Sony driver: radeon v: kernel 
bus-ID: 01:00.0 chip-ID: 1002:6841 class-ID: 0300 
Device-2: Acer USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-1.3:4 chip-ID: 5986:02d3 
class-ID: 0e02 
Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: ati,radeon 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1848 s-dpi: 96 s-size: 506x487mm (19.9x19.2") s-diag: 702mm (27.6") 
Monitor-1: LVDS res: 1366x768 hz: 60 
Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23") 
OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.12.6-zen1-1-zen LLVM 11.1.0) v: 3.3 Mesa 21.1.1 
compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Sony driver: snd_hda_intel 
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] vendor: Sony 
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 1002:aa90 class-ID: 0403 
Sound Server-1: ALSA v: k5.12.6-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.28 running: no 
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Foxconn Unex DHXA-225 
driver: ath9k v: kernel port: 5000 bus-ID: 02:00.0 chip-ID: 168c:0032 class-ID: 0280 
IF: wlp2s0 state: up mac: <filter> 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Sony driver: r8168 
v: 8.048.03-NAPI modules: r8169 port: 2000 bus-ID: 0e:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp14s0 state: down mac: <filter> 
Bluetooth: Device-1: Foxconn / Hon Hai Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 
bus-ID: 1-1.2:3 chip-ID: 0489:e036 class-ID: e001 serial: <filter> 
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:    Local Storage: total: 698.64 GiB used: 32.51 GiB (4.7%)
ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS547575A9E384
family: HGST Travelstar 5K750 size: 698.64 GiB block-size: physical: 512 B logical: 512 B
sata: 2.6 speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A50B temp: 41 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 2y 136d 7h cycles: 8324
Partition: ID-1: / raw-size: 689.83 GiB size: 689.83 GiB (100.00%) used: 32.51 GiB (4.7%) fs: btrfs
block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 689.83 GiB size: 689.83 GiB (100.00%) used: 32.51 GiB (4.7%) fs: btrfs
block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 689.83 GiB size: 689.83 GiB (100.00%) used: 32.51 GiB (4.7%) fs: btrfs
block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 689.83 GiB size: 689.83 GiB (100.00%) used: 32.51 GiB (4.7%) fs: btrfs
block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
maj-min: 8:2
ID-2: swap-2 type: zram size: 1.44 GiB used: 116.1 MiB (7.9%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.44 GiB used: 106.6 MiB (7.2%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.44 GiB used: 110.6 MiB (7.5%) priority: 32767 dev: /dev/zram2
Sensors:   System Temperatures: cpu: 73.0 C mobo: 56.0 C gpu: radeon temp: 69.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 243 Uptime: 10m wakeups: 1 Memory: 5.75 GiB used: 3.64 GiB (63.4%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1487 lib: 350
Shell: fish (sudo) v: 3.2.2 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.04

Try to give a look at cause #5 here.
https://wiki.archlinux.org/title/Network_configuration/Wireless
They suggest boot parameter intel_iommu=off
Maybe if that doesn't help you could try also iommu=off

1 Like

cheers filo for your quick reply, I tried =, nothing happened! I also try to install the lts kernel, did not work, jumped back to zen, and now grub give me a error during boot: "error: need to load kernel first "

Sorry it didn't work.
So now you can't launch zen kernel from GRUB, but the lts one still works I hope?
In that case you could try to update-grub or reinstall the zen and retry...

I've a few snapshots,and I'm running on it as a quick fix, just running a -Syu to see if it can fix the problem by updating the zen image, buapparently this isn't a very serious error.

Ok. After restoring a snapshot try a reboot.
Sometimes installing when in the middle of a restore created troubles.

In the meanwhile I found a couple of other things you could try:
1

echo "options ath9k btcoex_enable=1" | sudo tee /etc/modprobe.d/ath9k_btcoex.conf

2

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

Both of course require a reboot, and if not working just remove each of those .conf files.

2 Likes

This statement makes littles sense as the "driver" is included directly in every modern kernel. The driver cannot be directly installed/uninstalled, as it is part of the Linux kernel. Please clarify your above statement and what you actually have done.

Have you tested this system with other Linux distros? How is your reception on other distros? Note which kernel and linux-firmware version is being used if you find a distro that works well.

Have you tried disabling wifi power saving and MAC Address randomization? This can be easily done though the Garuda Network Assistant. Reboot both your computer and your router after implementing these changes.

I would also try changing your router's channel bandwidth to 20Mhz, and test out different channels rather than using auto selection. There are tools you can install on your phone to aid in the best chanel to select in your home wifi area if congested with other signals.

Also test disabling IPv6 while in your routers setting utility.

I would also suggest testing further kernels such as lnux and linux-mainline.

Is your bios the most current version available?

Double check that you have the crda package installed and that your regdomain (REGDOM) is set to your home country. Search this info online.

If you use Bluetooth I would suggest disabling it temporarily as a test. If you do not use Bluetooth I would suggest disabling it permanently. There are many ways to do this. Search is your friend.

Have you tested Garuda from one of the most recent live environments? I would test the live environment using the LXQT-Kwin edition for troubleshooting purposes. This is extremely important as problems with this adapter have been linked to Network Manager usage. The LXQt edition uses Connman for managing your network connection and may fix this issue. Please do not request further help until you have tested the live LXQt ISO for troubleshooting purposes.

Please answer all my questions and test all suggestions for further assistance. Incomplete answers or failing to provide feedback on all suggestions is not likely to result in a resolution to your issue. To find the proper solution this issue must be worked through methodically in sequence. All the first questions/suggestions must be answered/implemented before further progress can be made.

Welcome to the Garuda forum BTW.

5 Likes

Hi TBG, thanks for your reply! And sorry for the wait.

1st – I used both pacman -R and modprob –ignore-remove all modules as follow: ath9k, ath9k_common, ath9k_hw, ath, r8169 and realtek. Please, note that I previously have clone the git files for all modules been purged and I only needed to makepkg.

2nd – I have run 4 linux distros with their respective stock kernel previously without any problems, please note that all kernel used were derivated from Linux kernel either the 4.y.z and/or 5.y.z.

3rd – Both power save and mac address random are set off for a long time.

4th – I’ve re-config my router, disabled Ipv6, yet I can not change the cahnnel bands. My router only accepts predefined ranges (20Mhz – 40Mhz, for 2.5G) and (60Mhz – 160Mhz - 5G) and automatically choose between these arrays (router is a Sagemcom, EMTA D3.1).

5th – Unfortunaly, every time that I try to change the kernel, I’m contrasted with either a error that does not allow me to install the kernel (error is related with timeshift package) or either after install I’m surprized by a grub msg saying that it cannot find the kernel (I think it is related with the btrfs file system), so I’m unable to jump to Linux kernel, which I think would run the adapters without any problem.

6th – Used the live LXQt and Comnman, no luck there! Same issue.

Cheers,

Well then it sounds like you've got real problems with your system if you can't install and change kernels properly.

I know it's a headache, but in your case I would also suggest downloading a Garuda XFCE ISO to boot the live environment. The Xfce ISO uses the LTS kernel, so that will narrow down a bit if the kernel is a major part of the problem.

Thank you for your concise report on your efforts.

5 Likes

How about a report on these suggestions as well.

3 Likes

Are you using only the Garuda assistant tool or also the command line?
I'm asking this because yesterday I got a timeshift error from the assistant tool, while the installation via pacman went smoothly.
I understand this is a difficult situation but trying different kernals can really help.

3 Likes

Hi @tbg ,

I managed to install the Linux 5.y.z kernel,

mhwd-kernel -li
Currently running: 5.12.8-arch1-1 (linux)
The following kernels are installed in your system:
local/linux 5.12.8.arch1-1
local/linux-zen 5.12.8.zen1-1

Now my machine somehow manage to finding the router and connection, yet low strength (around 25%), only my 2.5Ghz band, and every time that I try to connect I get in a semi-infinite loop of "configuring interface" or something like that.

I'm going to install the LTS kernel and see if it gets any better!

cheers for all support.

@tbg ,

crda is installed, but I believe that some conflict is happening, since it comes back

crda
COUNTRY environment variable not set.

But, if I request the iw it return as the correct country

iw reg get
global
country BR: DFS-FCC
(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 80), (N/A, 17), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 24), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 24), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
phy#0
country 99: DFS-UNSET
(2402 - 2472 @ 40), (N/A, 20), (N/A)
(2457 - 2482 @ 40), (N/A, 20), (N/A), PASSIVE-SCAN
(5140 - 5360 @ 80), (N/A, 30), (N/A), PASSIVE-SCAN
(5715 - 5860 @ 80), (N/A, 30), (N/A), PASSIVE-SCAN

I'm trying to figure out how to solve it for now...

@filo tks, I managed to install the kernel using cmd line as you saied!

cheers,

1 Like