April 2023 bug : Garuda Linux booting into TTY or terminal instead of Login screen after recent upgrade

Hello Garuda users.

So, yesterday after updating and restarting, I was thrown into TTY instead of default login screen in Garuda Linux Cinnamon edition.
And I am pretty sure that many of the other users are facing this issue as well, so I am creating this post.

The simplest solution to this is first of all, login to the shell using your username and password.

Then simply write

sudo systemctl enable --now lightdm.service

and enter password.
It should show up login screen now. You may also reboot and check.

For other editions, you will have to enable their respective display manager. Like for KDE, it is sddm instead of lightdm but I am not sure whether the same problem exists in KDE editions also, and whether this will solve the issue.

Edit :
Yeah, for KDE, use command

sudo systemctl enable --now sddm.service

Also, please use garuda-update to update your system. It already contains the patch!

Anybody still facing similar issue is requested to report here.

Thank You


I noticed that it was after updating the package "plymounth-git 22.02.122.r170".

here is my message with details:

Garuda Linux ISO Builds is not installed for the same reason. At the initial download, there is no graphical environment, it asks for a login password.


Plz download the ISO from here Garuda Linux | Download
The other URL you had are for daily builds and usually not recommended.

However after upgrading the 230319 ISO from the link I provided you will have the same issue, which is why you need to enable the proper service for KDE (now with those changes I am unsure which service file it should be, probably sddm.service). following Naman's step.

Thank you, I know about it.

1 Like


I use KDE and have the same problem after the update.
Helped me as described above

sudo systemctl enable --now sddm.service


Thank you for this post, this was a quick resolution to a confusing bug. Garuda has always been rock solid for me otherwise.

Much appreciation,



I've been running into, probably, this error for the last few days. Everytime I update I get thrown to the the emergency shell after reboot, and I've went countless times back to older snapshots. I've seen this solution posted in a few places but, and this probably seems stupid to all you linux buffs, what does this mean:

The simplest solution to this is first of all, login to the shell using your username and password.

Specifically "login to the shell"? The terminal I'm thrown into seems to have no CLI utilities, and googling this doesn't seem very helpful when all the commands out there simply "don't exist"... Would be really helpful to the less initiated as to what I'm supposed to run in order to "login to the shell".

Hi there, welcome to the community

First of all, if you can boot into snapshot, boot into it, restore it, and use garuda-update. It already have the patch.


You have to just enter your username and password

For example, it should show your pc name, and then after login : , write your username that you made during installation, and press enter. Now, it should ask for password. Enter password, and you have successfully logged in.

I hope this helps. If you still have a doubt, feel free to ask.


If you went before the plymounth-git 22.02.122.r170 installation and used garuda-update, it shouldn't be dropping you into TTY on restart.
(The fix should be automatically applied with garuda-update using its garuda-migrations 2.3.0 from 5 days ago)


Yeah, seeing also Naman's reply makes me think I have a different issue. I'm seeing a different shell with nothing about login:

mount: /new_root: can't find UUID=59a871de-53c2-4f5a-9d77-585560603a81 
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

Thanks for the quick replies though, I'll keep searching for a solution.

Yeah that is a different issue.
If you don't find a solution, plz open a specific Help Request for that so we can follow properly.
Good news is, this issue you experience has loads of hits on Google and I have seen some threads here on the Forum about that. So it's a good start.


I ran into the same issue today. It seems like the initial ramdisk isn't being automatically built successfully after updating systemd.

I was able to revert back to an earlier snapshot, and resolved the issue by running garuda-update, followed by "sudo mkinitcpio -p linux-zen" to manually build the image. After that, I could reboot my system and everything works as expected.


This bug is now in the latest kde ISO (dr460): 20230409

'startx' is not working, but the given solution in post #1 works. Didn't do the fresh install.


A post was split to a new topic: Gnome - booting issue