Apps that need authentication does not open / ask for password

I'm an old Arch user, but new to Garuda. I just installed and it looks great! I just stumbled across my first hurdle though. Apps won't authenticate / ask for password. So I cannot open apps like Timeshift or Firewall that needs administrative privileges. I'm using Garuda KDE edition. It's a clean install with nothing else done yet.

1 Like

Hi and Welcome, Timeshift and the firewall needs admin rights to open. This is normal like updating the OS.

2 Likes

I know they need authentication. That is the problem - they don't ask for authentication and fail to open. This is not normal. I suspect it's a polkit problem. If i run ❯ /usr/lib/polkit-kde-authentication-agent-1 the apps work fine, but I do not want to do this everytime I want to run an app that needs admin rights.

Have you tried to update and reboot your computer yet?

1 Like

Yes, Several times. I even reinstalled. Problem persist.

Did you try this?

2 Likes

I already stated this - "If i run ❯ /usr/lib/polkit-kde-authentication-agent-1 the apps work fine, but I do not want to do this everytime I want to run an app that needs admin rights." This is a workaround, yes, but it's hardly a solution.

Can you please tell us exactly which version lite / ultimate / barebones and from what date you installed KDE?

With me from the terminal, timeshift opens immediately after asking for the password.

timeshift-launcher
Anwendungskonfiguration geladen: /etc/timeshift.json

/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,commit=120,subvolid=5,subvol=/

So please use the terminal for this app you want to start and post the output here, maybe we can see what is missing.


edit: librewish know it is a KDE bug, so, maybe it is fixed with next update. :slight_smile:

2 Likes

I'm using KDE ultimate from 201022

As I suggested previously, the error seems to be related to polkit -
❯ timeshift-launcher ─╯ ==== AUTHENTICATING FOR org.freedesktop.policykit.exec ==== Authentication is needed to run /usr/bin/env' as the super user
Authenticating as: George van der Westhuizen (george)
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie`

Thanks for the response. Let's hope it will be fixed soon, as I really like this distro!

3 Likes

Not sure it's about a fix from kde. Hopefully.
What if you use pkexec <application> in terminal?

1 Like

This error makes me wonder if the system is not finding your "magic cookie". In that case you could export XAUTHORITY=/home/$USER/.Xauthority.

You can also prefix apps that have this issue with the proper environment variable that is missing.

Example:

XAUTHORITY=/home/$USER/.Xauthority pamac-manager

If that works, then you could start it from the terminal in that manner. However, it would be more convenient to simply export the environment variable or edit the desktop launcher to add the environment variable in front of the executable name. That way you could start the app from your dock/start menu as usual with a modified desktop startup file.

No idea if that's the actual problem, I'm just spit balling here.

1 Like