Applications seem to be confused on what theme to use

It seems that some of my applications (PasswordSafe, Pale Moon, Garuda Boot Options and some others) don’t know I’m trying to use a dark theme and instead use light theme. Pale Moon has a theming system and I even use the Dark Moon theme however, the tab groups thing? It doesn’t know. Might be a GTK thing however it seems that all solutions that I found on the internet have failed.
I made my own colour scheme so maybe that could be the problem? I mean, this only happened after fiddling around with the settings to make it look how I want it. Couldn’t find info on that either.
And no, Kvantum and Qt5 Settings Gui don’t show my colour scheme.
Am I supposed to create a specific and separate dark theme? I tried searching that up too and didn’t get anything.


Kernel: 6.9.4-arch1-1 arch: x86_64
bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc
avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
rw rootflags=subvol=@ loglevel=3
Desktop: KDE Plasma v: 6.0.5
tk: Qt v: N/A info: frameworks
v: 6.3.0 wm: kwin_x11
with: krunner vt: 2 dm: SDDM
Distro: Garuda base: Arch Linux
Type: Laptop System: HP
product: HP ZBook 17 G3 v: N/A
serial: <superuser required>
Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 80D6
v: KBC Version 10.75
serial: <superuser required>
part-nu: 1MY26EC#ABA
uuid: <superuser required>
UEFI: HP v: N81 Ver. 01.45
date: 01/06/2020
ID-1: BAT0 charge: 14.8 Wh (20.9%)
condition: 70.9/70.9 Wh (100.0%)
volts: 10.5 min: 11.4
model: Hewlett-Packard Primary
type: Li-ion serial: <filter>
status: discharging
Info: model: Intel Core i5-6440HQ
bits: 64 type: MCP arch: Skylake-S
gen: core 6 level: v3 note: check
built: 2015 process: Intel 14nm
family: 6 model-id: 0x5E (94)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4
smt: <unsupported> cache:
L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB
L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 800
min/max: 800/3500 scaling:
driver: intel_pstate
governor: powersave cores: 1: 800
2: 800 3: 800 4: 800
bogomips: 20810
Flags: avx avx2 ht lm nx pae sse
sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 530
vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9
process: Intel 14n built: 2015-16
ports: active: eDP-1 empty: DP-1,
DP-2, DP-3, HDMI-A-1, HDMI-A-2,
HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:191b class-ID: 0300
Device-2: NVIDIA GM204GLM [Quadro
M3000M] vendor: Hewlett-Packard
driver: N/A alternate: nouveau
non-free: 545.xx+ status: current
(as of 2024-04; EOL~2026-12-xx)
arch: Maxwell code: GMxxx
process: TSMC 28nm
built: 2014-2019 pcie: gen: 3
speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:13fa
class-ID: 0300
Device-3: Cheng Uei Precision
Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 1-7:2
chip-ID: 05c8:0383 class-ID: 0e02
Display: x11 server: X.Org
v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X:
loaded: modesetting
alternate: fbdev,intel,vesa
dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080
s-dpi: 96
s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1
model: ChiMei InnoLux 0x1738
built: 2015 res: 1920x1080 hz: 60
dpi: 128 gamma: 1.2
size: 381x214mm (15x8.43")
diag: 437mm (17.2") ratio: 16:9
modes: 1920x1080
API: EGL v: 1.5 hw:
drv: intel iris platforms: device: 0
drv: iris device: 1 drv: swrast
surfaceless: drv: iris x11:
drv: iris inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5
vendor: intel mesa v: 24.1.1-arch1.1
glx-v: 1.4 direct-render: yes
renderer: Mesa Intel HD Graphics
530 (SKL GT2) device-ID: 8086:191b
memory: 7.57 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 10
device: 0 type: integrated-gpu
name: Intel HD Graphics 530 (SKL
GT2) driver: mesa intel
v: 24.1.1-arch1.1
device-ID: 8086:191b
surfaces: xcb,xlib device: 1
type: cpu name: llvmpipe (LLVM
17.0.6 256 bits)
driver: mesa llvmpipe
v: 24.1.1-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000
surfaces: xcb,xlib
Device-1: Intel 100 Series/C230
Series Family HD Audio
vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel
alternate: snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:a170
class-ID: 0403
Device-2: NVIDIA GM204 High
Definition Audio
vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel
pcie: speed: Unknown lanes: 63
link-max: gen: 6 speed: 64 GT/s
bus-ID: 01:00.1 chip-ID: 10de:0fbb
class-ID: 0403
API: ALSA v: k6.9.4-arch1-1
status: kernel-api with: aoss
type: oss-emulator
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.7
status: active with:
1: pipewire-pulse status: active
2: wireplumber status: active
3: pipewire-alsa type: plugin
4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-LM
vendor: Hewlett-Packard
driver: e1000e v: kernel port: N/A
bus-ID: 00:1f.6 chip-ID: 8086:15b7
class-ID: 0200
IF: enp0s31f6 state: down
mac: <filter>
Device-2: Intel Wireless 8260
driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 8086:24f3
class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Info: services: NetworkManager,
systemd-timesyncd, wpa_supplicant
Device-1: Intel Bluetooth wireless
interface driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-12:4
chip-ID: 8087:0a2b class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0
state: up address: <filter>
bt-v: 4.2 lmp-v: 8 status:
discoverable: no pairing: no
class-ID: 6c010c
Local Storage: total: 1.14 TiB
used: 21.49 GiB (1.8%)
SMART Message: Unable to run
smartctl. Root privileges
ID-1: /dev/nvme0n1 maj-min: 259:0
vendor: SanDisk model: THNSN5256GPUK
size: 238.47 GiB block-size:
physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4
tech: SSD serial: <filter>
fw-rev: 5KDA4103 temp: 40.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0
vendor: HGST (Hitachi)
model: HTS721010A9E630
size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B
speed: 6.0 Gb/s tech: HDD
rpm: 7200 serial: <filter>
fw-rev: A3T0 scheme: GPT
ID-1: / raw-size: 237.97 GiB
size: 237.97 GiB (100.00%)
used: 17.29 GiB (7.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 513 MiB
size: 512 MiB (99.80%)
used: 454.9 MiB (88.9%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 914.01 GiB
size: 914.01 GiB (100.00%)
used: 3.76 GiB (0.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log
raw-size: 237.97 GiB
size: 237.97 GiB (100.00%)
used: 17.29 GiB (7.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp
raw-size: 237.97 GiB
size: 237.97 GiB (100.00%)
used: 17.29 GiB (7.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60)
cache-pressure: 100 (default)
zswap: no
ID-1: swap-1 type: zram
size: 15.5 GiB used: 0 KiB (0.0%)
priority: 100 comp: zstd
avail: lzo,lzo-rle,lz4,lz4hc,842
max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 44.0 C
pch: 49.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB
available: 15.5 GiB
used: 2.88 GiB (18.6%)
Processes: 224 Power: uptime: 32m
states: freeze,mem,disk
suspend: deep avail: s2idle
wakeups: 0 hibernate: platform
avail: shutdown, reboot, suspend,
test_resume image: 6.18 GiB
services: org_kde_powerdevil,
power-profiles-daemon, upowerd
Init: systemd v: 255
default: graphical tool: systemctl
Packages: 1961 pm: pacman
pkgs: 1947 libs: 550
tools: octopi,paru pm: flatpak
pkgs: 14 Compilers: clang: 17.0.6
gcc: 14.1.1 Shell: garuda-inxi
default: Bash v: 5.2.26
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-06-13
Last full system update: 2024-06-15
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut(custom) mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Most likely you already tried this, anyway, have you checked in Settings->Appearance->Configure GNOME/GTK Application Style (at the bottom) and select GTK theme: Sweet dark (or any other dark theme)?
Additionally, try creating a new user and check if the issue appears also there.


Well, I’ve already tried that one.

Alrighty, just tried that, and as it turns out, yes, it is still ignored in the new user too… I don’t know what I did to make it so it messed up in every user.

Maybe you could try reinstalling the garuda-dr460nized package and, on the new user, reapply the Dr460nized Global Theme, checking all the flags to apply it.

1 Like

The apps still don’t use dark mode even after all of that for some reason…

Post the output of this terminal command :

env | grep -v $USER | sort -u 
1 Like
MANPAGER=sh -c 'col -bx | bat -l man -p'
MEMORY_PRESSURE_WATCH=/sys/fs/cgroup/user.slice/user-1000.slice/[email protected]/app.slice/[email protected]/memory.pressure

If you’re wondering why I set GTK_Theme to Purple:dark, it was because I was following a fix and was trying to use one of the solutions.
I highly doubt changing it to Default will change much considering it was broke before changing too.

Did anything change after this change?
How did you set this, what file?

If nothing changed, remove this modification. While troubleshooting, you want to check each change with logout/login, one at a time.

List what you have already tried, so we don’t bother proposing.
Have you checked each of them with login/logout?
Have you read Archwiki about this known Linux problem? What have you tried and failed?

1 Like

First off, the GTK_THEME thing did nothing, so I removed it like you said…
I used /etc/environment to add GTK_THEME…
I also used Pale Moon on GTK2 and as it turns out, it effects not just GTK3 stuff but GTK2 as well.
I have tried using gtk-application-prefer-dark-theme, trying to follow Dark mode switching, installing the stuff that the Arch Wiki article you linked to told me to install, checking my non-existent xconfig file, making a new theme, switching to an old one, trying to follow this superuser answer, and probably a few other things that I can’t remember…

Wait a minute… it appears I didn’t notice that Dark mode switching on the Arch Wiki seems to be saying that:

Notably, if you are using KDE, the Breeze GTK theme does not support it. You can switch to Adwaita theme by running the command below.

Now then, I can’t tell if it’s just the command or the entire program but if it’s the entire program then I guess I can’t use it.
However, considering Dr460nized on a new user is still mixed… it doesn’t matter much, does it?

This issue (uniform appearance of gtk/qt apps) is very complicated and different depending on what/how/which things you use.

For Garuda theming, it is better to follow advice from Garuda KDE/dragonized maintainers that know the latest implementations.
If you don’t care about the Garuda OOTB theming, I would only suggest a couple of things from my old time using KDE (this issue made me create my custom DE, so I get rid of it :rage: ).

Use kvantum for widget styling and kde-gtk-apps setting (System Settings).
Then find a kVantum theme you prefer, so it should(?) work the same for all apps.
Gnome is the exception, as it is a blind giant that doesn’t care at the slightest for other DEs.
There is only one method that IIRC worked properly (not sure for today). Adding GTK_THEME=<some-existing-gtk3/4/5/6-theme> in the commandline that launches your program. You test it in a terminal, and if it works as expected, you create a <program>.desktop file with key Exec as needed and save it to $HOME/.local/share/applications/
For example

Exec=env GTK_THEME=breeze-dark palemoon

Also, check if you have the qt6 variants of some kde qt5 packages.
There is no one easy solution. You have to sweat to find your custom taste, or accept what they provide, or change DE, or quit Linux. :rofl: :melting_face:


Welp, if I can’t use Fusion then I might as well have to use a kvantum theme that matches just enough so that it goes well with my current theme. Seems like I just have to try literally everything until that one thing wo- oh wait, that’s Linux lols.

Alrighty I forgot to check the Gnome GTK Application Style. I thought I had done so though. It was set to default when I’m pretty sure it was SweetDark before. Why would I even change it if I wasn’t experiencing the problem before? But apparently, I FORGOT. And as it turns out, if it’s a new user, it uses the default. Once more, I am a complete idiot. I should have been able to figure this out but at the time I had thought that I had already tried to switch GTK Styles. :man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming:

This is due to the root user, you can fix it by logging into root 1 time or open up kde settings in root, (I cant remember the new command atm)

1 Like

As @elite stated any program that requires root privileges to run will not follow the users custom theming style. You will need to adjust the style while using root privs.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.