Any way to stop AUR packages being merged into Chaotic-AUR?

My AUR built packages keep getting merged into the chaotic-aur. I have chaotic-aur for garuda default packages like firedragon, garuda assistant etc.

I install programs from AUR using paru specifically telling it to download from AUR (paru -Sa). The packages get built and installed, but then for no reason the packages become part of chaotic-aur. Any way to stop this behaviour?

inxi -Faz
System:    Kernel: 5.14.12-arch1-g14-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: pm_debug_messages amd_pmc.dyndbg=+p acpi.dyndbg=file drivers/acpi/x86/s2idle.c +p
amd_pmc.enable_stb=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-g14
root=UUID=2eeb1928-e215-484e-9847-54e2ce849c93 rw [email protected] quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=2978cdd3-cd08-43ba-b001-a7053ea59b54 loglevel=3
Desktop: KDE Plasma 5.23.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401II_GA401II v: 1.0 serial: <filter>
Mobo: ASUSTeK model: GA401II v: 1.0 serial: <filter> UEFI: American Megatrends v: GA401II.219
date: 12/30/2020
Battery:   ID-1: BAT0 charge: 58.6 Wh (79.6%) condition: 73.6/76.0 Wh (96.9%) volts: 15.8 min: 15.8
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging
CPU:       Info: 6-Core model: AMD Ryzen 5 4600HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600104 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71896
Speed: 2465 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 2465 2: 3992
3: 3983 4: 3988 5: 3917 6: 3356 7: 3699 8: 1868 9: 3840 10: 3437 11: 3347 12: 2914
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 04:00.0
chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.12-arch1-g14-1 LLVM 12.0.1) v: 4.6 Mesa 21.2.4
direct render: Yes
Audio:     Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.12-arch1-g14-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 5-4:4 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 295.5 GiB (31.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 004C temp: 30.9 C scheme: GPT
Partition: ID-1: / raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 295.5 GiB (31.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 295.5 GiB (31.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 295.5 GiB (31.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 937.05 GiB size: 937.05 GiB (100.00%) used: 295.5 GiB (31.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.56 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.05 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 56.0 C mobo: 54.0 C gpu: amdgpu temp: 47.0 C
Fan Speeds (RPM): cpu: 2800
Info:      Processes: 344 Uptime: 8h 20m wakeups: 24 Memory: 15.05 GiB used: 4.63 GiB (30.8%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
pacman: 1478 lib: 367 Shell: fish v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.07

pacman doesn't store the source of the package so it looks in the repos for a package of the same name and if it finds it, it updates it from the repos. Since chaotic-aur is a repo on your system it will always prioritize updates from there.

Working around that is likely to be somewhat clumsy. For example, you could have two different pacman.conf's with and without chaotic-aur enabled. Then you could choose which one to use based on your update strategy.

Alternatively many helpers support using AUR/packagename so you could build a script/alias/function that explicitly upgraded those from AUR when you update.

3 Likes

Btw, why are you trying to get them separated
:thinking:

3 Likes

Had previous experience of breaking things when I installed stuff from chaotic-aur. So I keep choatic just to update garuda default programs.

Right now on pamac, the packages installed through AUR seem to be part of both AUR and choatic-aur.

If you told us what exactly broke, we might be able to fix it. Imagine other people also suffered from issues, how is it going to be fixed? - right, it needs to be reported! :eyes:

6 Likes

Sorry. It was on my previous Garuda install on the same machine 3-4 weeks ago. This was the time I first installed Linux on bare metal, didn't know much back then and thought it was part of "Arch instability" some people talk about.

From what I remember, installing some package through pamac GUI from chaotic-aur, it updated some garuda config files (even though I had done full system upgrade before hand) as part of installing it. After this pretty much nothing from Garuda Assistant app was working and kept throwing garuda config file errors.

That's why I decided to install packages from AUR even if they are available from chaotic-aur on my next install. Right now it's running nicely on my machine and I have setup timeshift in case something goes downhill again.

PS: Don't use pamac anymore too, I use pacman, and paru for AUR packages now.

1 Like

Please from now on report issues either at the packages repo of Chaotic-AUR or here. We are dedicated to precompiling stuff for users to save time, potentially fixing eventual bugs in PKGBUILDs as well.

5 Likes

I suspect if you put the Chaotic AUR repo at the bottom of pacman.conf--or eliminate it altogether--you'd tend to be a bit more successful. But then you wouldn't exactly be running Garuda anymore, either, would you?

Since you want pkgbuilds straight from the AUR, why not run straight Arch with the Chaotic AUR as an additional source? There are a number of vanilla Archlinux installers using Calamares, with or without even more installation options, by the way. Or just do a handy. :wink:

There is probably no good middle road on this thing. You're either running Garuda, Arch, or some bastardized system doomed for failure. Mixing 'n' matching virus vaccines may work in humans, but every time I've chosen that third route in (Arch) Linux, I have not ended up a happy camper.

3 Likes

Another approach could be to create a local repo that only contained the garuda* packages from chaotic.

That being said, I am not sure the reason you are avoiding chaotic is entirely warranted. Are you sure what happened to your system was specifically related to chaotic?

That would create the exact same problem. It doesn't matter which Arch-based distro you run in this case. As soon as you add chaotic-aur to your pacman.conf, it becomes part of your repos and will override your ability for helpers to get updates from the AUR.

1 Like

Therein lies the problem. Helpers aren't so helpful when they cannot discriminate pkgbuild repositories. Using either Pacman or (say) yay commands from a terminal can. According to the Chaoitic AUR repo page...

  • If you're using other third parties repositories, I recommend you to put chaotic-aur before them on /etc/pacman.conf. We update most packages hourly and follow AUR's PKGBUILDs, which makes this repository more suitable as the first option when downloading packages.

The above statement, by inference, implies you should put the Chaotic repo at the bottom of pacman.conf to switch sources.

  • You can pick the repository from which you download a package, like this: pacman -S chaotic-aur/dxvk-mingw-git. Some AUR's helpers support it too, e.g: yay -S aur/firefox-hg

And those two lines supports the option.

But, once again, this sets a user up for a bastardized system and I assume that is not the objective of the exercise.
:wink:

The order in pacman.conf only impacts packages brought in from the repos. Whether it is at the bottom or the top it is still a repo and will always take precedence over the AUR.

The issue the OP has is that even if they carefully install a package from the AUR, as soon as an update comes through, it will get replaced with the chaotic version.

This happens even if you don't use helpers at all. Even if you only use pacman and makepkg. Since pacman doesn't store the source of a package, even if you manually build and install a package from AUR, it will still get updated from chaotic-aur by pacman if you have enabled it in pacman.conf.

Then that should probably be added to the Chaotic AUR page. Otherwise it is obfuscating.

1 Like

And round and round we go. I think this has been pretty much covered. In the end the OP's reasons for wanting this seem rather deluded.

I think we can close this out as it's going nowhere fast.

7 Likes