Another Freezing System

Hi All,

Much like some that have been posted already. I rebuilt my laptop (Dell XPS 9380) a few weeks ago, and have found a few issues since.

The system, when booting, will sporadically freeze - and at different points. There have been times when this has been on the grub screen (I see the countdown, and it will stop at 1s and no longer continue), others prior to even reaching grub, and some where it will lock up while attempting to load the system post grub.
The times when I have managed to get the system to load the log in screen, I had to unplug the USBC hubs from the laptop - which, as you will imagine, is highly inconvenient to have to unplug & plug in the hubs again each and every boot.

Once booted, though, the system generally runs fine. However, there are occasions where processes will, again, seemingly lock up, and have to wait for the application to refresh itself before I can do anything. I have monitored the system in a terminal at the time, and there does not appear to be heavy load when this has occurred.

Similarly, I have observed times where I have locked my laptop, and it will not unlock, as it has frozen (although the clock still updates...), meaning a full boot cycle.

I followed another thread, and have just installed & enabled the throttled package, as well as disabling/masking the thermald service.

I was running the previous iteration of Garuda (prior to chaotic-aur going down), where the system seemed to perform perfectly without these issues, and so I am not entirely sure what else has been updated to introduce the problem.

Here are the system details, which are typically requested. Any assistance would be much appreciated.

    System:    Kernel: 5.10.6-110-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
root=UUID=3de39916-9c34-4acc-866d-49bb17413863 rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9380 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: Dell model: 088MRW v: A01 serial: <filter> UEFI: Dell v: 1.11.0 date: 07/06/2020 
Battery:   ID-1: BAT0 charge: 47.5 Wh condition: 47.5/52.0 Wh (91%) volts: 8.5/7.6 model: SMP DELL G8VCF6C type: Li-poly 
serial: <filter> status: Full 
CPU:       Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
model-id: 8E (142) stepping: C (12) microcode: DE L2 cache: 8 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32026 
Speed: 4453 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 4453 2: 4403 3: 4279 4: 4554 5: 4278 6: 4334 7: 4297 
8: 4289 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds mitigation: TSX disabled 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:2 chip ID: 0c45:6723 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel unloaded: modesetting alternate: fbdev,vesa 
display ID: :0 screens: 1 
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1015x285mm (40.0x11.2") s-diag: 1054mm (41.5") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 168 size: 290x170mm (11.4x6.7") diag: 336mm (13.2") 
Monitor-2: DP1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2") 
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.3.2 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:9dc8 
Device-2: Microdia USB Live camera type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-6.2:6 chip ID: 0c45:6536 
serial: <filter> 
Device-3: C-Media TONOR TC-777 Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-6.1:5 
chip ID: 0d8c:0134 
Device-4: FiiO K3 type: USB driver: snd-usb-audio bus ID: 1-6.4:9 chip ID: 2972:0047 
Sound Server: ALSA v: k5.10.6-110-tkg-bmq 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
vendor: Bigfoot Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel port: efa0 bus ID: 02:00.0 
chip ID: 168c:003e 
IF: wlp2s0 state: up mac: <filter> 
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 476.94 GiB used: 23.51 GiB (4.9%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC611 NVMe 512GB size: 476.94 GiB block size: 
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11001111 temp: 47.9 C 
Partition: ID-1: / raw size: 476.64 GiB size: 476.64 GiB (100.00%) used: 23.51 GiB (4.9%) fs: btrfs dev: /dev/nvme0n1p2 
maj-min: 259:2 
ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
maj-min: 259:1 
ID-3: /home raw size: 476.64 GiB size: 476.64 GiB (100.00%) used: 23.51 GiB (4.9%) fs: btrfs dev: /dev/nvme0n1p2 
maj-min: 259:2 
ID-4: /var/log raw size: 476.64 GiB size: 476.64 GiB (100.00%) used: 23.51 GiB (4.9%) fs: btrfs dev: /dev/nvme0n1p2 
maj-min: 259:2 
ID-5: /var/tmp raw size: 476.64 GiB size: 476.64 GiB (100.00%) used: 23.51 GiB (4.9%) fs: btrfs dev: /dev/nvme0n1p2 
maj-min: 259:2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
ID-1: swap-1 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
ID-5: swap-5 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
ID-6: swap-6 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
ID-7: swap-7 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
ID-8: swap-8 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A 
Fan Speeds (RPM): N/A 
Info:      Processes: 281 Uptime: 9m wakeups: 28 Memory: 15.32 GiB used: 7.32 GiB (47.8%) Init: systemd v: 247 Compilers: 
gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1365 lib: 311 Shell: fish v: 3.1.2 running in: konsole inxi: 3.2.01 
> Installed PCI configs:
--------------------------------------------------------------------------------
NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-linux            2020.12.03                true            PCI


local/intel-compute-runtime 20.48.18558-1
Intel(R) Graphics Compute Runtime for oneAPI Level Zero and OpenCL(TM) Driver
local/intel-gmmlib 20.4.1-1
Intel Graphics Memory Management Library
local/intel-graphics-compiler 1:1.0.5435-1
Intel Graphics Compiler for OpenCL
local/intel-media-driver 20.4.5-1
Intel Media Driver for VAAPI — Broadwell+ iGPUs
local/intel-opencl-clang 11.0.0-1
Wrapper library around clang that can compile OpenCL C kernels to SPIR-V modules
local/intel-ucode 20201118-1
Microcode update files for Intel CPUs
local/intellij-idea-community-edition 2:2021.3.1-2
IDE for Java, Groovy and other programming languages with advanced refactoring features
local/ipw2100-fw 1.3-10
Intel Centrino Drivers firmware for IPW2100
local/ipw2200-fw 3.1-8
Firmware for the Intel PRO/Wireless 2200BG
local/lib32-libva-intel-driver 2.4.1-1
VA-API implementation for Intel G45 and HD Graphics family (32-bit)
local/lib32-libvdpau 1.4-1
Nvidia VDPAU library
local/lib32-opencl-mesa 20.3.2-1
OpenCL support for AMD/ATI Radeon mesa drivers (32-bit)
local/lib32-vulkan-intel 20.3.2-1
Intel's Vulkan mesa driver (32-bit)
local/lib32-vulkan-radeon 20.3.2-1
Radeon's Vulkan mesa driver (32-bit)
local/libmfx 20.5.1-1
Intel Media SDK dispatcher library
local/libva-intel-driver 2.4.1-1
VA-API implementation for Intel G45 and HD Graphics family
local/libva-utils 2.10.0-1
Intel VA-API Media Applications and Scripts for libva
local/libvdpau 1.4-1
Nvidia VDPAU library
local/mhwd-amdgpu 19.1.0-1
MHWD module-ids for amdgpu
local/mhwd-nvidia 455.45.01-2
mhwd-nvidia pci id
local/mhwd-nvidia-390xx 390.138-1
mhwd-nvidia-390xx pci id
local/neard 0.16-2
Intel's Near Field Communication manager
local/opencl-mesa 20.3.2-2
OpenCL support for AMD/ATI Radeon mesa drivers
local/throttled 0.8-2
Workaround for Intel throttling issues in Linux.
local/vulkan-intel 20.3.2-2
Intel's Vulkan mesa driver
local/vulkan-radeon 20.3.2-2
Radeon's Vulkan mesa driver
local/whois 5.5.7-1
Intelligent WHOIS client
local/xf86-video-amdgpu 19.1.0-2 (xorg-drivers)
X.org amdgpu video driver
local/xf86-video-intel 1:2.99.917+914+ga511f22c-1 (xorg-drivers)
X.org Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-nouveau 1.0.16-2 (xorg-drivers)
Open Source 3D acceleration driver for nVidia cards

/etc/X11/xorg.conf.d/00-keyboard.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "us"
EndSection
ls: cannot access '/etc/modules-load.d/*.conf': No such file or directory

/etc/modprobe.d/nobeep.conf
# Prevent annoying beep from the pc speaker.
blacklist pcspkr
/etc/modprobe.d/noime.conf
# Intel VPRO remote access technology driver.
blacklist mei
blacklist mei_me
/var/log/Xorg.0.log
[     4.870] Current Operating System: Linux liam-xps139380 5.10.6-110-tkg-bmq #1 TKG SMP PREEMPT Sun, 10 Jan 2021 18:01:03 +0000 x86_64
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     4.871] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 12 12:21:17 2021
[     4.874] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     4.874] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     4.874] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     4.885] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     4.896] (WW) Warning, couldn't open module fbdev
[     4.896] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     4.896] (WW) Warning, couldn't open module vesa
[     4.896] (EE) Failed to load module "vesa" (module does not exist, 0)
[     4.897] (WW) Falling back to old probe method for modesetting
[     4.925] (II) Initializing extension MIT-SCREEN-SAVER
[     5.347] (II) XINPUT: Adding extended input device "ELAN292F:00 04F3:292F" (type: TOUCHSCREEN, id 15)
[    74.046] (EE) event26 - SEMITEK USB-HID Gaming Keyboard: client bug: event processing lagging behind by 16ms, your system is too slow
[   127.625] (EE) event26 - SEMITEK USB-HID Gaming Keyboard: client bug: event processing lagging behind by 18ms, your system is too slow
[   337.164] (EE) event26 - SEMITEK USB-HID Gaming Keyboard: client bug: event processing lagging behind by 31ms, your system is too slow

To me this would seem indicative of an issue with USBC. If you are using a docking station with USBC be sure the firmware is up to date. If there is any hardware attached to the USBc hub such as external hard drives this sometimes will prevent a boot if the drive is approaching failure and has errors. A hard drive in a pre-failure state even if it passes an fsck and smartmon tests can still prevent booting or cause lockups from my experience.

Test different kernels such as linux, linux-lts, linux-zen, or linux-hardened.

I suggested this for a Lenovo laptop, and I believe that fix is specific to Lenovo models. Although disabling thermald is a good troubleshooting step.

2 Likes

Sorry to hear about that, I understand the frustration!

I may have an idea of one thing to look for, but just before I mention, did those issues start to happen exactly at the time you upgraded and never had them before?

If your answer is yes, then my idea bursts into flames. :frowning:

Thanks for the reply.

I have two USBC hubs. One that has four USB-A outputs, connected to mouse, webcam, microphone, and my headphone amp. The second is connected to my monitor and keyboard only. All other extenal storage has been disconnected until I need to access it.

I followed the throttled package through to the GitHub repository that suggested that users had confirmed that the package had worked on other Dell 93* hardware (specifically the 9365 and the 9380).

I can start looking into other kernels, if need be. Is there any in particular that I should focus on first that has been known to work successfully?

Sadly this did only start happening after I upgraded to the latest version of Dr460nized after the festive period.

Upgraded or reinstalled?

2 Likes

It's mostly trial and error when it comes to kernels, as it's usually different hardware involved with each issue posted. Be sure to keep two kernels installed at all times for safety. The LTS kernel is the one usually used as a fallback by most people. Just speculation, the linux-hardened kernel might be one of the better bets in this case.

Nice job researching that thoroughly. That's good information to know. Thanks for posting that.

To test that the Garuda performance-tweaks are not causing problems on your system you may want to disable or mask the services individually one at a time.

Mask the prelockd service:

systemctl mask prelockd.service

Reboot after masking the service.

If you wish to activate the service again after troubleshooting repeat the command substituting "unmask" in place of "mask".

You can also test disabling, or masking the memavaild and auto-cpufreq services as a further troubleshooting step.

See the Archwiki if you wish to find further information regarding enabling, disabling, or masking systemd services:

https://wiki.archlinux.org/index.php/systemd

Have you tried booting with only one hub connected at a time with only the mouse keyboard and monitor connected to start off with. Then add peripheral devices one at a time on separate boots to rule out any of the extra peripheral devices as a cause.

You might also want to test connecting your monitor by an alternate method, as well as connecting your keyboard and mouse directly to your computer.

The only other troubleshooting method that I haven't mentioned is testing different grub kernel boot parameters. As I do not own a Dell laptop I have no idea which grub boot parameters might be best to test out. As your research skills seem quite good I'm sure you can find some good candidates to test out.

4 Likes

Reinstalled using the latest ISO.

Thanks for these suggestions, I'll work through them when I have finished work. For now my system is stable enough for me to finish my working day.

With regards to the USB hubs, I have narrowed it down to the hub that serves my monitor & keyboard. The second that serves the rest of my peripherals seems to be fine.

That's not a usual way of updating to the latest version, when in Rolling distro.
Just update normally.
And installing onto old partitions, without erasing may give problems. I hope you haven't done so.

2 Likes

While I appreciate that, I had to (sadly) install windows for a short period of time for work purposes (where a VM would not suffice), and so when I reinstalled, I ensured that I did so using the latest ISO.

All upgrades prior to this work were via normal channels.

Writing the "latest version/ISO" is not helpful.

For now and future, last ISO, is maybe in two days, ISO before last ISO :smiley: :wink:
For people that read this in 2022 is latest ISO what?

Post always the full name of the used ISO you use, like

garuda-bspwm-linux-tkg-bmq-210107.iso
1 Like

This suggests it's hardware-related rather than a Garuda issue. There's no point in fixing software or tweaking settings if the software is never run.

You might want to do things like check cables and connections, and run a memory test, disk health check, and CPU stress test.

Once you have ruled out a hardware issue then you can move on to blaming Linux. :grin:

2 Likes

If this issue is still apparent in 2022 I would imagine that there would be wider problems to be concerned with :wink:

With that in mind, though, I used...

garuda-dr460nized-linux-tkg-bmq-210107.iso

I would have thought so, too. The query arose due to the same laptop being able to run dr460nized without issue, and was able to install and boot Windows without any problems. The issue only became apparent when I reinstalled dr460nized after I no longer needed to have Windows running.

I'll be running some testing when I have some quiet periods at work, though, and see what sort of results I get. I'm pretty sure I've already checked this to a degree, though, but there would be no harm in doing so again even if only to rule out hardware problems.

1 Like