Another Cursor issue, this time related to dconf

Hello again :smiley:
I have an issue where I am unable to manipulate the cursor via dconf-editor. I am trying to do this, so my cursor theme and size gets applied in LightDM as well as the XFCE/bspwm desktop.
I get this warning:

(dconf-editor:5375): dconf-WARNING **: 09:47:01.527: failed to commit changes to dconf: The connection is closed-
garuda-inxi
System:
  Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=66e5d40a-2370-44f3-b3b6-ddff5b2046cf rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=e5f09ca4-2e13-4405-b97d-9a69816c4515 loglevel=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: bspwm 0.9.10
    vt: 7 dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B550 AORUS PRO V2 serial: N/A
    UEFI: American Megatrends LLC. v: F14e date: 10/14/2021
CPU:
  Info: model: AMD Ryzen 7 5800X socket: AM4 bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x21 (33) stepping: 0
    microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2337 high: 3800 min/max: 2200/4850 boost: enabled
    base/boost: 3800/4850 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 2200 2: 2200 3: 2200 4: 2200
    5: 2200 6: 2200 7: 2200 8: 2800 9: 2200 10: 2200 11: 2200 12: 2200
    13: 3800 14: 2200 15: 2200 16: 2200 bogomips: 121376
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ZOTAC
    driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 07:00.0
    chip-ID: 10de:2504 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: picom v: git-c4107
    driver: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 139 s-size: 702x392mm (27.6x15.4")
    s-diag: 804mm (31.7")
  Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 140
    size: 697x392mm (27.4x15.4") diag: 800mm (31.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA vendor: ZOTAC driver: snd_hda_intel v: kernel
    bus-ID: 07:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 09:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Device-3: RODE Microphones RØDE NT-USB Mini type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-6.3:6 chip-ID: 19f7:0015
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 50.93 TiB used: 24.01 GiB (0.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair
    model: Corsair MP600 PRO XT size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: EIFM31.2 temp: 32.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MG09ACA18TE
    size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0104 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MG09ACA18TE
    size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0104 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Toshiba model: MG09ACA18TE
    size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0104 scheme: GPT
Partition:
  ID-1: / raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 24.01 GiB (1.3%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
    used: 24.01 GiB (1.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
    used: 24.01 GiB (1.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
    used: 24.01 GiB (1.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 62.77 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 69.05 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 363 Uptime: 21m wakeups: 0 Memory: 62.77 GiB
  used: 4.19 GiB (6.7%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1205 lib: 292 Shell: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-02-13
  Last full system update: 2022-02-14
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service

Not a BSPWM user here... so please forgive me if mycomment may be pointless...
Anyway, at a quick internet search, I have only a doubt: could it be that you're launching dconf-editor with sudo (which I see shouldn't be done)?

No that's not the issue. I tried setting the cursor size via

gsettings set org.gnome.desktop.interface cursor-size 16

and

xfconf-query --channel xsettings --property /Gtk/CursorThemeSize --set  16

as root and as user, but it doesn't help. The cursor size gets applied for everything but gtk apps, so if the cursor is in lightDM or over the desktop or anything gtk/xfce, it way too huge and I can't change this setting. I even logged in as root and tried changing there, to no avail. I have set the cursor size in Xresources.
Nothing works.

XFCE is nothing to do with gnome.org nor is lightdm xfce has its own setting manager

Maybe also see if this can help:
https://wiki.archlinux.org/title/Cursor_themes#X_resources
https://wiki.archlinux.org/title/Cursor_themes#Change_X_shaped_default_cursor
https://wiki.archlinux.org/title/Cursor_themes#Cursor_size_does_not_change_on_startup

1 Like

Thank you, but I have literally tried all of these things, nothing works.

I have also tried what helped here.

I'm currently trying to build the gcong-editor because I've read somewhere that this could help, but I'm having issues with libxml2. I'm going in circles here.

And mandog, I know that XFCE has nothing to do with Gnome. But since this seems to be an issue related to gtk, and XFCE is build on that, I have simply tried what I can. Which is gsettings (gnome) and xconf-query (xfce).

My last attempt :slight_smile: . I guess you've already tried internet searches, e.g. this one seems interesting (solution in Update 2):

But it was somehow already covered in the Arch Wiki...

1 Like

I have tried to put the curcor size into .profile, but it didn't work, thank you though! Much appreciated! :slight_smile:
I had already set the size in Xressources tho. :confused:

So, any other ideas? Is it possible to set a size in index.theme?

Active environment variables and relogin after changes.
You said you have tried Archwiki methods. Did you try opening your application(s) in question with a CURSOR specific variable?

XCURSOR_SIZE=16 <gtk-application>

If you want help, post your actual current settings, so we come closer to your PC :wink:

env | grep -i "^g\|session\|desktop"
grep "." " .config/gtkrc*" ".config/gtk*/settings.ini" ".gtkrc-2.0" ".Xresources" ".Xdefaults"
grep "." ".profile" ".xprofile" ".bashrc"  # if you use bash, else the equivalent for your shell
2 Likes

You're right, some more information would be actually helpful for you guys ... :smiley:
XCURSOR_SIZE=16 <gtk-application> didn't work sadly

env | grep -i "^g|session|desktop":

DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
DESKTOP_SESSION=xfce
GTK3_MODULES=xapp-gtk3-module
GTK_MODULES=canberra-gtk-module
GTK_IM_MODULE=fcitx
GTK2_RC_FILES=/home/p2501/.gtkrc-2.0
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_SESSION_CLASS=user
MCFLY_SESSION_ID=
XDG_SESSION_TYPE=x11
STARSHIP_SESSION_KEY=
XDG_SESSION_ID=2
GDMSESSION=xfce
XDG_SESSION_DESKTOP=xfce
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0

grep "." " .config/gtkrc*" ".config/gtk*/settings.ini" ".gtkrc-2.0" ".Xresources" ".Xdefaults":

grep:  .config/gtkrc*: No such file or directory
grep: .config/gtk*/settings.ini: No such file or directory
.gtkrc-2.0:gtk-theme-name="WhiteSur-dark"
.gtkrc-2.0:gtk-icon-theme-name="Tela-circle-blue-dark"
.gtkrc-2.0:gtk-sound-theme-name="Yaru"
.gtkrc-2.0:gtk-font-name="Fira Sans 10"
.gtkrc-2.0:gtk-cursor-theme-name="WhiteSur-cursors"
.gtkrc-2.0:gtk-cursor-theme-size=16
.gtkrc-2.0:gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
.gtkrc-2.0:gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
.gtkrc-2.0:gtk-button-images=1
.gtkrc-2.0:gtk-menu-images=1
.gtkrc-2.0:gtk-enable-event-sounds=1
.gtkrc-2.0:gtk-enable-input-feedback-sounds=1
.gtkrc-2.0:gtk-xft-antialias=1
.gtkrc-2.0:gtk-xft-hinting=1
.gtkrc-2.0:gtk-xft-hintstyle="hintfull"
.gtkrc-2.0:gtk-xft-rgba="none"
.gtkrc-2.0:gtk-modules="canberra-gtk-module:gail:atk-bridge"
.Xresources:! X colors.
.Xresources:*foreground:        #ebb2b7
.Xresources:*background:        #0C0201
.Xresources:*.foreground:       #ebb2b7
.Xresources:*.background:       #0C0201
.Xresources:emacs*foreground:   #ebb2b7
.Xresources:emacs*background:   #0C0201
.Xresources:URxvt*foreground:   #ebb2b7
.Xresources:XTerm*foreground:   #ebb2b7
.Xresources:UXTerm*foreground:  #ebb2b7
.Xresources:URxvt*background:   [100]#0C0201
.Xresources:XTerm*background:   #0C0201
.Xresources:UXTerm*background:  #0C0201
.Xresources:URxvt*cursorColor:  #ebb2b7
.Xresources:XTerm*cursorColor:  #ebb2b7
.Xresources:UXTerm*cursorColor: #ebb2b7
.Xresources:URxvt*borderColor:  [100]#0C0201
.Xresources:! Colors 0-15.
.Xresources:*.color0: #0C0201
.Xresources:*color0:  #0C0201
.Xresources:*.color1: #0E0A4B
.Xresources:*color1:  #0E0A4B
.Xresources:*.color2: #BD5758
.Xresources:*color2:  #BD5758
.Xresources:*.color3: #B48D62
.Xresources:*color3:  #B48D62
.Xresources:*.color4: #C39D60
.Xresources:*color4:  #C39D60
.Xresources:*.color5: #F7877E
.Xresources:*color5:  #F7877E
.Xresources:*.color6: #DE6C82
.Xresources:*color6:  #DE6C82
.Xresources:*.color7: #ebb2b7
.Xresources:*color7:  #ebb2b7
.Xresources:*.color8: #a47c80
.Xresources:*color8:  #a47c80
.Xresources:*.color9: #0E0A4B
.Xresources:*color9:  #0E0A4B
.Xresources:*.color10: #BD5758
.Xresources:*color10:  #BD5758
.Xresources:*.color11: #B48D62
.Xresources:*color11:  #B48D62
.Xresources:*.color12: #C39D60
.Xresources:*color12:  #C39D60
.Xresources:*.color13: #F7877E
.Xresources:*color13:  #F7877E
.Xresources:*.color14: #DE6C82
.Xresources:*color14:  #DE6C82
.Xresources:*.color15: #ebb2b7
.Xresources:*color15:  #ebb2b7
.Xresources:! Black color that will not be affected by bold highlighting.
.Xresources:*.color66: #0C0201
.Xresources:*color66:  #0C0201
.Xresources:! Xclock colors.
.Xresources:XClock*foreground: #ebb2b7
.Xresources:XClock*background: #0C0201
.Xresources:XClock*majorColor:  rgba:eb/b2/b7/ff
.Xresources:XClock*minorColor:  rgba:eb/b2/b7/ff
.Xresources:XClock*hourColor:   rgba:eb/b2/b7/ff
.Xresources:XClock*minuteColor: rgba:eb/b2/b7/ff
.Xresources:XClock*secondColor: rgba:eb/b2/b7/ff
.Xresources:! Set depth to make transparency work.
.Xresources:URxvt*depth: 32
.Xresources:Xcursor.theme:	Layan-white-cursors
.Xresources:Xcursor.size:	16
grep: .Xdefaults: No such file or directory

grep "." ".profile" ".xprofile" ".bashrc":

.profile:export EDITOR=/usr/bin/micro
.profile:export BROWSER=firedragon
.profile:export TERM=alacritty
.profile:export MAIL=thunderbird
.profile:export QT_QPA_PLATFORMTHEME="qt5ct"
.profile:export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
.profile:sh ~/.config/autostart-scripts/tty-color.sh &
.profile:export XCURSOR_THEME="Layan-white-cursors"
.profile:export XCURSOR_SIZE=16
.profile:export GTK_IM_MODULE=fcitx
.profile:export QT_IM_MODULE=fcitx
.profile:export [email protected]=fcitx
grep: .xprofile: No such file or directory
.bashrc:#
.bashrc:# ~/.bashrc
.bashrc:#
.bashrc:# If not running interactively, don't do anything
.bashrc:[[ $- != *i* ]] && return
.bashrc:alias ls='ls --color=auto'
.bashrc:PS1='[\[email protected]\h \W]\$ '
.bashrc:export GTK_IM_MODULE=fcitx
.bashrc:export QT_IM_MODULE=fcitx
.bashrc:export [email protected]=fcitx

There you go. :slight_smile:

  • The cursor size of 16 might not exist. Try one of 24, 32, 48, 64
  • You are in a xfce4 session. Use its utility to set cursor size.
2 Likes

I set it to 24 in this utility, with absolutely no change to the cursors size.