Annoying little box when opening Steam


I have a problem when I open Steam (installed using wine)

Once the program opens, an annoying little white box starts with the program and is overlayed on top of everything, including running games, despite the in-game video settings.

I tried installing Steam multiple different ways and each time this problem persists.

Is there any solution, or at least a work-around to getting this to go away or at least display below everything else?

It is a white rectangular box about 4 times larger than my mouse pointer, with a black " | " in the middle of it (tried uploading a screenshot but I'm a new user here).

Thank you.

╭─obaak@F15 in ~ took 1ms
╰─λ garuda-inxi
Kernel: 6.3.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c44844d4-3c97-4f50-a8da-fce62bde5202 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=1ec2b04f-ddd5-4077-a756-79bef62a9a9a loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX517ZC_FX517ZC
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FX517ZC v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: FX517ZC.315 date: 06/17/2022
ID-1: BAT1 charge: 44.4 Wh (60.0%) condition: 74.0/75.8 Wh (97.5%)
volts: 15.7 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
status: not charging
Info: model: 12th Gen Intel Core i7-12650H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x42A
Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1941 high: 2983 min/max: 400/4600:4700:3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 1970 2: 2200 3: 1989
4: 1859 5: 1992 6: 1740 7: 1991 8: 2107 9: 1969 10: 1967 11: 2039 12: 2983
13: 1556 14: 1585 15: 1568 16: 1555 bogomips: 86016
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0 chip-ID: 8086:46a3
class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: ASUSTeK
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
chip-ID: 10de:25a2 class-ID: 0300
Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:6 chip-ID: 322e:202c
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: eDP-1 model: BOE Display 0x0a07 built: 2021 res: 2560x1440
hz: 165 dpi: 189 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 2560x1440
API: OpenGL v: 4.6 Mesa 23.1.2 renderer: Mesa Intel Graphics (ADL GT2)
direct-render: Yes
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Device-3: ASUSTek C-Media Audio driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-9:7
chip-ID: 0b05:6206 class-ID: 0300
API: ALSA v: k6.3.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 0000:00:1f.6 chip-ID: 8086:1a1e class-ID: 0200
IF: eno2 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:10 chip-ID: 8087:0026
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Local Storage: total: 476.94 GiB used: 267.63 GiB (56.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 47.9 C scheme: GPT
ID-1: / raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 267.63 GiB (58.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 267.63 GiB (58.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 267.63 GiB (58.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 267.63 GiB (58.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.25 GiB used: 9.93 GiB (65.1%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.78 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3300
Processes: 408 Uptime: 1h 48m wakeups: 81 Memory: available: 15.25 GiB
used: 9.19 GiB (60.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 2055
libs: 578 tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-06-18
Last full system update: 2023-06-21
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Have you tried disabling the in-game overlay in Steam's settings?

1 Like

The first thing, there is are two clients for linux, with no need to install on WINE.

paru -S steam
paru -S steam-native-runtime

I have never had a problem using the first one, but I only play Doom/Doom Eternal/DOTA 2/Gauntlet, so the second may work better for your use possibly.

Second, as you are on a hybrid graphics, you may try to run steam by doing

prime-run steam

to fully utilize your nvidia hardware. (this provided me no noticeable difference on my hardware, but I have seen it suggested elsewhere)

Otherwise, you may share

how or what these ways were for a better response.


I definitely agree on using the steam and steam-native-runtime packages in the Arch Multilib repository.
Important reading (in general, not for this issue):
And to launch games with dGPU, I suggest using the game start parameter like here

rather than launching steam itself with prime-run.

1 Like

I noticed both of those versions only allow me to play steam games that are compatible for Linux so I downloaded the windows version of steam and installed using wine and the games run perfectly, better then they did on windows but there is that small box that overlays on top. I confirmed that the same thing is happening on my wife's laptop that's running Manjaro. Same box. You guys are saying I should be able to play windows games from those two paru clients? Do I have to enable some kind of compatibility or something like that?

I'm not a gamer, but, as far as I know, it is proton (baked in steam on linux) that allows launching most Windows games.
It is mentioned in the steam link in my previous post, and also our wiki might help:


Yes I have tried that. It starts with steam and leaves when steam is closed. Otherwise it’ll be on top of every single window

In steam-native and steam-runtime, I'm only able to download linux compatible games, and if I enable an option in the settings, it lets me install all the other games but they don't work.. Such as GTA4, I'm able to run it using a windows version of steam installed with wine (but I get the little box overlay thing), and the two versions of Steam that Garuda comes with as problems opening those games

Just replied to haakoth on this, those have issue with the Windows compatible steam games I try to launch but work on the windows version installed with wine, but has the box

You don't need to install Steam with Wine to get windows games going... That is just gong to cause problems. I assume your "white box" issue is because you are running the Windows Steam client; that does not have the same checks for hardware and fixes for hardware as the Linux client has (like shutting off hardware acceleration on Nvidia).

If game titles aren't handpicked by Valve to run with proton, you can still change the compatibility settings.
Then make sure both "Enable Steam Play" options are on, and set the "run other titles" with Proton Experimental (don't set a custom proton in here as there is most likely still a bug that unchecks the "other titles" setting)


Hi there @0baak

I increased your trust level to TL1 from TL0. Please post the screenshot, so that we can see what is the actual issue.

Without Text?

So we need no picture.
Or post the text as text, please :slight_smile:

That was what I did to be able to install the games without using the other client but the games were having problems running. I resolved the white box issue. Commenting below

Was able to resolve the issue

Problem resolved:

I used winecfg and added steam.exe in, and in graphic tab enabled "emulate a virtual desktop" and the white box went away.

So, the compatibility feature in steam-native and steam-runtime (that came installed with Garuda) were having issues with the Windows games. GTA4 for instance. Didn't work, changed to a lot of different versions and still no luck.

However I confirmed GTA4 and Halo Masterchief Edition to be working with the Windows Steam version that I installed with Wine (where I started having problems with the white box which is now resolved).

I'm running games better than I did when I had Windows 11, and this method is having no issues whatsoever. I'm glad I was able to get the white box to go away.

Thank you everyone for chiming in to help me with this issue. I appreciate it a lot! This community is awesome.

Glad to hear you got it working.

This is where I set compatibility to run windows games on linux without wine (it uses proton)

I didn't check the games you mentioned, so this may not work for you. If you have the chance to check/look, it could be worth it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.