Animation jitter when scrolling through the App List in Gnome in Balanced & Power Saver power profiles in X11

I've faced this issue for the longest time. Scrolling is perfect under all power profiles when under a Wayland session but there is an obstinate jitter for the "Balanced" and "Power Saver" power profiles under X11 session.

```text
System:
  Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d5b774b2-54ac-458b-a078-f474ae961f5d
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=aaea27cb-5d83-4c3c-ab0a-c4fc3dbf923c loglevel=3
  Desktop: GNOME v: 42.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0 Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF Z270 MARK 2 v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 1301 date: 03/14/2018
Battery:
  Device-1: hidpp_battery_0 model: Logitech G304 Lightspeed Wireless Gaming Mouse serial: <filter>
    charge: 100% (should be ignored) rechargeable: yes status: discharging
CPU:
  Info: model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB
    L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 4200 high: 4201 min/max: 800/4200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4200 2: 4200 3: 4201 4: 4200 bogomips: 27999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel ports: active: HDMI-A-1
    empty: HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1912 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 compositor: gnome-shell driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: BenQ RL2455 serial: <filter> built: 2016
    res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2 size: 531x298mm (20.91x11.73") diag: 609mm (24")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: vboxnet0 state: down mac: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 11.15 GiB (1.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-00WN4A0 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: MBR
Partition:
  ID-1: / raw-size: 223.79 GiB size: 223.79 GiB (100.00%) used: 11.15 GiB (5.0%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 223.79 GiB size: 223.79 GiB (100.00%) used: 11.15 GiB (5.0%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 223.79 GiB size: 223.79 GiB (100.00%) used: 11.15 GiB (5.0%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 223.79 GiB size: 223.79 GiB (100.00%) used: 11.15 GiB (5.0%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.63 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
    maj-min: 8:3
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 246 Uptime: 14m wakeups: 3 Memory: 7.63 GiB used: 2.55 GiB (33.4%) Init: systemd
  v: 251 tool: systemctl Compilers: gcc: 12.1.0 Packages: 1322 pacman: 1318 lib: 363 flatpak: 4
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2022-05-28
  Last full system update: 2022-05-28 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service 
```

All problems resolved by switching to tkg-pds kernel. Perhaps, the zen kernel was at fault :man_shrugging:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.