Animated wallpapers dosent seam to function in Garuda

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f2e0593b-9957-4cd7-ae92-50ff917d54b6
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=442e4a39-4e7c-4961-8395-de24febbfd37 loglevel=3
pci=realloc intel_iommu=on
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: GAME GARAJ product: TRACER XL v: REV:1.0 serial: <filter> Chassis:
type: 10 serial: <filter>
Mobo: GAME GARAJ model: TRACER XL v: REV:1.0 serial: <filter> BIOS: American Megatrends
v: E17F5IE2.100 date: 01/22/2021
Battery:   ID-1: BAT1 charge: 51.1 Wh (100.0%) condition: 51.1/51.3 Wh (99.6%) volts: 12.9 min: 11.4
model: MSI BIF0_9 type: Li-ion serial: N/A status: Full
CPU:       Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake family: 6
model-id: A5 (165) stepping: 2 microcode: EA cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399
Speed: 4574 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 4574 2: 4700 3: 3910 4: 4692
5: 4146 6: 4595 7: 4594 8: 3426 9: 4191 10: 4600 11: 4551 12: 4589
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Micro-Star MSI driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Micro-Star MSI driver: nvidia
v: 470.74 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1-1 res: 1920x1080 hz: 144 dpi: 128 size: 382x215mm (15.0x8.5")
diag: 438mm (17.3")
OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
driver: r8168 v: 8.049.02-NAPI modules: r8169 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
IF-ID-3: virbr1 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.36 TiB used: 785.1 GiB (56.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: S5Z44101 temp: 35.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Seagate model: Expansion size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 0712 scheme: GPT
Partition: ID-1: / raw-size: 448.75 GiB size: 448.75 GiB (100.00%) used: 294.19 GiB (65.6%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 448.75 GiB size: 448.75 GiB (100.00%) used: 294.19 GiB (65.6%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 448.75 GiB size: 448.75 GiB (100.00%) used: 294.19 GiB (65.6%)
fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 448.75 GiB size: 448.75 GiB (100.00%) used: 294.19 GiB (65.6%)
fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.01 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: swap-2 type: zram size: 15.46 GiB used: 1024 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A gpu: nvidia temp: 50 C
Fan Speeds (RPM): N/A
Info:      Processes: 408 Uptime: 38m wakeups: 1 Memory: 15.46 GiB used: 7.4 GiB (47.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2018 lib: 564
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

I have been trying to get a live wallpaper to work on garuda for a while now and nothing seems to be working. I have tried komorebi, wallset and livewallpaper but they all had problems. The one i had the least problems was wallset which worked but the default wallpaper was infront of it and it was in the background. Is there any way around this?

I will bite... I believe Garuda's KDE out of the box uses a plugin 'Inactive blur' . You can check if it is active by right-clicking on your desktop/Configure Desktop and Wallpaper and checking 'Wallpaper Type.' Could that be what the issue is? You can either uninstall that plugin or switch it to the standard, 'image' or to your live wallpaper if it shows up there, all from the dropdown box. Just a thought.

3 Likes

Nope. Didnt work chief. Also you can add animated wallpapers to the kde menu?

Seemed like the logical place to find it if using an external application. I don't know much about the live-wallpaper apps themselves, so maybe someone else can weigh in.

Hi there, welcome to the community.
KDE is doing quite nice with native wallpaper plugins. See

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.