Alacritty (xfce) doesnt start

Error: There was an error initializing the shaders: Failed compiling shader: 0:1(10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

help

First, post your garuda-inxi
After fresh install use

garuda-update

Second, did you search about this error in World Wide Web?

3 Likes
System:
  Kernel: 5.15.55-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=e5e70c27-2494-44a8-90d5-c6a775cc8a0f rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Sony product: VGN-NW270F v: C602Q26U
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Sony model: VAIO serial: <superuser required>
    BIOS: American Megatrends v: R1120Y4 date: 08/20/2009
CPU:
  Info: model: Intel Core2 Duo T6600 bits: 64 type: MCP
    arch: Penryn Yorkfield built: 2008 process: Intel 45nm family: 6
    model-id: 0x17 (23) stepping: 0xA (10) microcode: 0xA0B
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 2 MiB desc: 1x2 MiB
  Speed (MHz): avg: 1196 min/max: 1200/2200 scaling: driver: acpi-cpufreq
    governor: schedutil cores: 1: 1196 2: 1196 bogomips: 8771
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Sony
    driver: i915 v: kernel arch: Gen5 process: Intel 45nm built: 2008 ports:
    active: LVDS-1 empty: DP-1, DP-2, HDMI-A-1, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:2a42 class-ID: 0300
  Device-2: Chicony type: USB driver: uvcvideo bus-ID: 1-2:2
    chip-ID: 04f2:b14e class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 res: 1366x768 hz: 60 size: N/A modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 82801I HD Audio vendor: Sony driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:293e class-ID: 0403
  Sound Server-1: ALSA v: k5.15.55-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Marvell 88E8057 PCI-E Gigabit Ethernet vendor: Sony driver: sky2
    v: 1.30 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 01:00.0
    chip-ID: 11ab:4380 class-ID: 0200
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter
    vendor: Foxconn T77H126.00 802.11bgn driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:002b
    class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
Drives:
  Local Storage: total: 298.09 GiB used: 83.76 GiB (28.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HM320II
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: N/A serial: <filter> rev: 01C4 scheme: MBR
Partition:
  ID-1: / raw-size: 61.43 GiB size: 61.43 GiB (100.00%)
    used: 11.13 GiB (18.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 61.43 GiB size: 61.43 GiB (100.00%)
    used: 11.13 GiB (18.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 61.43 GiB size: 61.43 GiB (100.00%)
    used: 11.13 GiB (18.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 61.43 GiB size: 61.43 GiB (100.00%)
    used: 11.13 GiB (18.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.68 GiB used: 21.2 MiB (0.6%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 232 Uptime: 37m wakeups: 1 Memory: 3.68 GiB
  used: 1.52 GiB (41.4%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1459 lib: 402
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.19
Garuda (2.6.5-1):
  System install date:     2022-07-20
  Last full system update: 2022-07-21 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service

Thank you Mr SGS

I search it on internet but other forums doesnt tell you how to do it

something about creating a profile something on xfce user session and other not exactly information

first i would reboot after an update then see if the problem persists

2 Likes

If the error persists after reboot, giving a look at this bug report I'd try installing alacritty-git from AUR.
The bug seems to have been closed

pulling the master branch and running cargo install --path .

2 Likes