After upgrading graphics card, colors on one display are off, flickering artifacts on desktop, poor performance in general UI and more

I've been using garuda dragonized for like a year, mostly a smooth ride, really like it. Fast forward to a couple weeks ago, I got a rtx 3070 to replace my rx 5700 xt. Swapped the cards, tried to boot to garuda as it was, the UI was broken, there was no mouse pointer and turning the compositor off made no difference, besides everything was super laggy. Whatever, I reinstalled garuda, had the problems I'll list below, tried my best to find solutions, meanwhile in my windows install no similar problems showed up after DDU and installing new drivers. As soon as I had some free time, I just nuked the whole SSD (with both OSs) and installed windows (w10, same as before), after that I installed garuda again, exact same problems, was still unable to solve them.

So, the problems I have are as follows:

  • Main display (a viewsonic 1080p 144hz plugged via displayport) gets randomly disabled (mostly when I walk away from the PC for a few minutes, (it still shows up marked as primary even though the enabled checkbox is empty). Figured that disabling the screen energy saving mitigated it most of the time, but it still happens sometimes. I also figured that changing the nvidia x server settings mitigated this problem the most, now it almost never happens when I'm using the PC, but it still does sometimes, as well as when I walk away

  • When display gets disabled, it also gets moved to occupy the same space as secondary display, sometimes it changes refresh rate to 60 too, this also became once every three times or so instead of each time once I changed nvidia x server settings, but again, it keeps happening.

  • Colors are waaaaay off for main display, after tweaking the x server settings (mainly changing color range, dithering, mode and depth) I managed to get it mostly right, but the colors are still a little bit off and there's some very prominent color banding, such problems don't show up in windows.

  • x server doesn't let me change main display from RGB color space, if I set the display to YUV directly through the display OSD, the colors turn to solid neon green, purple and blue among other colors (gradients don't seem to show up) and the x server settings still don't allow me to change from RGB, rebooting the system with the display manually set doesn't make a difference.

  • If the main display is set to 120 Hz, there's a sort of flickering artifact (looks like white text, maybe from the UI, segmented in horizontal lines, bigger font in bold) that shows up for a fraction of a second at random intervals almost at the top of the screen, in the horizontal center. Can't possibly get a good look at it. Turning off or changing settings on the compositor doesn't make a difference.

  • The UI is noticeably laggy, like the animations in the dock, some animations in the settings, even moving the typing cursor through text in a browser like when writing this post on firedragon, though the cursor one is somewhat rare, if deleting stuff with backspace said lag makes the cursor move fluctuate in speed when held. The lag is not enough to make it unusable or frustrating, but it is pretty noticeable and very annoying. Sometimes opening UI menus can take up to half a second of no response.

  • I tried launching a couple of games, both with gamemode on, while performance seemed normal, I had some green hue in some colors flicker in and out of existence, the behavior was a little different, in the witcher 3 (using proton) for example, said flicker happened a couple of times at the beggining of the cinematic before entering the game, then stayed solid for a couple seconds and then disappeared for most of it, in game it showed up solid for a few seconds at random but it was hard to tell in the area I tested, in 7 days to die (running as a native linux game) it was more sporadic and random during gameplay, can't remember what other game I tried (was a bit more than a week ago, I haven't had much free time recently). Both games launched from steam, tried runtime and native and it seemed to make no difference.

That's about it, I haven't used linux too much lately because of these issues, as I said before, the exact same problems showed up after reinstalling and after doing a clean install when nuking the whole SSD, I'll add that I had not a single one of these problems before swapping the graphics card, I did try reseating it and the ram as well as power connectors just in case.

To the best of my ability, I wasn't able to find these issues when searching, let alone a solution, everything I managed to do to mitigate the problems was through trial and error.

Before nuking the system, I tried downloading the image and remaking the installation usb drive in case that was the problem somehow.

In case it helps diagnosing the issue, the grub shows up in like 360p, not a problem but I found it odd since it showed up in full resolution when I had the AMD card, so I think it's worth at least mentioning.

The main display is not true 8bit, it's 6 bit+ FRC, when I first got it, it looked odd, with the help of a friend I tweaked the OSD settings and got it to look beautiful with minimal color banding, we made the tweaks exclusively through the OSD settings it's using right now and we did it using this same distro, so it should be calibrated the same, I did nothing to the colors through the OS. As mentioned before, it looks normal in windows. The second display runs at 60 hz and is plugged with a displayport to HDMI.

With nothing else to add, here's the inxi:

System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f34081c4-88c8-4948-96a7-926dc263cc60 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME B350M-A v: Rev X.0x
serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 5603
date: 07/28/2020
CPU:
Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ gen: 2
level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2179 high: 3892 min/max: 1550/3400 boost: enabled
scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 2548 2: 1556
3: 2794 4: 1550 5: 1550 6: 1550 7: 1557 8: 2952 9: 2951 10: 1569 11: 1679
12: 3892 bogomips: 81436
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: eVga.com. driver: nvidia
v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 08:00.0 chip-ID: 10de:2484
class-ID: 0300
Display: x11 server: X.Org v: 21.1.5 with: Xwayland v: 22.1.6
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 91 s-size: 1070x301mm (42.13x11.85")
s-diag: 1112mm (43.76")
Monitor-1: DP-0 pos: right res: 1920x1080 dpi: 94
size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
Monitor-2: HDMI-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 102
size: 477x268mm (18.78x10.55") diag: 547mm (21.54") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce RTX
3070/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA GA104 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel bus-ID: 3-1.1:6 chip-ID: 2573:0017 pcie:
class-ID: 0102 gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 08:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: ESI Audiotechnik GmbH MAYA22 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Kingston HyperX Cloud Flight Wireless Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.3:5 chip-ID: 0951:16c4
class-ID: 0300
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Drives:
Local Storage: total: 2.96 TiB used: 27.29 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WDS100T2B0A-00SM50 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: HD103SJ
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: MBR
ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD10EZEX-21M2NA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: MBR
Partition:
ID-1: / raw-size: 122.43 GiB size: 122.43 GiB (100.00%)
used: 27.29 GiB (22.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-2: /home raw-size: 122.43 GiB size: 122.43 GiB (100.00%)
used: 27.29 GiB (22.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-3: /var/log raw-size: 122.43 GiB size: 122.43 GiB (100.00%)
used: 27.29 GiB (22.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-4: /var/tmp raw-size: 122.43 GiB size: 122.43 GiB (100.00%)
used: 27.29 GiB (22.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.55 GiB used: 1.2 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 3.91 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda6 maj-min: 8:6
Sensors:
System Temperatures: cpu: 41.8 C mobo: N/A gpu: nvidia temp: 52 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 343 Uptime: 24m wakeups: 0 Memory: 15.55 GiB
used: 6.06 GiB (39.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 2028 libs: 556 tools: gnome-software,octopi,pamac,paru Shell: fish
v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.10-1):
System install date:     2022-12-01
Last full system update: 2022-12-14
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

I wanted to add info from the x server but I hit the character limit

Use Garuda PrivateBin upper right on this page.

1 Like

So here's the info from x server: Garuda's PrivateBin

And here's the info from window manager: Garuda's PrivateBin

Don't know what else to copy and paste for useful info, I'm honestly lost at this problem.

Thanks a lot btw, I didn't notice I deleted all my please and thank yous after hitting the character limit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.