After update, games not working under Proton but work in Wine. assumed DXVK issue

This issue started a while back after an update and is only causing issues with 3 games (that i know of) out of my whole library, all others work as intended. I have asked around for help on other sites and was told something is wrong with my OS so I am asking here. These games will launch through Wine but not through Proton.

I have been able to test these 3 games on 2 other Garuda machines and they work as intended. (Open with Steam/Proton Experimental or whatever other version. All using Intel w/ Nvidia) All of these games worked previously, and 1 of the games hasnt been updated in years, so its not the game itself.

While digging I ran across someone on Protondb mentioning their DXVK was corrupt and putting PROTON_USE_WINED3D=1 %COMMAND% in launch options of Steam allow it to launch the game with OpenGL instead of Vulkan which fixed it. All the games that would crash on launch worked after adding that launch option, so i assume something is wrong with my Vulkan/DVXK going off of that.

The games are FAITH, Nuclear Throne, and Just King in case its useful somehow haha.

INXI

System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=855a40ff-2fe4-4d97-a9f3-4e5d5c058c2c rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: STRIX Z270E GAMING v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 0906
    date: 03/22/2017
CPU:
  Info: model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 4425 high: 4800 min/max: 800/4500:4800 scaling:
    driver: intel_pstate governor: performance cores: 1: 4200 2: 4800 3: 4800
    4: 4200 5: 4200 6: 4200 7: 4800 8: 4200 bogomips: 67200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: Micro-Star MSI
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max:
    gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2503 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4080x1920 s-dpi: 91 s-size: 1139x536mm (44.84x21.10")
    s-diag: 1259mm (49.56")
  Monitor-1: DP-0 pos: primary,bottom-c res: 1920x1080 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: DP-3 pos: top-right res: 1080x1920 dpi: 82
    size: 336x598mm (13.23x23.54") diag: 686mm (27.01") modes: N/A
  Monitor-3: DP-4 pos: primary,top-left res: 1080x1920 hz: 60 dpi: 93
    size: 296x527mm (11.65x20.75") diag: 604mm (23.8") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA
    520.56.06 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel bus-ID: 1-5:4 v: kernel bus-ID: 00:1f.3
    chip-ID: 041e:3264 chip-ID: 8086:a2f0 class-ID: 0102 serial: <filter>
    class-ID: 0403
  Device-2: NVIDIA GA106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Device-3: Creative Sound Blaster X3 type: USB
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid
  Device-4: Blue Microphones Yeti Stereo Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-6:5 chip-ID: b58e:9e84
    class-ID: 0300 serial: <filter>
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth:
  Device-1: ASUSTek Qualcomm Bluetooth 4.1 type: USB driver: btusb v: 0.8
    bus-ID: 1-7:6 chip-ID: 0b05:1825 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    port: f020 bus-ID: 00:17.0 chip-ID: 8086:2822 rev: class-ID: 0104
Drives:
  Local Storage: total: 2.05 TiB used: 1.5 TiB (73.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 59.68 GiB
    (25.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 59.68
    GiB (25.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 59.68
    GiB (25.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 59.68
    GiB (25.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.27 GiB used: 543 MiB (1.7%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 60.0 C mobo: N/A gpu: nvidia temp: 57 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 315 Uptime: 2h 0m wakeups: 0 Memory: 31.28 GiB used: 8.14 GiB
  (26.0%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1771
  libs: 574 tools: octopi,pamac,paru pm: flatpak pkgs: 0 Shell: fish v: 3.5.1
  running-in: alacritty inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2022-10-23
  Last full system update: 2022-10-23 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

Sorry if this is the wrong place to ask, I have been told to either try here or the arch wiki/forums multiple times so here I am. I will be actively monitoring this thread and will reply asap.

Thank you tons for the help in advance. I do greatly appreciate it.

I'm not a gamer nor a Nvidia user but, given this, maybe try to give a look here:
https://wiki.archlinux.org/title/Vulkan#Nvidia_-_vulkan_is_not_working_and_can_not_initialize
And if necessary also the installation/verification chapters, of course.

3 Likes

Appreciate the reply. I tried this, and my PC straight up would not load garuda anymore. Was able to get it back using Btrfs but same issue persists.

I will continue looking as now im getting tons of Gstreamer errors on a lot of things too which was not present prior.

I will try again and reformat if this doesnt work. Thank you for the reply.

I just noticed this on my Steam beta update notes after I just updated it just now: Steam Community :: Group :: Steam Client Beta
States that they just released an update to fix a crash launching 32 bit Vulkan titles (including DXVK SteamPlay)
Given that it only effects some games for you (and that you could run them in OpenGL instead), this might have been your issue on the prior version.

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.