After update fastfetch does not display anything in terminal anymore

Hello everybody,
I performed an update yesterday and after that fastfetch does not display anything anymore in the terminal. I checked the forum and I found some possible fixes. However I do not understand how to really get it back to work. I receive following error when I am opening a terminal in fish:

Error: failed to parse JSON config file /usr/share/fastfetch/presets/dr460nized at (1, 2 ): no digit after minus sign

Some people suggest to change the fish config file but I do not have one. Some people say I need to change something like yourflags but I do not know what that is and how to change.

Is it possible that one of you could provide me a step by step guide how to get the beautiful garuda konsole back?

thanks a lot

This seems easy (the copy and paste, then possibly change according to your needs).


thanks a lot by I do not know how to do. two questions on that: How do i know what my current-flag is? I also do not have a fastfetch folder in .config. Do I need to create it and just make a config.jsonc file with that content?

Use kate, copy the text in the link and save it as ~/.config/fastfetch/config.jsonc done.

                   .%;888:8898898:                sgs@hypr
                 x;XxXB%89b8:b8%b88:              --------
              .8Xxd                8X:.           OS: Garuda Linux BirdOfPrey Soaring x86_64
            .8Xx;                    8x:.         Host: 82MS (Yoga Slim 7 Pro 14ACH5)
          .tt8x          .d            x88;       Kernel: Linux 6.8.9-AMD-znver3
       .@8x8;          .db:              xx@;     Uptime: 1 hour, 5 mins
     ,tSXX°          .bbbbbbbbbbbbbbbbbbbB8x@;    Packages: 1492 (pacman)[stable]
   .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;    Shell: fish 3.7.1
 ,888S                                     pd!    Display (CSO1402): 2880x1800 @ 90Hz (as 1440x900) [Built-in]
8X88/                                       q     WM: Hyprland (Wayland)
8X88/                                             Theme: Sweet-Dark [GTK2/3/4]
GBB.                                              Icons: BeautyLine [GTK2/3/4]
 x%88        d888@8@X@X@X88X@@XX@@X@8@X.          Font: Noto Music [GTK2/3], Fira Sans (10pt) [GTK4]
   dxXd    dB8b8b8B8B08bB88b998888b88x.           Cursor: Sweet (24px)
    dxx8o                      .@@;.              Terminal: xfce4-terminal 1.1.3
      dx88                   .t@x.                CPU: AMD Ryzen 9 5900HX (16) @ 4,68 GHz
        d:SS@8ba89aa67a853Sxxad.                  GPU: AMD Radeon Vega Series / Radeon Vega Mobile Series @ 0,40 GHz [Integrated]
          .d988999889889899dd.                    Memory: 5,66 GiB / 13,51 GiB (42%)
                                                  Swap: 0 B / 13,51 GiB (0%)
                                                  Disk (/): 35,51 GiB / 123,72 GiB (29%) - btrfs
                                                  Local IP (wlp1s0): *
                                                  Battery: 56% [AC Connected]
                                                  Locale: de_DE.UTF-8

are WM,Font,Swap, …


thanks. But it did not work. I created the file and copied the content into it and restarted the computer and still get the same error:

Is there anything else that I can do?

Actually I wonder if
i need to install garuda from scratch,. It seems I have more issues after the update: Maybe they are all related: the shut down icon is not responding, octopi does not open (seems a library is missing and reinstallation of octopi did not help), some programs crash when starting and the onscreen keyboard closes whemm clicking anywhere. …

Please post your garuda-inxi as requested by the template.

octopi is fixed but not in the repos yet. Just be patient.

thanks a lot and sorry for the confusing. (it is all a little owerhelming)
I will open topics for the other issues.
thanks for the advice with fish. the error disappeared alsthough it does not look as beautiful anymore as before:

here is the garuda-inxi file output:

`perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LC_ALL = (unset),
LC_NAME = "zh_CN.UTF-8",
LC_PAPER = "zh_CN.UTF-8",
LC_TIME = "en_BE.UTF-8",
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
Kernel: 6.9.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ccaaa6c4-1b6e-42b0-b7c4-6dd84c11fd62 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Convertible System: LENOVO product: 82QF v: Yoga 14c ARB7
serial: <superuser required> Chassis: type: 31 v: Yoga 14c ARB7
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0T76479 WIN
serial: <superuser required> part-nu: LENOVO_MT_82QF_BU_idea_FM_Yoga 14c
ARB7 uuid: <superuser required> UEFI: LENOVO v: K5CN40WW date: 04/17/2023
ID-1: BAT0 charge: 53.9 Wh (75.2%) condition: 71.7/71.0 Wh (101.0%)
power: 9.7 W volts: 16.1 min: 15.4 model: LGES L21L4PE0 type: Li-poly
serial: <filter> status: discharging cycles: 70
Info: model: AMD Ryzen 7 6800U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 714 high: 2379 min/max: 400/4768 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 2379
4: 400 5: 400 6: 400 7: 400 8: 1337 9: 1541 10: 400 11: 1375 12: 400
13: 400 14: 400 15: 400 16: 400 bogomips: 86242
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,
DP-2, DP-3, DP-4, DP-5, DP-6, HDMI-A-1, Writeback-1 bus-ID: 33:00.0
chip-ID: 1002:1681 class-ID: 0300 temp: 41.0 C
Device-2: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 04f2:b758
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2240x1400 s-dpi: 96 s-size: 592x370mm (23.31x14.57")
s-diag: 698mm (27.48")
Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0xa195 built: 2020
res: 2240x1400 hz: 60 dpi: 190 gamma: 1.2 size: 300x188mm (11.81x7.4")
diag: 354mm (13.9") ratio: 16:10 modes: max: 2240x1400 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
rembrandt LLVM 17.0.6 DRM 3.57 6.9.1-zen1-1-zen) device-ID: 1002:1681
memory: 1.95 GiB unified: no
API: Vulkan v: 1.3.279 layers: 9 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV REMBRANDT) driver: mesa radv v: 24.0.7-arch1.3
device-ID: 1002:1681 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 33:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 33:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 33:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.9.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
vendor: Lenovo driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 01:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Foxconn / Hon Hai Bluetooth 5.2 Adapter [MediaTek MT7922]
driver: btusb v: 0.8 type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-4:2 chip-ID: 0489:e0d8 class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0000
Device-2: Microsoft Nano Transceiver v1.0 for Bluetooth
driver: hid-generic,usbhid type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
mode: 1.1 bus-ID: 3-2:2 chip-ID: 045e:0745 class-ID: 0300
Local Storage: total: 953.87 GiB used: 126.16 GiB (13.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 33.9 C scheme: GPT
ID-1: / raw-size: 250 GiB size: 250 GiB (100.00%) used: 43.27 GiB (17.3%)
fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:5
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 94.4 MiB (31.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 201.61 GiB size: 201.61 GiB (100.00%)
used: 82.8 GiB (41.1%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:6
ID-4: /var/log raw-size: 250 GiB size: 250 GiB (100.00%)
used: 43.27 GiB (17.3%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:5
ID-5: /var/tmp raw-size: 250 GiB size: 250 GiB (100.00%)
used: 43.27 GiB (17.3%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 13.34 GiB used: 1.07 GiB (8.0%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
System Temperatures: cpu: 43.8 C mobo: 42.0 C gpu: amdgpu temp: 41.0 C
Fan Speeds (rpm): N/A
Memory: total: 16 GiB note: est. available: 13.34 GiB used: 5.15 GiB (38.6%)
Processes: 398 Power: uptime: 37m states: freeze,mem,disk suspend: s2idle
wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
image: 5.31 GiB services: org_kde_powerdevil, power-profiles-daemon,
upowerd Init: systemd v: 255 default: graphical tool: systemctl
Packages: 2301 pm: pacman pkgs: 2275 libs: 607 tools: gnome-software,
octopi, pamac, paru, yay pm: flatpak pkgs: 26 Compilers: clang: 17.0.6
gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2023-12-24
Last full system update: 2024-05-20 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:`

Reboot and check again.

@reni - if Konsole fastfetch is still not working properly for you, here is how I did it:
Open Dolphin (file manager) → go to root (left side, at the bottom) → navigate to the mentioned usr/share/fastfetch/presets/dr460nized → when it opens in the text editor (Kate), remove the text and replace it with the one Sdar provided in the first linked thread (filo linked it). Save it, and it should work, well, at least it did for me.

How does fastfetch decide which config to use? Does it fallback to ./config/fastfetch if the one in usr/share/fastfetch is not present?

I had to replace the dr460nized preset in usr/share as well, the one in .config did not work for me, reboot or not.

The issue has already been fixed and fastfetch was updated yesterday. Did you reboot afterwards?

Reminder to people on older Garuda installations: make sure you have fastfetch from the Extra repo. On one of my machines I noticed I was running some version that wasn’t even in the repos anymore and thus didn’t get the update at all that makes use of the new file type. (so it was failing to load the new one)
In terminal use this command and replace when asked:

sudo pacman -S fastfetch

(wanted to add to the recent discussion here just in case if it helps somebody else on an older install)



I’ve been having the same problem and fail to identify/apply the right solution, if there one jet.
Maybe it is right there and I lack the knowledge to properly understand it or apply it

Someone could be so kind to point me how to fix this in a foolproof fashion. I just want the terminal to look like as default.

Thanks in advance,

Nevermind, Mad solution did the trick for me:

Thanks a lot