After install nvidia driver stuck on loading initial ramdisk

hey there :tophat:
after install my nvidia driver (geforce rtx3060) i stuck in initial ramdisk. i used snapper tool to restore to before installing drivers. please anyone know what should i do? i tried many things but the problem is still on...
i appreciate your help...

DKMS does not have an acceptable release for the new zen kernel.

Load into the Live USB enviroment.
Load chroot
sudo pacman -Syy linux-lts linux-lts-headers
garuda-update

reboot but select the linux-lts kernel in advanced garuda boot options. You can choose to remove the zen kernel until it is working, or just leave it there. You will have to run the linux-lts kernel for the time being, until there is an acceptable dkms release.

1 Like

That's not true.

The hardware configuration GUI currently has a bug that prevents NVIDIA drivers from being correctly applied. Installing a new kernel from the terminal fixes, because it triggers DKMS modules to be recompiled. The actual solution is to install NVIDIA drivers like so: sudo mhwd -a pci nonfree 0300

8 Likes

its not working too. again i stuck in loading initial ramdisk after install driver with sudo mhwd -a pci nonfree 0300

not working

i think im not lucky with garuda...

Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: ASUSTeK driver: nvidia
    v: 520.56.06 alternate: nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 0b:00.0
    chip-ID: 10de:2503 class-ID: 0300

Work fine here on i3wm and KDE dragonized, dual boot with

System:
  Kernel: 6.0.9-AMD

and linux-bore, IIRC :slight_smile:

Please, post your

garuda-inxi

from live ISO.

Post also input and output from terminal as text, too.

Ah, a Laptop
Search for prime etc., I can't help, sorry.

i cant help it i think. i tried many ways but each time i stuck in loading initial ramdisk. anyway thanks for your help im moving...

Yes, it is happening to me also.
You have 3. options:

  1. nouveau drivers (for me, with a GT 710 could be acceptable, for you with a 3060, of course not)
  2. change to a non-zen kernel, or stay in 5.x branch, that is working with nvidia proprietary drivers (at least for me)
  3. try this Video-nvidia-470xx fails on kernel 6.0 - #29 by BunchOfAtoms - Graphics & Display - Manjaro Linux Forum . Read the complete thread to some guidance.

Regards

1 Like

Check if the ibt=off kernel boot parameter helps: see e.g. here how to do it.
To test it once, before making it persistent with the procedure above, when you are in the grub line that you use, press button E, go to the end of the line starting with linux and add ibt=off at the end of the line (with a space before...), then CTRL+x

4 Likes

:heart: thanks mate

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.