After install a new internal ssd is read only

Hey guys,

I've input a new ssd into the pc, used kde partition (Brrfs). After that the ssd was mounted but I have just rights to read.

I try "chgrp plugdev" and "chmod 775" not sure, if tha works on an Arch linux. respectively it does not work. :slight_smile:

so, could u help me plz.


Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=878a71d6-a259-499a-9984-39f4801d6b55 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Micro-Star product: MS-7C37 v: 3.0
serial: <superuser required>
Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0
serial: <superuser required> UEFI: American Megatrends v: H.B0
date: 10/30/2020
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: N/A
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3536 high: 3682 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3271 2: 3326
3: 3598 4: 3591 5: 3592 6: 3589 7: 3601 8: 3492 9: 3591 10: 3230 11: 3596
12: 3599 13: 3595 14: 3584 15: 3588 16: 3599 17: 3682 18: 3594 19: 3218
20: 3555 21: 3602 22: 3576 23: 3600 24: 3600 bogomips: 177599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: Gigabyte driver: nvidia
v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 2d:00.0 chip-ID: 10de:2484 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.57x13.11")
s-diag: 868mm (34.19")
Monitor-1: DP-0 res: 3440x1440 dpi: 87376 size: 1x1mm (0.04x0.04")
diag: 1mm (0.06") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
Device-1: NVIDIA GA104 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2d:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI X570-A PRO
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech [G533 Wireless Headset Dongle] type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.4.2:7
chip-ID: 046d:0a66 class-ID: 0300
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Broadcom BCM4321 802.11a/b/g/n vendor: Apple AirPort Extreme
driver: b43-pci-bridge v: N/A modules: ssb pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 29:00.0 chip-ID: 14e4:4328 class-ID: 0280
Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
bus-ID: 3-3:2 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 3.1 TiB used: 1.67 TiB (53.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Corsair model: Force MP600
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: EGFM11.3
temp: 39.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Sabrent model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFM12.2
temp: 23.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Apple model: HDD HTS541010A9E662
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: B5D0
scheme: MBR
ID-4: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SD8SBAT128G1122
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3000 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Samsung
model: SSD SM871 2.5 7mm 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2D0Q
scheme: GPT
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 77.84 GiB (65.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 77.84 GiB (65.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 77.84 GiB (65.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 77.84 GiB (65.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.78 GiB used: 3 MiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 48 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 486 Uptime: 3h 28m wakeups: 6 Memory: 62.78 GiB
used: 7.66 GiB (12.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1772 lib: 507 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-3):
System install date:     2022-01-20
Last full system update: 2022-04-21
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Welcome :slight_smile:

Search about chown in web or forum, it has probably already been explained a million times.


Thanks for reply. chown change the group or user as I know. How should this help in this case? I used kde partion as the admin user, creat a new partition. So the new partion shuld have the rights by this user.

As u can see, I need a litte more help to understand if possible.


oder geht Deutsch? Wo ich die Flagge sehe?!

1 Like

You're running a graphical user interface, so what could be easier? Right-click on the device using Dolphin, then "Change Ownership to Active User."

I also furnish underwear-changing instructions with Dolphin upon demand.



Thanks again, but that was of course the first thing I've done!

But I can not change anything there! All is gray and I cannot activate or deactivate any options.

Why is your answer so sarcastic. Isn't a forum there to share some of the knowledge of the pros with new users? Instead, you're making fun of the question.

Of course, I tried to find a solution in advance, but sometimes, as a beginner, you don't even know the right question for your own problem.

So, is this a forum where you can get help or do you have to already know everything so that all users can only praise themselves?

Really, this kind of behavior is annoying.

Can you post the output of lsblk -f and identify the drive you want to access?

1 Like

Hello @NiMora!
German is available here: Deutsch - Garuda Linux Forum

in your initial post you wrote about chmod. This is basically for the rights of the files and data.
You need chown for taking over ownership.

sudo chown -R <owner> <group> <your file(s)>

I'd use -R all the time which is the recursive function of this command. If it isn't needed then it wouldn't throw errors to your CLI and if it is needed then it'd do its job.

Refering to your "why isn't this forum friendly":
There is a distinct difference between being friendly and being cuddly. To put it into a slight metaphor.
Garuda is an Arch based Distro and there are a ton of reasons for that. The most popular reason is of course its extreme flexibility which just can be beaten by super extreme Distros like LFS or Gentoo. But with this flexibility the DIY aspect is a major and necessary component as well. Hence newbie questions (especially if they can be solved by reading manuals or arch wiki) ain't the deal and considered help vampirism.

Sure Garuda has pretty comfy tools as you've mentioned but in the end it is an advanced Distro and it is expected to do at least basic research before even asking. Therefore there exists the pre-texted helper in this forum you'll see when you're creating a post every time. And there is the section

  • "which attempts to solve the problem are done",
  • "which sources do you have checked"

and so on. In short - based on the ArchLinux community agreement it is called RTFM (read the manual).
It isn't about being annoying, it is about taking care about non-trivial problems which appear as such.

Welcome in the Forum :smiley:

have a good one,

Bruce :shark:


Right click -> Root actions -> Open in file manager
Right Click -> Change ownership to... (if there is no such thing choose properties and change ownership from there)

1 Like

Just mount your SSD to some directory, then you don't need to change ownership.

To mount your SSD to some directory edit file /etc/fstab. by adding the line

UUID=<your ssd's uuid> <directory where you want to mount ssd> auto nosuid,nodev,nofail,x-gvfs-show 0 0

To know ssd uuid use command

sudo lsblk


sudo blkid

And finally after saving /etc/fstab use command

sudo mount -a

If sudo mount -a gives error then something is wrong in writing command in /etc/fstab and you need to change that accordingly. Or your system will not start.

With the nofail flag the boot should not be broken if the fstab entry is incorrect.


Hello and thanks to all. I solved it on a very unpopular way. I deleted the partion with diskpart on a windows pc, than create a new partition on linux and after that I can use the way, mrvictory discribed.

Thanks again, now I have full access.



Why make it simple when you can make it complicated :smiley:

Please mark the post that contains the solution for you.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.