After every system restart the Thunar first start is slow

After every system restart the thunar first start is sloooowww. For checking what is wrong i started it in terminal and i get this error.


(thunar:2843): Gtk-WARNING **: 19:14:04.112: Attempting to read the recently used resources file at '/home/robi/.local/share/recently-used.xbel', but the parser failed: Failed to open file “/home/robi/.local/share/recently-used.xbel”: Permission denied.
ThunarThumbnailer: Failed to retrieve supported types: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

Some idea how can i fix this?

Thank you.


  Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=095c9f1d-4e23-42b2-aa42-36402880711e rw rootflags=subvol=@
    quiet resume=UUID=4b8a0d61-7df0-445b-9329-0c5cf2f2c346 loglevel=3 ibt=off
  Desktop: Hyprland info: waybar vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Laptop System: Dell product: Vostro 3580 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0PMTCG v: A00 serial: <superuser required> UEFI: Dell
    v: 1.27.0 date: 11/16/2023
  ID-1: BAT0 charge: 29.3 Wh (100.0%) condition: 29.3/42.0 Wh (69.8%)
    volts: 12.6 min: 11.4 model: BYD DELL 1VX1H97 type: Li-ion serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i5-8265U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 8 level: v3 note: check
    built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xF8
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 512 high: 700 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 700 3: 700 4: 400
    5: 700 6: 400 7: 400 8: 400 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: HDMI-A-1,eDP-1 empty: DP-1,HDMI-A-2 bus-ID: 0000:00:02.0
    chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3
    chip-ID: 1bcf:2b98 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: Hyprland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 d-rect: 4480x1080
    display-ID: 1
  Monitor-1: HDMI-A-1 pos: right model: LG (GoldStar) ULTRAWIDE
    serial: <filter> built: 2014 res: 2560x1080 hz: 60 dpi: 112 gamma: 1.2
    scale: 1 size: 677x290mm (26.65x11.42") diag: 628mm (24.7") modes:
    max: 2560x1080 min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: AU Optronics 0x38ed built: 2015
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 scale: 1
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: Vulkan v: 1.3.276 layers: 3 device: 0 type: integrated-gpu name: Intel
    UHD Graphics 620 (WHL GT2) driver: mesa intel v: 23.3.5-arch1.1
    device-ID: 8086:3ea0 surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.5-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 0000:00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 0000:01:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel bus-ID: 0000:02:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: wguk133t state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 0cf3:e009
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
    driver: intel_nvme_remap v: N/A port: 4060 bus-ID: 0000:00:17.0
    chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 1.36 TiB used: 20.13 GiB (1.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: KBG40ZNS256G NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B tech: SSD serial: <filter> fw-rev: 10410106 temp: 22.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: A-Data model: SU630 size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 3R17 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: ST1000LM 024 HN-M101M
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 2AR2 scheme: MBR
  ID-1: / raw-size: 60 GiB size: 60 GiB (100.00%) used: 10.5 GiB (17.5%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /home raw-size: 162.16 GiB size: 162.16 GiB (100.00%)
    used: 9.63 GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 10.5 GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-5: /var/tmp raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 10.5 GiB (17.5%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.63 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.01 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
  System Temperatures: cpu: 61.0 C pch: 55.0 C mobo: 42.0 C
  Fan Speeds (rpm): cpu: 2689
  Processes: 289 Uptime: 20m wakeups: 0 Memory: total: 8 GiB
  available: 7.63 GiB used: 4.24 GiB (55.6%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1455 libs: 421 tools: paru Shell: fish v: 3.7.0
  running-in: foot inxi: 3.3.31
Garuda (2.6.23-1):
  System install date:     2024-01-21
  Last full system update: 2024-02-06
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

And I thought this is a “me” issue!
Yes, Thunar almost takes 5-6 secs after restart (NOT AFTER LOGOUT AND RELOGIN)
Meanwhile, Firedragon takes 2 secs :stuck_out_tongue:
I guess that’s no problem?? (I don’t mind it)

Not a real big deal, but annoying. The second, third start is quick.

1 Like

Permission denied in the home folder?
Check if root is needed.

find $HOME ! -user $USER -type f

If, use

sudo chown -R $USER: $HOME

to remove root.
BTW, thunar works fine here. :slight_smile:

It doesn’t asked root permission.

I run this command just in case. Now i just got GDBus error

ThunarThumbnailer: Failed to retrieve supported types: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

First start still slow.

I tried Thunar on my old laptop with Garuda Dragonized and there is start quickly.

That is normal thuner always did that, for goodness sake people get a life. their used to be a work around written in the arch wiki again get a life read read read do not expect others to do your research for you

1 Like

I don’t expect nobody to do research. Maybe some of us here have limited time (due to job, family, and other commitments).

So, there are no root files in home.

For this new laptop, the bogomips are few. You use also raid and external USB volume /dev/sdb?

First set optimized or performance for govenor, if you need a quick PC, dont use powersave.

Again, I have many PC and thunar open quicker than dolphin.

1 Like

I don’t expect nobody to do research. Maybe some of us here have limited time (due to job, family, and other commitments).

The same goes for the rest of us we all have limited time due to job, family and other comitments? .
But you seem to think your the only one that does not have time time to spent a few mins research. i told you where to find the solution now go and research


So i checked the governor. In my cpu only has powersave and performance. But the performance basically run my all core at max frequency so it is not the best. Also the bogomips doesnt change. See below.

─λ cpupower frequency-info --governors
analyzing CPU 1:
  available cpufreq governors: performance powersave

 ╭─robi@vostro in ~ took 8ms
 ╰─λ garuda-inxi | grep governor
    driver: intel_pstate governor: powersave cores: 1: 600 2: 600 3: 600 4: 600

 ╭─robi@vostro in ~ took 1s
 ╰─λ garuda-inxi | grep bogomips
    4: 1624 5: 1900 6: 1900 7: 1373 8: 1900 bogomips: 28800

 ╭─robi@vostro in ~ took 1s
 ╰─λ sudo cpupower frequency-set --governor performance
[sudo] password for robi:      
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
Setting cpu: 4
Setting cpu: 5
Setting cpu: 6
Setting cpu: 7

 ╭─robi@vostro in ~ as 🧙 took 3s
 ╰─λ garuda-inxi | grep governor
    driver: intel_pstate governor: performance cores: 1: 3732 2: 3686 3: 400

 ╭─robi@vostro in ~ as 🧙 took 1s
 ╰─λ garuda-inxi | grep bogomips
    4: 400 5: 3834 6: 400 7: 3600 8: 3870 bogomips: 28800

I dont use raid. it was a bios setting. I changed it to achi now. Yes " /dev/sdb" is an external usb drive. i disconnected restart and try again, but still slow the first start.

Maybe i just swap for dolphin.

Thanks for pointing out those things.

Hey man. I don’t know who you are, but i don’t accept the tone in which you responded.

I have been using Garuda Linux as my primary system for over a year now. During this time, I’ve mostly just been reading through the forums.
While I working in IT for several years, my Linux knowledge is currently limited. I only recently created an account to seek help with some new things. I believe that is what this website is for.

In this tone and way how you responded to me, you can write for every 2-3 person in the forum, But for some reason i don’t see your respond in other tocpics. ( or just i don’t saw yet. )

So please do me a favor! Don’t even waste my time and yours by writing to me if you can’t use a normal tone with respect.

Thank you.

And don’t try to talk down to me you joined Nov 23 i joined April 2020 And have used Linux for over 25 years enough said. I gave you good advise when all you want to do is exect others to sort your problem for you.
IT was you that stated : Maybe some of us here have limited time (due to job, family, and other commitments).: if thats the case you should not use Linux but pay Mac instead for support.


MY research took all of 10-frigging-seconds.

Some folks whine, some folks do.


I have marked @Bro’s response the solution because it is the most technically relevant suggestion, and seems most likely to help folks searching in the forum for a solution in the future. @korobert feel free to uncheck it if you feel it does not resolve your issue.

Also, don’t take it too personally when some of the more experienced users throw the old “RTFM” at you. I don’t want to speak for anyone else, but I’m pretty sure they don’t mean any offense. :wink:


While that is unusually slow, know that the first start up of Thunar starts the daemon, and restarts are nearly instantaneous.

Incidentally, to make changes in Thunar, it may be necessary to run thunar -q to clear out the daemon, then do a restart…

Never know when you might need this!


This one worked for me! (It never bothered me much but guess I’ll save some more secs that went into launching)

I don’t know if you’re referring to me or not. I don’t have a problem with researching and finding solutions, but the way he wrote is not acceptable, at least for me.

Thanks. i already found it. It is woks now.

Yes, this was the solution. Now from 25-30sec change the start to 1 sec

No worries, I don’t take it personally, just simple i don’t accept the tone how he wrote.

Good to now this, I will keep in mind. Thank you.

It is done same.
In the past few days i tested power-profile-daemons and auto-cpufrq. Definitely auto-cpufreq a better in my case. This automatically change the governor is well based on that the laptop is charging or run from battery. Just needed change the lowest frequency in the settings file.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.