Add - Remove software not working

Hello Garuda users.

since few days now (I can't say when because I use this feature realy few but some times I really need it) the utilitary package manager interface under garuda welcome interface is not working.

Indeed, when I try to open the Add/Remove software tool, the garuda welcome frame flash and nothing append next.

Could you help me to understand what append ? plez

System
Kernel: 6.0.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f327471a-c329-462b-a1dc-fca7bb7580b2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20TH001AFR v: ThinkPad P1 Gen 3
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20TH001AFR v: SDK0T08861 WIN
serial: <superuser required> UEFI: LENOVO v: N2VET26W (1.11 )
date: 11/16/2020
Battery:
ID-1: BAT0 charge: 34.7 Wh (48.2%) condition: 72.0/80.4 Wh (89.6%)
volts: 14.3 min: 15.4 model: SMP 5B10X19049 type: Li-poly serial: <filter>
status: discharging cycles: 172
CPU:
Info: model: Intel Core i9-10885H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3331 high: 4983 min/max: 800/5300 scaling:
driver: intel_pstate governor: performance cores: 1: 4099 2: 4379 3: 2400
4: 2400 5: 2400 6: 3665 7: 3979 8: 2400 9: 2400 10: 4983 11: 4002 12: 3422
13: 3175 14: 3695 15: 3505 16: 2400 bogomips: 76800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:1fb8 class-ID: 0300
Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-8:2 chip-ID: 04f2:b6cb class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 model-id: CSO 0x1500 built: 2019 res: 1920x1080 hz: 60
dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 3840x2160
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel UHD Graphics (CML GT2)
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
Sound API: ALSA v: k6.0.9-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
IF-ID-2: veth1372eaf state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-3: vethefc81ed state: up speed: 10000 Mbps duplex: full
mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 253.7 GiB (26.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 5108AGLA temp: 38.9 C scheme: GPT
Partition:
ID-1: / raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 253.67 GiB (43.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 33.6 MiB (13.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 253.67 GiB (43.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 253.67 GiB (43.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 253.67 GiB (43.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.98 GiB used: 10.68 GiB (34.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 65.0 C pch: 53.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 3554 fan-2: 3382
Info:
Processes: 431 Uptime: 38m wakeups: 1592 Memory: 30.98 GiB
used: 16.22 GiB (52.3%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1589
pm: pacman pkgs: 1579 libs: 372 tools: octopi,paru pm: snap pkgs: 10
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2021-11-16
Last full system update: 2022-11-23 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Add/Remove software should launch octopi. It works fine here (I'm on Dr460nized), from Garuda Welcome, from Latte-dock, from Application Launcher, etc.
Does it start there from terminal? Or what error messages you get?

/usr/bin/octopi

Last but not least:

Reboot (although I see the problem is not new). You never can say...

3 Likes

I haven't try it but when I run manually octopy from latte-dock or by Garuda Welcome the result is the same. I have nothing.

If I try a terminal launch I have this error and nothing else, the program shutdown and the prompt come back :
octopi: symbol lookup error: octopi: undefined symbol: _ZN11QTermWidget20setScrollBarPositionENS_17ScrollBarPositionE

About linux garuda software, I update it every day at morning.

Try reinstalling octopi:

sudo pacman -S octopi
3 Likes

Indeed I must try this since the start. I was blocked by conflict with package octopi-dev and alpm_octopi_utils-dev when trying to reinstall octopi. With manual remove of this two package I was able to reinstall octopi correctly.

Thank

1 Like

The error message from terminal made the difference.
It appeared recently to another user and it was solved rebuilding the package in the chaotic AUR (due to updated dependencies). If the version remained the same, it was not triggered as to be updated. In those cases a reinstall forces the... reinstall (or remove and install, of course).

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.