Add/Remove Program is not opening at all

All issues related to Garuda Linux and its assistance

Add/remove program is not working

What is the output of pamac in the terminal?

pamac: error while loading shared libraries: libalpm.so.12: cannot open shared object file: No such file or directory

It won't work because Add/Remove Programs (Also called pamac) depends on libalpm (version 12) which has a newer release, but pamac has not caught up with changes in the new release yet (the command line tool pacman has caught up with the newer version of libalpm and has no problems).

So to install stuff, you can either use paru or pacman on the command line, or use a graphical application called bauh (command to install:

paru -S bauh --skipreview

). Any other solution which claims to get Add Remove Programs (also called pamac) working does so by downgrading libalpm pacman (the downgraded version comes with an older version of libalpm). This will take away the parallel downloads feature :slightly_smiling_face:.

Edit: Edited to clarify that the package downgrade is for pacman. Thanks @jonathon

paru -S bauh --skipreview

i have done this but it is still not opening

bauh is a different program. It is intended in this case as a replacement for Pamac, which is "Add/remove software".

2 Likes

It is a replacement for Add/Remove Programs. It does not fix it :slightly_smiling_face:. You have to open bauh to install stuff.

The whole reason Add/Remove programs is not working is because it uses a package which has released a newer version, but the developers have not yet incorporated the new changes. Any solution which claims to get the program working downgrades libalpm which takes away the parallel downloads feature. So we just have to wait and use a replacement application like bauh until the developers fix it and release a new version

4 Likes

Add another to the the dozens of related solved threads for the search invalids to again ignore.

Solved and locked.

This is partially correct. There is no such package as libalpm, this comes as part of the pacman package.

Pamac will build against pacman 5.2.2 but not pacman 6.0.0.

Hence, currently-built versions of Pamac require the older libalpm library that is part of the pacman 5.2.2 package. If you have pacman 6.0.0 then the libalpm library is too new. However, you can install libalpm12 which provides the library version Pamac currently expects.

If the "solution" involves downgrading pacman, then yes.

If the "solution" involves installing libalpm12, then no.

3 Likes